summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-appcontroller_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-appcontroller_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-appcontroller_git.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-appcontroller_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-appcontroller_git.bb
new file mode 100644
index 0000000..82f02be
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-appcontroller_git.bb
@@ -0,0 +1,55 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Boot to Qt Appcontroller"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://main.cpp;md5=f25c7436dbc72d4719a5684b28dbcf4b;beginline=1;endline=17"
33
34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
36
37QT_GIT_PROJECT = "qt-apps"
38
39SRC_URI += "file://appcontroller.conf"
40
41SRCREV = "5ab7fdbf0845c40418272bafa565295511055d3b"
42
43DEPENDS = "qtbase"
44
45do_configure_append() {
46 sed -i -e '/^platform=/d' ${WORKDIR}/appcontroller.conf
47 echo platform=${MACHINE} >> ${WORKDIR}/appcontroller.conf
48}
49
50do_install_append() {
51 install -m 0755 -d ${D}${sysconfdir}
52 install -m 0755 ${WORKDIR}/appcontroller.conf ${D}${sysconfdir}/
53}
54
55FILES_${PN} += "${sysconfdir}/appcontroller.conf"