summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/automotive
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/automotive')
-rw-r--r--meta-boot2qt/recipes-qt/automotive/gammaray_git.bb30
-rw-r--r--meta-boot2qt/recipes-qt/automotive/multiscreen-demo/automotivedemo.service12
-rw-r--r--meta-boot2qt/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service13
-rw-r--r--meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb67
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune-ui/neptune.service11
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune-ui_git.bb73
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qmllive-target/qmllive-target.patch19
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qmllive-target_git.bb50
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb70
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch29
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb110
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtwebbrowser_git.bb45
12 files changed, 529 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
new file mode 100644
index 0000000..7466822
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
@@ -0,0 +1,30 @@
1SUMMARY = "GammaRay Qt introspection probe"
2HOMEPAGE = "http://www.kdab.com/gammaray"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=a5b28ec9718d4516f7a621cd0232afc1"
6
7inherit cmake_qt5
8
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10
11BRANCH = "5.9"
12SRCREV = "87656b9c344077d84682b53ba3e4676e18b57f9e"
13PV = "${BRANCH}+git${SRCPV}"
14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \
16 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OECMAKE += " -DGAMMARAY_BUILD_UI=OFF -DGAMMARAY_CORE_ONLY_LAUNCHER=ON"
21
22FILES_${PN}-dev += " \
23 /usr/lib/cmake/* \
24 /usr/mkspecs/modules/* \
25"
26FILES_${PN}-dbg += " \
27 /usr/lib/.debug/* \
28 /usr/lib/gammaray/*/*/.debug \
29 /usr/lib/gammaray/*/*/styles/.debug \
30"
diff --git a/meta-boot2qt/recipes-qt/automotive/multiscreen-demo/automotivedemo.service b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo/automotivedemo.service
new file mode 100644
index 0000000..af23213
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo/automotivedemo.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=AutomotiveDemo
3After=dbus.service dbus-session.service systemd-user-sessions.service
4Conflicts=neptune.service
5
6[Service]
7ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
8Restart=on-failure
9WorkingDirectory=/opt/automotivedemo
10
11[Install]
12WantedBy=multi-user.target
diff --git a/meta-boot2qt/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service
new file mode 100644
index 0000000..1025cc1
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service
@@ -0,0 +1,13 @@
1[Unit]
2Description=AutomotiveDemo
3After=dbus.service dbus-session.service systemd-user-sessions.service
4Conflicts=neptune.service
5
6[Service]
7ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
8Restart=on-failure
9WorkingDirectory=/opt/automotivedemo
10Environment=QT_QPA_EGLFS_KMS_CONFIG=kms_config.json
11
12[Install]
13WantedBy=multi-user.target
diff --git a/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb
new file mode 100644
index 0000000..c81adee
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb
@@ -0,0 +1,67 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Multiscreen Demo"
31LICENSE = "GPLv3 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073"
33
34inherit qt5-module systemd
35require recipes-qt/qt5/qt5-git.inc
36
37QT_GIT_PROJECT = "qt-apps"
38QT_MODULE_BRANCH = "master"
39
40SRC_URI += "\
41 git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets \
42 file://automotivedemo.service \
43 "
44
45SRCREV_multiscreen-demo = "6d02e36c4280cee5b0c31323016ae666c73afef4"
46SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264"
47
48SRCREV_FORMAT = "multiscreen-demo_assets"
49
50DEPENDS = "qtbase qtdeclarative qt3d"
51RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard"
52
53EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt"
54
55do_install_append() {
56 rm ${D}/opt/automotivedemo/start.sh
57
58 install -d ${D}${systemd_system_unitdir}
59 install -m 0644 ${WORKDIR}/automotivedemo.service ${D}${systemd_system_unitdir}/
60}
61
62FILES_${PN} += "\
63 /opt/automotivedemo \
64 "
65
66SYSTEMD_SERVICE_${PN} = "automotivedemo.service"
67SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune-ui/neptune.service b/meta-boot2qt/recipes-qt/automotive/neptune-ui/neptune.service
new file mode 100644
index 0000000..16b6a1f
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/neptune-ui/neptune.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Neptune
3After=dbus.service dbus-session.service systemd-user-sessions.service
4
5[Service]
6ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
7Restart=on-failure
8WorkingDirectory=/usr/neptune-ui
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune-ui_git.bb
new file mode 100644
index 0000000..5898424
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/neptune-ui_git.bb
@@ -0,0 +1,73 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Copyright (C) 2018 Pelagicore AG.
5## Contact: https://www.qt.io/licensing/
6##
7## This file is part of the Boot to Qt meta layer.
8##
9## $QT_BEGIN_LICENSE:GPL$
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at https://www.qt.io/contact-us.
17##
18## GNU General Public License Usage
19## Alternatively, this file may be used under the terms of the GNU
20## General Public License version 3 or (at your option) any later version
21## approved by the KDE Free Qt Foundation. The licenses are as published by
22## the Free Software Foundation and appearing in the file LICENSE.GPL3
23## included in the packaging of this file. Please review the following
24## information to ensure the GNU General Public License requirements will
25## be met: https://www.gnu.org/licenses/gpl-3.0.html.
26##
27## $QT_END_LICENSE$
28##
29############################################################################
30
31DESCRIPTION = "Neptune IVI UI"
32LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
33LIC_FILES_CHKSUM = "\
34 file://LICENSE.GPL3;md5=c41b4a3e669de55dfe304b8376b04a82 \
35 file://imports/assets/fonts/OFL.txt;md5=a729250f3548d9d2deab9bfeb8a7ad51 \
36"
37
38inherit qt5-module systemd
39require recipes-qt/qt5/qt5-git.inc
40
41QT_GIT_PROJECT = "qt-apps"
42
43SRC_URI += " \
44 file://neptune.service \
45 "
46
47SRCREV = "7b64754e5d1aa3ea3b63347bc5637bae9795e193"
48
49DEPENDS = "qtbase qtdeclarative qttools-native qtquickcontrols2 qtapplicationmanager"
50RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \
51 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
53
54do_install_append() {
55 install -m 0755 -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
57
58 # Move the fonts to the system-wide font location
59 install -m 0755 -d ${D}${datadir}/fonts/ttf/
60 mv ${D}/usr/neptune-ui/imports/assets/fonts/*.ttf ${D}${datadir}/fonts/ttf/
61 rm -rf ${D}/usr/neptune-ui/imports/assets/fonts/
62}
63
64PACKAGES =+ "${PN}-apps"
65RRECOMMENDS_${PN} += "${PN}-apps"
66
67FILES_${PN}-apps += "/usr/neptune-ui/apps"
68FILES_${PN} += "\
69 /usr/neptune-ui \
70 ${datadir}/fonts/ttf \
71 "
72
73SYSTEMD_SERVICE_${PN} = "neptune.service"
diff --git a/meta-boot2qt/recipes-qt/automotive/qmllive-target/qmllive-target.patch b/meta-boot2qt/recipes-qt/automotive/qmllive-target/qmllive-target.patch
new file mode 100644
index 0000000..e3f81fa
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qmllive-target/qmllive-target.patch
@@ -0,0 +1,19 @@
1diff --git a/runtime.pro b/runtime.pro
2index 73dd6d7..e569b23 100644
3--- a/runtime.pro
4+++ b/runtime.pro
5@@ -1,5 +1,4 @@
6 TARGET = qmlliveruntime
7-DESTDIR = ../../bin
8
9 QT *= widgets quick
10 osx: CONFIG -= app_bundle
11@@ -14,6 +13,6 @@ include(../src.pri)
12 RESOURCES += \
13 qml.qrc
14
15-
16-
17+target.path += /usr/bin
18+INSTALLS += target
19
diff --git a/meta-boot2qt/recipes-qt/automotive/qmllive-target_git.bb b/meta-boot2qt/recipes-qt/automotive/qmllive-target_git.bb
new file mode 100644
index 0000000..54f1188
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qmllive-target_git.bb
@@ -0,0 +1,50 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QML Live target runtime"
31
32LICENSE = "GPL-3.0"
33LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
34
35inherit qmake5
36require recipes-qt/qt5/qt5-git.inc
37
38QT_GIT_PROJECT = "qt-apps"
39QT_MODULE = "qmllive"
40QT_MODULE_BRANCH = "master"
41
42SRC_URI += " \
43 file://qmllive-target.patch \
44 "
45
46SRCREV = "d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
47
48S = "${WORKDIR}/git/src/runtime"
49
50DEPENDS = "qtbase qtdeclarative"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
new file mode 100644
index 0000000..ae66e8a
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -0,0 +1,70 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=ff238b33ff354a0d8d79851a9c061717"
33
34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc
36
37SRCREV = "5581e400c95a1ff736c55c9d93bd451302970c11"
38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
41
42RDEPENDS_${PN} = "libcrypto ${PN}-tools"
43RDEPENDS_${PN}_remove_mingw32 = "libcrypto"
44
45EXTRA_QMAKEVARS_PRE += "\
46 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
47 -config install-prefix=/usr \
48 -config systemd-workaround \
49 -config hardware-id=neptune \
50 "
51
52do_install_append() {
53 install -m 0755 -d ${D}/opt/am/
54 install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/
55}
56
57FILES_${PN} += "\
58 /opt/am \
59 "
60
61BBCLASSEXTEND += "nativesdk"
62
63# nativesdk-qtdeclarative is added only to make build deterministic, can be removed once
64# there is a configure option to disable its usage.
65DEPENDS_class-nativesdk = "qtbase nativesdk-qtdeclarative nativesdk-glibc-locale nativesdk-libarchive"
66DEPENDS_class-nativesdk_remove_mingw32 = "nativesdk-glibc-locale nativesdk-libarchive"
67
68EXTRA_QMAKEVARS_PRE_class-nativesdk = "\
69 -config tools-only \
70 "
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch b/meta-boot2qt/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch
new file mode 100644
index 0000000..9f6c0c0
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch
@@ -0,0 +1,29 @@
1From b4ed8c9d4a391771cba485bfa685147126260dc2 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Thu, 7 Sep 2017 10:24:11 +0300
4Subject: [PATCH] Use QT_HOST_BINS/get for getting correct path
5
6Patch QT_HOST_BINS same way as is done it qtbase for getting
7the EffectivePath instead of installation path.
8
9Change-Id: I3e9c04019c432e182dcb5c0898275173f20de1e2
10---
11 mkspecs/features/ivigenerator.prf | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/mkspecs/features/ivigenerator.prf b/mkspecs/features/ivigenerator.prf
15index 65c497e..7634355 100644
16--- a/mkspecs/features/ivigenerator.prf
17+++ b/mkspecs/features/ivigenerator.prf
18@@ -31,9 +31,9 @@ QFACE_YAML = $$QFACE_ABS_PWD/$${QFACE_BASE_NAME}.yaml
19 OTHER_FILES += $$QFACE_FILE
20
21 # Detect whether we are using the feature inside the qtivi repository
22-VIRTUALENV_PATH = $$[QT_HOST_BINS]/ivigenerator/qtivi_qface_virtualenv
23+VIRTUALENV_PATH = $$[QT_HOST_BINS/get]/ivigenerator/qtivi_qface_virtualenv
24 INTERNAL_VIRTUALENV_PATH = $$QTIVI_BUILD_ROOT/src/tools/ivigenerator/qtivi_qface_virtualenv
25-IVI_GENERATOR_PATH = $$[QT_HOST_BINS]/ivigenerator
26+IVI_GENERATOR_PATH = $$[QT_HOST_BINS/get]/ivigenerator
27 QTEST_ENVIRONMENT = $$upper($$(QTEST_ENVIRONMENT))
28
29 # Try to use the internal virtualenv when building qtivi
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
new file mode 100644
index 0000000..5cbf131
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -0,0 +1,110 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt IVI"
31LICENSE = "(GFDL-1.3 & BSD & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
33 file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
34 file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
35 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
36 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02"
37
38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native"
39DEPENDS_class-native = "qtbase"
40DEPENDS_class-nativesdk = "qtbase"
41
42inherit qt5-module
43inherit python3native
44require recipes-qt/qt5/qt5-git.inc
45
46QT_MODULE_BRANCH_QFACE = "upstream/develop"
47
48SRC_URI += " \
49 ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \
50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
51"
52
53SRCREV_qtivi = "8d482b27c6c0c2b664104fd777ddee92652ab65c"
54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8"
55SRCREV = "${SRCREV_qtivi}"
56SRCREV_FORMAT = "qtivi_qface"
57
58PACKAGECONFIG ?= "taglib ivigenerator"
59PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
60PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon"
61PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only"
62# For cross-compiling tell qtivi to use the system-ivigenerator, which is installed by the native recipe"
63PACKAGECONFIG[ivigenerator] = "QMAKE_EXTRA_ARGS+=-system-ivigenerator"
64PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,python3 python3-virtualenv"
65PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only"
66PACKAGECONFIG[simulator] = "QMAKE_EXTRA_ARGS+=-feature-simulator,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtsimulator"
67PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtsimulator"
68
69PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native"
70PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
71PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only"
72
73ALLOW_EMPTY_${PN}-tools = "1"
74
75EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}"
76
77set_python_paths() {
78 # Otherwise pip might cache or reuse something from our home folder
79 export HOME="${STAGING_DATADIR_NATIVE}"
80 # This is needed as otherwise the virtualenv tries to use the libs from the host
81 export LD_LIBRARY_PATH="${STAGING_LIBDIR_NATIVE}"
82 # Let qtivi use the python3-native binaries
83 export PYTHON3_PATH="${STAGING_BINDIR_NATIVE}/python3-native"
84}
85do_compile_prepend() {
86 set_python_paths
87}
88do_install_prepend() {
89 set_python_paths
90}
91
92# This needs a modified python3 recipe which copies the binary into a path where this recipe can pick it up
93# This is needed to provide a proper executable using the correct interpreter in the SDK.
94# See https://bugreports.qt.io/browse/AUTOSUITE-176
95do_install_append_class-nativesdk() {
96 export IVIGENERATOR_ENABLED="${@bb.utils.contains("PACKAGECONFIG", "ivigenerator-native", "1", "0", d)}"
97
98 if [ "${IVIGENERATOR_ENABLED}" = "1" ]; then
99 cp ${STAGING_BINDIR}/qt5/python3* ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/
100 rm -f ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
101 ln -sf python3 ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
102 fi
103}
104
105
106BBCLASSEXTEND += "native nativesdk"
107
108INSANE_SKIP_${PN}_class-native = "already-stripped"
109INSANE_SKIP_${PN}_class-nativesdk = "already-stripped"
110INSANE_SKIP_${PN}-tools_class-nativesdk = "staticdev"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtwebbrowser_git.bb b/meta-boot2qt/recipes-qt/automotive/qtwebbrowser_git.bb
new file mode 100644
index 0000000..9cc0d37
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qtwebbrowser_git.bb
@@ -0,0 +1,45 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Web Browser"
31LICENSE = "GPL-3.0"
32LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6"
33
34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
36
37QT_GIT_PROJECT = "qt-apps"
38QT_MODULE_BRANCH = "dev"
39
40SRCREV = "023733af5523a5ad84359926224fa106001215f4"
41
42DEPENDS = "qtbase qtdeclarative qtwebengine"
43
44FILES_${PN} += "/data/user/qt/qtwebbrowser-app"
45FILES_${PN}-dbg += "/data/user/qt/qtwebbrowser-app/.debug"