summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/automotive/qtivi_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 5cbf131..5c17935 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -37,7 +37,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
37 37
38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native" 38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native"
39DEPENDS_class-native = "qtbase" 39DEPENDS_class-native = "qtbase"
40DEPENDS_class-nativesdk = "qtbase" 40DEPENDS_class-nativesdk = "qtbase qtivi-native"
41 41
42inherit qt5-module 42inherit qt5-module
43inherit python3native 43inherit python3native
@@ -50,12 +50,12 @@ SRC_URI += " \
50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \ 50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
51" 51"
52 52
53SRCREV_qtivi = "8d482b27c6c0c2b664104fd777ddee92652ab65c" 53SRCREV_qtivi = "8658258f2f8d8dac3327a870573dc046029b74bc"
54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8" 54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8"
55SRCREV = "${SRCREV_qtivi}" 55SRCREV = "${SRCREV_qtivi}"
56SRCREV_FORMAT = "qtivi_qface" 56SRCREV_FORMAT = "qtivi_qface"
57 57
58PACKAGECONFIG ?= "taglib ivigenerator" 58PACKAGECONFIG ?= "taglib ivigenerator remoteobjects"
59PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib" 59PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
60PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon" 60PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon"
61PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only" 61PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only"
@@ -65,8 +65,10 @@ PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,python
65PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only" 65PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only"
66PACKAGECONFIG[simulator] = "QMAKE_EXTRA_ARGS+=-feature-simulator,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtsimulator" 66PACKAGECONFIG[simulator] = "QMAKE_EXTRA_ARGS+=-feature-simulator,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtsimulator"
67PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtsimulator" 67PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtsimulator"
68PACKAGECONFIG[remoteobjects] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtremoteobjects"
69PACKAGECONFIG[remoteobjects-native] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtremoteobjects"
68 70
69PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native" 71PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native remoteobjects-native"
70PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}" 72PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
71PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only" 73PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only"
72 74