summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-graphics/fonts/ttf-devanagari_2.94.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-graphics/fonts/ttf-devanagari_2.94.0.bb')
-rw-r--r--meta-boot2qt/recipes-graphics/fonts/ttf-devanagari_2.94.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-graphics/fonts/ttf-devanagari_2.94.0.bb b/meta-boot2qt/recipes-graphics/fonts/ttf-devanagari_2.94.0.bb
new file mode 100644
index 0000000..ee0ea06
--- /dev/null
+++ b/meta-boot2qt/recipes-graphics/fonts/ttf-devanagari_2.94.0.bb
@@ -0,0 +1,53 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "Lohit Devanagari Fonts"
31SECTION = "fonts"
32HOMEPAGE = "https://fedorahosted.org/lohit/"
33LICENSE = "OFL-1.1"
34LIC_FILES_CHKSUM = "file://${WORKDIR}/lohit-devanagari-ttf-${PV}/OFL.txt;md5=7dfa0a236dc535ad2d2548e6170c4402"
35
36INHIBIT_DEFAULT_DEPS = "1"
37
38inherit allarch fontcache
39
40SRC_URI = "https://releases.pagure.org/lohit/lohit-devanagari-ttf-${PV}.tar.gz"
41
42SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8"
43SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353"
44
45do_install() {
46 install -m 0755 -d ${D}${datadir}/fonts/truetype/lohit
47 install -m 0755 -d ${D}${sysconfdir}/fonts/conf.d/
48 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/66-lohit-devanagari.conf ${D}${sysconfdir}/fonts/conf.d/
49 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/Lohit-Devanagari.ttf ${D}${datadir}/fonts/truetype/lohit
50}
51
52PACKAGES = "${PN}"
53FILES_${PN} += "${datadir}/fonts/truetype/lohit"