summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb')
-rw-r--r--meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb
new file mode 100644
index 0000000..1eb2652
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb
@@ -0,0 +1,65 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "VirtualBox Guest Additions for Linux: mount"
31LICENSE = "GPLv2"
32LIC_FILES_CHKSUM = "file://${WORKDIR}/VirtualBox-${PV}/COPYING;md5=e197d5641bb35b29d46ca8c4bf7f2660"
33
34SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2 \
35 file://mount-vboxsf.sh \
36 file://mount-vboxsf.service \
37 "
38
39SRC_URI[md5sum] = "cc053340f88922a11ad9d4fab56557bd"
40SRC_URI[sha256sum] = "ea9569ec16cd6202ee61bcadb2506d31ac12fd343adb91565773a05eaaea9a36"
41
42S = "${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/sharedfolders"
43
44do_compile() {
45 ${CC} ${LDFLAGS} mount.vboxsf.c vbsfmount.c -o mount.vboxsf
46}
47
48do_install() {
49 install -m 0755 -d ${D}${bindir}/
50 install -m 0755 mount.vboxsf ${D}${bindir}/
51 install -m 0755 ${WORKDIR}/mount-vboxsf.sh ${D}${bindir}/
52
53 install -m 0755 -d ${D}${sysconfdir}/init.d
54 ln -s ${bindir}/mount-vboxsf.sh ${D}${sysconfdir}/init.d/
55
56 install -m 0755 -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/mount-vboxsf.service ${D}${systemd_unitdir}/system/
58}
59
60INITSCRIPT_NAME = "mount-vboxsf.sh"
61INITSCRIPT_PARAMS = "defaults 33"
62
63SYSTEMD_SERVICE_${PN} = "mount-vboxsf.service"
64
65inherit update-rc.d systemd