summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt')
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb6
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb6
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb6
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb2
4 files changed, 10 insertions, 10 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
index 1afeb7e..8d63166 100644
--- a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
@@ -55,11 +55,11 @@ python remove_qt_from_rootfs() {
55 import subprocess 55 import subprocess
56 56
57 # remove qtbase and all dependent packages 57 # remove qtbase and all dependent packages
58 image_rootfs = d.getVar('IMAGE_ROOTFS', True) 58 image_rootfs = d.getVar('IMAGE_ROOTFS')
59 opkg_conf = d.getVar("IPKGCONF_TARGET", True) 59 opkg_conf = d.getVar("IPKGCONF_TARGET")
60 opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg") 60 opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg")
61 opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs) 61 opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs)
62 opkg_args += d.getVar("OPKG_ARGS", True) 62 opkg_args += d.getVar("OPKG_ARGS")
63 63
64 cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \ 64 cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \
65 (opkg_cmd, opkg_args, 'qtbase') 65 (opkg_cmd, opkg_args, 'qtbase')
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
index f115070..fe2ab16 100644
--- a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
@@ -38,11 +38,11 @@ S = "${WORKDIR}"
38 38
39inherit qbsp 39inherit qbsp
40 40
41PV := "${@d.getVar('PV', True).split('+')[0]}" 41PV := "${@d.getVar('PV').split('+')[0]}"
42 42
43VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" 43VERSION_SHORT = "${@d.getVar('PV').replace('.','')}"
44QBSP_NAME = "Automotive ${PV}" 44QBSP_NAME = "Automotive ${PV}"
45QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" 45QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}"
46QBSP_INSTALLER_COMPONENT = "automotive.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" 46QBSP_INSTALLER_COMPONENT = "automotive.${VERSION_SHORT}.yocto.${QBSP_MACHINE}"
47QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}" 47QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}"
48 48
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
index a599e23..c85d3ba 100644
--- a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
@@ -38,11 +38,11 @@ S = "${WORKDIR}"
38 38
39inherit qbsp 39inherit qbsp
40 40
41PV := "${@d.getVar('PV', True).split('+')[0]}" 41PV := "${@d.getVar('PV').split('+')[0]}"
42 42
43VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" 43VERSION_SHORT = "${@d.getVar('PV').replace('.','')}"
44QBSP_NAME = "Boot2Qt ${PV}" 44QBSP_NAME = "Boot2Qt ${PV}"
45QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" 45QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}"
46QBSP_INSTALLER_COMPONENT = "embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" 46QBSP_INSTALLER_COMPONENT = "embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}"
47QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}" 47QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}"
48 48
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
index 2adad90..79749fc 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
@@ -34,7 +34,7 @@ PR = "r0"
34inherit nativesdk packagegroup 34inherit nativesdk packagegroup
35 35
36python __anonymous() { 36python __anonymous() {
37 overrides = d.getVar("OVERRIDES", True).split(":") 37 overrides = d.getVar("OVERRIDES").split(":")
38 if "mingw32" not in overrides: 38 if "mingw32" not in overrides:
39 d.appendVar("OVERRIDES", ":linux") 39 d.appendVar("OVERRIDES", ":linux")
40} 40}