summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt')
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb55
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb50
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb39
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb41
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb42
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch82
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/0002-Disable-ltcg-for-host_build.patch (renamed from meta-boot2qt-distro/recipes-qt/qt5/qtbase/0015-Disable-ltcg-for-host_build.patch)6
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend3
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch9
9 files changed, 249 insertions, 78 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb
new file mode 100644
index 0000000..25bfb4d
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb
@@ -0,0 +1,55 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt Automation Qt5 image"
31LICENSE = "The-Qt-Company-Commercial"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
33
34DEPLOY_CONF_TYPE = "Qt for Automation ($QT_VERSION)"
35
36IMAGE_FEATURES += "\
37 package-management \
38 ssh-server-dropbear \
39 tools-debug \
40 debug-tweaks \
41 hwcodecs \
42 "
43
44inherit core-image qbsp-image
45inherit consistent_timestamps
46
47IMAGE_INSTALL += "\
48 packagegroup-b2qt-embedded-base \
49 packagegroup-b2qt-embedded-tools \
50 ${@bb.utils.contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
51 ${@bb.utils.contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
52 packagegroup-b2qt-qt5-modules \
53 packagegroup-b2qt-embedded-addons \
54 packagegroup-b2qt-automation-addons \
55 "
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb
new file mode 100644
index 0000000..16a1530
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb
@@ -0,0 +1,50 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Meta task for QBSP creation"
31
32LICENSE = "The-Qt-Company-Commercial"
33LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
34
35# get Qt version number
36require recipes-qt/qt5/qt5-git.inc
37S = "${WORKDIR}"
38
39inherit qbsp
40
41PV := "${@d.getVar('PV').split('+')[0]}"
42
43VERSION_SHORT = "${@d.getVar('PV').replace('.','')}"
44QBSP_NAME = "Automation ${PV}"
45QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}"
46QBSP_INSTALLER_COMPONENT = "automation.${VERSION_SHORT}.yocto.${QBSP_MACHINE}"
47QBSP_INSTALL_PATH = "/${PV}/Automation/${MACHINE}"
48
49QBSP_SDK_TASK = "meta-toolchain-b2qt-automation-qt5-sdk"
50QBSP_IMAGE_TASK = "b2qt-automation-qt5-image"
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb
new file mode 100644
index 0000000..8cd0d04
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb
@@ -0,0 +1,39 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
31
32LICENSE = "The-Qt-Company-Commercial"
33LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
34
35inherit populate_b2qt_qt5_sdk
36
37TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host"
38TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \
39 packagegroup-b2qt-automation-qt5-toolchain-target"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb
new file mode 100644
index 0000000..d90e1b9
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb
@@ -0,0 +1,41 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Automation specific Qt packages"
31LICENSE = "The-Qt-Company-Commercial"
32
33inherit packagegroup
34
35PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
36
37RDEPENDS_${PN} += " \
38 qtmqtt \
39 qtknx \
40 qtopcua \
41 "
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
new file mode 100644
index 0000000..257ef0f
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
@@ -0,0 +1,42 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Target packages for B2Qt Automation Qt5 SDK"
31LICENSE = "The-Qt-Company-Commercial"
32PR = "r0"
33
34inherit packagegroup
35
36PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
37
38RDEPENDS_${PN} += " \
39 qtmqtt-dev \
40 qtknx-dev \
41 qtopcua-dev \
42 "
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch
index ac4fe40..7b13555 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch
@@ -1,4 +1,4 @@
1From 0386cb5f9a46e56a0a94f2a92e87ed52d41cf4ea Mon Sep 17 00:00:00 2001 1From 8d720921ddda76fcf77c0f7ebc5ac0b873ab1595 Mon Sep 17 00:00:00 2001
2From: David Schulz <david.schulz@theqtcompany.com> 2From: David Schulz <david.schulz@theqtcompany.com>
3Date: Fri, 3 Jul 2015 16:06:59 +0200 3Date: Fri, 3 Jul 2015 16:06:59 +0200
4Subject: [PATCH] Add win32-g++-oe mkspec that uses the OE_ environment. 4Subject: [PATCH] Add win32-g++-oe mkspec that uses the OE_ environment.
@@ -8,108 +8,52 @@ Upstream-Status: Inappropriate [embedded specific]
8 8
9Change-Id: Ic60b32f88ee6a792b0d8938e40e2d6cb19fb93aa 9Change-Id: Ic60b32f88ee6a792b0d8938e40e2d6cb19fb93aa
10--- 10---
11 mkspecs/win32-g++-oe/qmake.conf | 87 ++++++++++++++++++++++++++++++++++++ 11 mkspecs/win32-g++-oe/qmake.conf | 31 ++++++++++++++++++++
12 mkspecs/win32-g++-oe/qplatformdefs.h | 42 +++++++++++++++++ 12 mkspecs/win32-g++-oe/qplatformdefs.h | 42 ++++++++++++++++++++++++++++
13 2 files changed, 129 insertions(+) 13 2 files changed, 73 insertions(+)
14 create mode 100644 mkspecs/win32-g++-oe/qmake.conf 14 create mode 100644 mkspecs/win32-g++-oe/qmake.conf
15 create mode 100644 mkspecs/win32-g++-oe/qplatformdefs.h 15 create mode 100644 mkspecs/win32-g++-oe/qplatformdefs.h
16 16
17diff --git a/mkspecs/win32-g++-oe/qmake.conf b/mkspecs/win32-g++-oe/qmake.conf 17diff --git a/mkspecs/win32-g++-oe/qmake.conf b/mkspecs/win32-g++-oe/qmake.conf
18new file mode 100644 18new file mode 100644
19index 0000000..76eefe5 19index 0000000000..ab759e2093
20--- /dev/null 20--- /dev/null
21+++ b/mkspecs/win32-g++-oe/qmake.conf 21+++ b/mkspecs/win32-g++-oe/qmake.conf
22@@ -0,0 +1,87 @@ 22@@ -0,0 +1,31 @@
23+# 23+#
24+# qmake configuration for win32-g++ 24+# qmake configuration for win32-g++
25+# 25+#
26+# Written for MinGW / gcc 4.6 or higher 26+# Written for MinGW-w64 / gcc 5.3 or higher
27+# 27+#
28+# Cross compile example for i686-w64-mingw32-g++: 28+# Cross compile example for i686-w64-mingw32-g++:
29+# configure -xplatform win32-g++ -device-option CROSS_COMPILE=i686-w64-mingw32- 29+# configure -xplatform win32-g++ -device-option CROSS_COMPILE=i686-w64-mingw32-
30+# 30+#
31+ 31+
32+load(device_config) 32+include(../common/g++-win32.conf)
33+include(../common/g++-base.conf)
34+ 33+
35+MAKEFILE_GENERATOR = MINGW 34+# modifications to g++-win32.conf
36+QMAKE_PLATFORM = win32 mingw
37+CONFIG += debug_and_release debug_and_release_target precompile_header
38+DEFINES += UNICODE
39+QMAKE_COMPILER_DEFINES += __GNUC__ WIN32
40+
41+QMAKE_EXT_OBJ = .o
42+QMAKE_EXT_RES = _res.o
43+
44+QMAKE_COMPILER = $$(OE_QMAKE_COMPILER)
45+ 35+
46+QMAKE_CC = $$(OE_QMAKE_CC) 36+QMAKE_CC = $$(OE_QMAKE_CC)
47+QMAKE_LEX = flex
48+QMAKE_LEXFLAGS =
49+QMAKE_YACC = bison -y
50+QMAKE_YACCFLAGS = -d
51+QMAKE_CFLAGS += -fno-keep-inline-dllexport $$(OE_QMAKE_CFLAGS) 37+QMAKE_CFLAGS += -fno-keep-inline-dllexport $$(OE_QMAKE_CFLAGS)
52+QMAKE_CFLAGS_WARN_ON += -Wextra 38+QMAKE_CFLAGS_WARN_ON += -Wextra
53+QMAKE_CFLAGS_SSE2 += -mstackrealign
54+ 39+
55+QMAKE_CXX = $$(OE_QMAKE_CXX) 40+QMAKE_CXX = $$(OE_QMAKE_CXX)
56+QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD 41+QMAKE_CXXFLAGS += -fno-keep-inline-dllexport
57+QMAKE_CXXFLAGS_RTTI_ON = -frtti 42+QMAKE_CXXFLAGS_WARN_ON = $$QMAKE_CFLAGS_WARN_ON
58+QMAKE_CXXFLAGS_RTTI_OFF = -fno-rtti
59+QMAKE_CXXFLAGS_EXCEPTIONS_ON = -fexceptions -mthreads
60+
61+QMAKE_INCDIR =
62+
63+QMAKE_RUN_CC = $(CC) -c $(CFLAGS) $(INCPATH) -o $obj $src
64+QMAKE_RUN_CC_IMP = $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
65+QMAKE_RUN_CXX = $(CXX) -c $(CXXFLAGS) $(INCPATH) -o $obj $src
66+QMAKE_RUN_CXX_IMP = $(CXX) -c $(CXXFLAGS) $(INCPATH) -o $@ $<
67+ 43+
68+QMAKE_LINK = $$(OE_QMAKE_LINK) 44+QMAKE_LINK = $$(OE_QMAKE_LINK)
69+QMAKE_LINK_C = $$(OE_QMAKE_LINK) 45+QMAKE_LINK_C = $$(OE_QMAKE_CC)
70+QMAKE_LFLAGS = $$(OE_QMAKE_LDFLAGS) 46+QMAKE_LFLAGS = $$(OE_QMAKE_LDFLAGS)
71+QMAKE_LFLAGS_EXCEPTIONS_ON = -mthreads
72+QMAKE_LFLAGS_RELEASE = -Wl,-s
73+QMAKE_LFLAGS_CONSOLE = -Wl,-subsystem,console
74+QMAKE_LFLAGS_WINDOWS = -Wl,-subsystem,windows
75+QMAKE_LFLAGS_DLL = -shared
76+QMAKE_LFLAGS_GCSECTIONS = -Wl,--gc-sections
77+QMAKE_LINK_OBJECT_MAX = 10
78+QMAKE_LINK_OBJECT_SCRIPT = object_script
79+QMAKE_PREFIX_SHLIB =
80+QMAKE_EXTENSION_SHLIB = dll
81+QMAKE_PREFIX_STATICLIB = lib
82+QMAKE_EXTENSION_STATICLIB = a
83+QMAKE_LIB_EXTENSIONS = a dll.a
84+ 47+
85+QMAKE_LIBS =
86+QMAKE_LIBS_CORE = -lole32 -luuid -lws2_32 -ladvapi32 -lshell32 -luser32 -lkernel32
87+QMAKE_LIBS_GUI = -lgdi32 -lcomdlg32 -loleaut32 -limm32 -lwinmm -lws2_32 -lole32 -luuid -luser32 -ladvapi32
88+QMAKE_LIBS_NETWORK = -lws2_32
89+QMAKE_LIBS_OPENGL = -lglu32 -lopengl32 -lgdi32 -luser32
90+QMAKE_LIBS_OPENGL_ES2 = -lgdi32 -luser32
91+QMAKE_LIBS_OPENGL_ES2_DEBUG = -lgdi32 -luser32
92+QMAKE_LIBS_COMPAT = -ladvapi32 -lshell32 -lcomdlg32 -luser32 -lgdi32 -lws2_32
93+QMAKE_LIBS_QT_ENTRY = -lmingw32 -lqtmain
94+
95+QMAKE_IDL = midl
96+QMAKE_LIB = $$(OE_QMAKE_AR) -rc 48+QMAKE_LIB = $$(OE_QMAKE_AR) -rc
97+QMAKE_RC = $$(RC) 49+QMAKE_RC = $$(RC)
98+ 50+
99+QMAKE_STRIP = $$(OE_QMAKE_STRIP) 51+QMAKE_STRIP = $$(OE_QMAKE_STRIP)
100+QMAKE_STRIPFLAGS_LIB += --strip-unneeded
101+QMAKE_OBJCOPY = $${CROSS_COMPILE}objcopy
102+QMAKE_NM = $${CROSS_COMPILE}nm -P
103+
104+isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $$(OE_QMAKE_QT_CONFIG)
105+
106+include(../common/angle.conf)
107+include(../common/gcc-base.conf)
108+ 52+
109+load(qt_config) 53+load(qt_config)
110diff --git a/mkspecs/win32-g++-oe/qplatformdefs.h b/mkspecs/win32-g++-oe/qplatformdefs.h 54diff --git a/mkspecs/win32-g++-oe/qplatformdefs.h b/mkspecs/win32-g++-oe/qplatformdefs.h
111new file mode 100644 55new file mode 100644
112index 0000000..9d63527 56index 0000000000..9d63527955
113--- /dev/null 57--- /dev/null
114+++ b/mkspecs/win32-g++-oe/qplatformdefs.h 58+++ b/mkspecs/win32-g++-oe/qplatformdefs.h
115@@ -0,0 +1,42 @@ 59@@ -0,0 +1,42 @@
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0015-Disable-ltcg-for-host_build.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0002-Disable-ltcg-for-host_build.patch
index a7ee953..b1a755f 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0015-Disable-ltcg-for-host_build.patch
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0002-Disable-ltcg-for-host_build.patch
@@ -1,4 +1,4 @@
1From 9b541f4f6272c4ed4bb5bf6591e9a65cded6fdfa Mon Sep 17 00:00:00 2001 1From 4de366eeb48038da4140c3dcb3e96070e7d56429 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io> 2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Tue, 23 Oct 2018 09:54:57 +0300 3Date: Tue, 23 Oct 2018 09:54:57 +0300
4Subject: [PATCH] Disable ltcg for host_build 4Subject: [PATCH] Disable ltcg for host_build
@@ -22,11 +22,11 @@ Upstream-Status: Inappropriate [embedded specific]
22 1 file changed, 1 insertion(+), 1 deletion(-) 22 1 file changed, 1 insertion(+), 1 deletion(-)
23 23
24diff --git a/mkspecs/features/ltcg.prf b/mkspecs/features/ltcg.prf 24diff --git a/mkspecs/features/ltcg.prf b/mkspecs/features/ltcg.prf
25index ccf0226272..00118be872 100644 25index 482e5b5..de00842 100644
26--- a/mkspecs/features/ltcg.prf 26--- a/mkspecs/features/ltcg.prf
27+++ b/mkspecs/features/ltcg.prf 27+++ b/mkspecs/features/ltcg.prf
28@@ -1,4 +1,4 @@ 28@@ -1,4 +1,4 @@
29-CONFIG(release, debug|release) { 29-CONFIG(release, debug|release):!host_build {
30+CONFIG(release, debug|release):!host_build:!equals(QMAKE_HOST.os, Windows):!staticlib { 30+CONFIG(release, debug|release):!host_build:!equals(QMAKE_HOST.os, Windows):!staticlib {
31 # We need fat object files when creating static libraries on some platforms 31 # We need fat object files when creating static libraries on some platforms
32 # so the linker will know to load a particular object from the library 32 # so the linker will know to load a particular object from the library
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
index 5684832..95ca956 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
@@ -47,7 +47,7 @@ PACKAGECONFIG += " \
47 ltcg \ 47 ltcg \
48 sql-sqlite \ 48 sql-sqlite \
49 tslib \ 49 tslib \
50 xkbcommon-evdev \ 50 xkbcommon \
51 " 51 "
52 52
53PACKAGECONFIG_remove = "tests" 53PACKAGECONFIG_remove = "tests"
@@ -60,6 +60,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
60SRC_URI += " \ 60SRC_URI += " \
61 file://oe-device-extra.pri \ 61 file://oe-device-extra.pri \
62 file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \ 62 file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \
63 file://0002-Disable-ltcg-for-host_build.patch \
63 " 64 "
64do_configure_prepend() { 65do_configure_prepend() {
65 install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs 66 install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch
index b90d2f8..c5e9fbf 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch
@@ -1,20 +1,19 @@
1From 5a68ac7a0121eff661a448e2fcbe5c02981c50a1 Mon Sep 17 00:00:00 2001 1From 1362ec91854e9d56be56dc3556a9991eb3b17a5c Mon Sep 17 00:00:00 2001
2From: Mikko Gronoff <mikko.gronoff@qt.io> 2From: Mikko Gronoff <mikko.gronoff@qt.io>
3Date: Wed, 25 Oct 2017 13:22:16 +0300 3Date: Wed, 25 Oct 2017 13:22:16 +0300
4Subject: [PATCH] location: disable simulator content under plugins 4Subject: [PATCH] location: disable simulator content under plugins
5 5
6Does not build against more recent simulator 6Does not build against more recent simulator
7
8--- 7---
9 src/plugins/position/position.pro | 2 +- 8 src/plugins/position/position.pro | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
11 10
12diff --git a/src/plugins/position/position.pro b/src/plugins/position/position.pro 11diff --git a/src/plugins/position/position.pro b/src/plugins/position/position.pro
13index 4453b8a3..c36a1b58 100644 12index 6800d5a3..a6d3edba 100644
14--- a/src/plugins/position/position.pro 13--- a/src/plugins/position/position.pro
15+++ b/src/plugins/position/position.pro 14+++ b/src/plugins/position/position.pro
16@@ -6,7 +6,7 @@ qtHaveModule(dbus):SUBDIRS += geoclue 15@@ -6,7 +6,7 @@ linux:qtHaveModule(dbus):SUBDIRS += geoclue
17 qtHaveModule(dbus):SUBDIRS += geoclue2 16 linux:qtHaveModule(dbus):SUBDIRS += geoclue2
18 qtConfig(gypsy):SUBDIRS += gypsy 17 qtConfig(gypsy):SUBDIRS += gypsy
19 qtConfig(winrt_geolocation):SUBDIRS += winrt 18 qtConfig(winrt_geolocation):SUBDIRS += winrt
20-qtHaveModule(simulator):SUBDIRS += simulator 19-qtHaveModule(simulator):SUBDIRS += simulator