summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb')
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb
new file mode 100644
index 0000000..af291c7
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb
@@ -0,0 +1,66 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34inherit packagegroup
35
36RDEPENDS_${PN} = "\
37 gst-meta-video \
38 gst-meta-audio \
39 gst-plugins-good \
40 gst-plugins-base-app \
41 gst-plugins-base-audiorate \
42 gst-plugins-base-videorate \
43 gst-plugins-base-encodebin \
44 gst-plugins-good-videofilter \
45 gst-plugins-good-id3demux \
46 gst-plugins-good-auparse \
47 gst-plugins-good-isomp4 \
48 gst-plugins-good-icydemux \
49 gst-plugins-good-video4linux2 \
50 gst-plugins-good-multifile \
51 gst-plugins-good-videocrop \
52 gst-plugins-good-jpeg \
53 gst-plugins-ugly-rmdemux \
54 gst-plugins-ugly-asf \
55 gst-plugins-ugly-a52dec \
56 gst-plugins-bad-mpegdemux \
57 gst-plugins-bad-faad \
58 gst-plugins-bad-camerabin2 \
59 gst-plugins-bad-jpegformat \
60 gst-plugins-ugly-mad \
61 gst-plugins-ugly-mpegaudioparse \
62 gst-plugins-ugly-mpeg2dec \
63 gst-plugins-ugly-mpegstream \
64 gst-plugins-bad-mpegvideoparse \
65 gst-ffmpeg \
66 "