summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb')
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
new file mode 100644
index 0000000..b6573e2
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
@@ -0,0 +1,58 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34inherit packagegroup
35
36MACHINE_EXTRA_INSTALL ?= ""
37
38RDEPENDS_${PN} = "\
39 kernel-modules \
40 linux-firmware \
41 ca-certificates \
42 liberation-fonts \
43 ttf-devanagari \
44 ttf-opensans \
45 ttf-dejavu-common \
46 ttf-dejavu-sans \
47 ttf-freefont-mono \
48 otf-noto \
49 dbus-session-init \
50 tzdata \
51 tzdata-americas \
52 tzdata-asia \
53 tzdata-europe \
54 connman \
55 rng-tools \
56 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "weston weston-examples", "", d)} \
57 ${MACHINE_EXTRA_INSTALL} \
58 "