summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/conf/distro/include/tegra-t18x.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt-distro/conf/distro/include/tegra-t18x.conf')
-rw-r--r--meta-boot2qt-distro/conf/distro/include/tegra-t18x.conf97
1 files changed, 97 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/tegra-t18x.conf b/meta-boot2qt-distro/conf/distro/include/tegra-t18x.conf
new file mode 100644
index 0000000..6c79d2c
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/tegra-t18x.conf
@@ -0,0 +1,97 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30IMAGE_FSTYPES += "tar.gz"
31
32QBSP_IMAGE_CONTENT = "\
33 ${IMAGE_LINK_NAME}.tar.gz \
34 "
35
36PLATFORM_TOPDIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186")}'
37NVLAYER_DIR ?= "${TOPDIR}/../sources/nvidia-layer"
38
39MACHINE_EXTRA_INSTALL += "\
40 tegra-firmware-fecs \
41 tegra-firmware-gmicrocode \
42 tegra-firmware-gpccs \
43 tegra-firmware-gpmu \
44 tegra-firmware-gshader \
45 tegra-firmware-pmu \
46 tegra-firmware-prod-fuse \
47 tegra-firmware-xusb \
48 tegra-firmware-vic \
49 tegra-firmware-nvdec \
50 tegra-firmware-nvenc \
51 tegra-firmware-nvjpeg \
52 tegra-drivers \
53 virtual/libegl \
54 virtual/libgles2 \
55 libdrm-nv \
56 "
57
58PREFERRED_PROVIDER_virtual/libgles2 = "tegra-drivers"
59PREFERRED_PROVIDER_virtual/libgles2-dev = "tegra-drivers"
60PREFERRED_PROVIDER_virtual/libegl = "tegra-drivers"
61PREFERRED_PROVIDER_virtual/libegl-dev = "tegra-drivers"
62PREFERRED_PROVIDER_virtual/egl = "tegra-drivers"
63PREFERRED_PROVIDER_virtual/libgl = "tegra-drivers"
64PREFERRED_PROVIDER_virtual/libgles1 = "tegra-drivers"
65PREFERRED_PROVIDER_virtual/mesa = "tegra-drivers"
66PREFERRED_PROVIDER_drm = "libdrm-nv"
67PREFERRED_PROVIDER_libdrm = "libdrm-nv"
68PREFERRED_PROVIDER_virtual/kernel = "linux-nvidia"
69PREFERRED_VERSION_linux-libc-headers = "4.4"
70PREFERRED_VERSION_nativesdk-linux-libc-headers = "4.4"
71
72BBMASK += "\
73 meta-tegra/recipes-bsp/flashing \
74 meta-vib4/recipes-connectivity/openssl \
75 meta-vib4/recipes-core/busybox \
76 meta-vib4/recipes-core/glibc \
77 meta-vib4/recipes-core/images \
78 meta-vib4/recipes-core/kbd \
79 meta-vib4/recipes-core/packagegroups \
80 meta-vib4/recipes-core/toybox \
81 meta-vib4/recipes-devtools/binutils \
82 meta-vib4/recipes-devtools/gcc \
83 meta-vib4/recipes-dummy/files \
84 meta-vib4/recipes-extended/common-api \
85 meta-vib4/recipes-extended/persistence-common-object \
86 meta-vib4/recipes-extended/quota \
87 meta-vib4/recipes-extended/xz \
88 meta-vib4/recipes-graphics/wayland/libinput_%.bbappend \
89 meta-vib4/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend \
90 meta-vib4/recipes-graphics/weston \
91 meta-vib4/recipes-kernel/linux-libc-headers \
92 meta-vib4/recipes-multimedia/audiomanager \
93 meta-vib4/recipes-navigation/gpsd \
94 meta-vib4/recipes-support/keyutils \
95 meta-vib4/recipes-support/lvm2 \
96 meta-vib4/recipes-yocto-ivi \
97 "