summaryrefslogtreecommitdiffstats
path: root/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb')
-rw-r--r--meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb b/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
deleted file mode 100644
index 69adc4f..0000000
--- a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1# Copyright (C) 2011-2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require recipes-kernel/linux/linux-imx.inc
5
6COMPATIBLE_MACHINE = "(mx6)"
7
8# Revision of 4.1.0 branch
9SRCREV = "bdde708ebfde4a8c1d3829578d3f6481a343533a"
10LOCALVERSION = "-4.1.0+yocto"
11
12# Patches need for Yocto and not applied by Freescale when doing 4.1.0 branch
13SRC_URI += "file://drm-vivante-Add-00-sufix-in-returned-bus-Id.patch \
14 file://epdc-Rename-mxcfb_epdc_kernel.h-to-mxc_epdc.h.patch \
15 file://0001-perf-tools-Fix-getrusage-related-build-failure-on-gl.patch \
16 file://0002-ARM-7668-1-fix-memset-related-crashes-caused-by-rece.patch \
17 file://0003-ARM-7670-1-fix-the-memset-fix.patch \
18 file://0004-ENGR00271136-Fix-build-break-when-CONFIG_CLK_DEBUG-i.patch \
19 file://0005-ENGR00271359-Add-Multi-touch-support.patch \
20 file://0006-Add-support-for-DVI-monitors.patch \
21 file://0007-ARM-mach-mx6-board-mx6q_sabresd-Register-SDHC3-first.patch"
22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
25
26do_configure_prepend() {
27
28cat <<EOF >> ${WORKDIR}/defconfig
29
30# FunctionFS for adb
31CONFIG_USB_FUNCTIONFS=m
32
33# Enable USB serial support
34CONFIG_USB_SERIAL=m
35CONFIG_USB_SERIAL_GENERIC=y
36CONFIG_USB_SERIAL_FTDI_SIO=m
37CONFIG_USB_SERIAL_PL2303=m
38CONFIG_USB_ACM=m
39
40# Control group support
41CONFIG_CGROUPS=y
42
43# Open by fhandle syscalls
44CONFIG_FHANDLE=y
45CONFIG_EXPORTFS=y
46
47# Namespaces support
48CONFIG_NAMESPACES=y
49CONFIG_UTS_NS=y
50CONFIG_IPC_NS=y
51CONFIG_USER_NS=y
52CONFIG_PID_NS=y
53CONFIG_NET_NS=y
54
55EOF
56}
57
58# bbappend in meta-tibidabo still tries to use PRINC, set to -1 to prevent errors
59PRINC = "-1"