diff options
-rwxr-xr-x | b2qt-init-build-env | 15 | ||||
-rw-r--r-- | classes/internal-build.bbclass | 46 | ||||
-rw-r--r-- | conf/local.conf.sample | 15 | ||||
-rw-r--r-- | recipes-qt/qt5-addons/qtquickcompiler_git.bb | 2 | ||||
-rw-r--r-- | recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch | 39 | ||||
-rw-r--r-- | recipes/gcc/gcc-source_4.9.bbappend | 26 | ||||
-rw-r--r-- | recipes/meta/meta-environment.bbappend | 2 | ||||
-rw-r--r-- | scripts/manifest.xml | 23 | ||||
-rw-r--r-- | scripts/manifest_jethro.xml | 24 | ||||
-rwxr-xr-x | scripts/setup-environment.sh | 2 |
10 files changed, 86 insertions, 108 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env index 8541c72..b395e5d 100755 --- a/b2qt-init-build-env +++ b/b2qt-init-build-env | |||
@@ -26,7 +26,10 @@ usage() { | |||
26 | echo "Usage: $(basename $0) COMMAND [ARGS]" | 26 | echo "Usage: $(basename $0) COMMAND [ARGS]" |
27 | echo | 27 | echo |
28 | echo "Initialize build environment:" | 28 | echo "Initialize build environment:" |
29 | echo " $(basename $0) init --device <name> [--reference <mirror path>]" | 29 | echo " $(basename $0) init --device <name> [--reference <mirror path>] [--internal]" |
30 | echo " --device <name>: target device name or 'all'" | ||
31 | echo " --reference <mirror path>: path to local mirror, initialized previously with '$(basename $0) mirror'" | ||
32 | echo " --internal: fetch internal repositories, available only inside The Qt Company network." | ||
30 | echo "Initialize local mirror:" | 33 | echo "Initialize local mirror:" |
31 | echo " $(basename $0) mirror" | 34 | echo " $(basename $0) mirror" |
32 | echo "List available devices:" | 35 | echo "List available devices:" |
@@ -51,6 +54,9 @@ while test -n "$1"; do | |||
51 | shift | 54 | shift |
52 | REPO_URL="--repo-url $1" | 55 | REPO_URL="--repo-url $1" |
53 | ;; | 56 | ;; |
57 | "--internal") | ||
58 | INTERNAL="y" | ||
59 | ;; | ||
54 | *) | 60 | *) |
55 | if [ -n "$COMMAND" ]; then | 61 | if [ -n "$COMMAND" ]; then |
56 | echo "Unknown argument: $1" | 62 | echo "Unknown argument: $1" |
@@ -90,7 +96,7 @@ get_repo() { | |||
90 | get_groups() { | 96 | get_groups() { |
91 | case ${DEVICE} in | 97 | case ${DEVICE} in |
92 | all) | 98 | all) |
93 | PROJECT_GROUPS="all" | 99 | PROJECT_GROUPS="external" |
94 | ;; | 100 | ;; |
95 | apalis-imx6|colibri-imx6|colibri-vf) | 101 | apalis-imx6|colibri-imx6|colibri-vf) |
96 | PROJECT_GROUPS="toradex" | 102 | PROJECT_GROUPS="toradex" |
@@ -127,11 +133,14 @@ get_groups() { | |||
127 | ;; | 133 | ;; |
128 | *) | 134 | *) |
129 | echo "Unknown device configuration, including all meta layers" | 135 | echo "Unknown device configuration, including all meta layers" |
130 | PROJECT_GROUPS="all" | 136 | PROJECT_GROUPS="external" |
131 | ;; | 137 | ;; |
132 | esac | 138 | esac |
133 | 139 | ||
134 | PROJECT_GROUPS="${PROJECT_GROUPS} default" | 140 | PROJECT_GROUPS="${PROJECT_GROUPS} default" |
141 | if [ "${INTERNAL}" = "y" ]; then | ||
142 | PROJECT_GROUPS="${PROJECT_GROUPS} internal" | ||
143 | fi | ||
135 | } | 144 | } |
136 | 145 | ||
137 | list_devices() { | 146 | list_devices() { |
diff --git a/classes/internal-build.bbclass b/classes/internal-build.bbclass new file mode 100644 index 0000000..0fb28e5 --- /dev/null +++ b/classes/internal-build.bbclass | |||
@@ -0,0 +1,46 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | python enable_internal_build () { | ||
23 | import socket | ||
24 | try: | ||
25 | socket.gethostbyname('yocto-cache.ci.local') | ||
26 | except: | ||
27 | return | ||
28 | |||
29 | e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH") | ||
30 | e.data.setVar('PREMIRRORS', "\ | ||
31 | ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
32 | http://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
33 | https://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
34 | bzr://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
35 | cvs://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
36 | git://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
37 | gitsm://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
38 | hg://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
39 | osc://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
40 | p4://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
41 | svn://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
42 | ") | ||
43 | } | ||
44 | |||
45 | addhandler enable_internal_build | ||
46 | enable_internal_build[eventmask] = "bb.event.ConfigParsed" | ||
diff --git a/conf/local.conf.sample b/conf/local.conf.sample index 02e7811..5dd5c3d 100644 --- a/conf/local.conf.sample +++ b/conf/local.conf.sample | |||
@@ -252,20 +252,6 @@ BB_DISKMON_DIRS = "\ | |||
252 | #SSTATE_MIRRORS ?= "\ | 252 | #SSTATE_MIRRORS ?= "\ |
253 | #file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \ | 253 | #file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \ |
254 | #file://.* file:///some/local/dir/sstate/PATH" | 254 | #file://.* file:///some/local/dir/sstate/PATH" |
255 | SSTATE_MIRRORS ?= "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH" | ||
256 | |||
257 | PREMIRRORS = "\ | ||
258 | ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
259 | http://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
260 | https://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
261 | bzr://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
262 | cvs://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
263 | git://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
264 | gitsm://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
265 | hg://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
266 | osc://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
267 | p4://.*/.* http://yocto-cache.ci.local/sources/ \n \ | ||
268 | svn://.*/.* http://yocto-cache.ci.local/sources/ \n" | ||
269 | 255 | ||
270 | # | 256 | # |
271 | # Qemu configuration | 257 | # Qemu configuration |
@@ -285,6 +271,7 @@ CONF_VERSION = "1" | |||
285 | 271 | ||
286 | INHERIT += "rm_work" | 272 | INHERIT += "rm_work" |
287 | INHERIT += "image-buildinfo" | 273 | INHERIT += "image-buildinfo" |
274 | INHERIT += "internal-build" | ||
288 | 275 | ||
289 | ACCEPT_FSL_EULA = "1" | 276 | ACCEPT_FSL_EULA = "1" |
290 | LICENSE_FLAGS_WHITELIST = "commercial" | 277 | LICENSE_FLAGS_WHITELIST = "commercial" |
diff --git a/recipes-qt/qt5-addons/qtquickcompiler_git.bb b/recipes-qt/qt5-addons/qtquickcompiler_git.bb index b09af7c..42013e7 100644 --- a/recipes-qt/qt5-addons/qtquickcompiler_git.bb +++ b/recipes-qt/qt5-addons/qtquickcompiler_git.bb | |||
@@ -29,7 +29,7 @@ SRC_URI = " \ | |||
29 | git://codereview.qt-project.org/qt/tqtc-qmlcompiler;branch=${BRANCH};protocol=ssh \ | 29 | git://codereview.qt-project.org/qt/tqtc-qmlcompiler;branch=${BRANCH};protocol=ssh \ |
30 | " | 30 | " |
31 | 31 | ||
32 | SRCREV = "494283b7bf77f2801021e185c95ef948632ddddf" | 32 | SRCREV = "ea222ff87942781d1091fdcd0385a0c842d21e15" |
33 | BRANCH = "5.6" | 33 | BRANCH = "5.6" |
34 | 34 | ||
35 | S = "${WORKDIR}/git" | 35 | S = "${WORKDIR}/git" |
diff --git a/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch b/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch deleted file mode 100644 index c0ea62f..0000000 --- a/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From b30ffb8097749fdb55704aa7d8307ca1a58255d6 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Stefan=20M=C3=BCller-Klieser?= <s.mueller-klieser@phytec.de> | ||
3 | Date: Tue, 7 Apr 2015 16:15:11 +0200 | ||
4 | Subject: [PATCH] gcc/var-tracking.c: backport from gcc trunk r212178 | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | resolves a bug seen on cortexa8 building qt5 libraries. | ||
10 | |||
11 | 2014-06-30 Joseph Myers <joseph@codesourcery.com> | ||
12 | |||
13 | * var-tracking.c (add_stores): Return instead of asserting if old | ||
14 | and new values for conditional store are the same. | ||
15 | |||
16 | git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@212178 138bc75d-0d04-0410-961f-82ee72b054a4 | ||
17 | |||
18 | Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de> | ||
19 | --- | ||
20 | gcc/var-tracking.c | 3 ++- | ||
21 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/gcc/var-tracking.c b/gcc/var-tracking.c | ||
24 | index 65d8285..7c38910 100644 | ||
25 | --- a/gcc/var-tracking.c | ||
26 | +++ b/gcc/var-tracking.c | ||
27 | @@ -5997,7 +5997,8 @@ add_stores (rtx loc, const_rtx expr, void *cuip) | ||
28 | { | ||
29 | cselib_val *oval = cselib_lookup (oloc, GET_MODE (oloc), 0, VOIDmode); | ||
30 | |||
31 | - gcc_assert (oval != v); | ||
32 | + if (oval == v) | ||
33 | + return; | ||
34 | gcc_assert (REG_P (oloc) || MEM_P (oloc)); | ||
35 | |||
36 | if (oval && !cselib_preserved_value_p (oval)) | ||
37 | -- | ||
38 | 1.9.1 | ||
39 | |||
diff --git a/recipes/gcc/gcc-source_4.9.bbappend b/recipes/gcc/gcc-source_4.9.bbappend deleted file mode 100644 index 2b937e6..0000000 --- a/recipes/gcc/gcc-source_4.9.bbappend +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | FILESEXTRAPATHS_append := "${THISDIR}/gcc-4.9:" | ||
23 | |||
24 | SRC_URI += " \ | ||
25 | file://0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch \ | ||
26 | " | ||
diff --git a/recipes/meta/meta-environment.bbappend b/recipes/meta/meta-environment.bbappend index 39f3586..276868d 100644 --- a/recipes/meta/meta-environment.bbappend +++ b/recipes/meta/meta-environment.bbappend | |||
@@ -19,6 +19,8 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | inherit image-buildinfo | ||
23 | |||
22 | toolchain_create_sdk_version_append () { | 24 | toolchain_create_sdk_version_append () { |
23 | echo 'Layer Revisions:' >> $versionfile | 25 | echo 'Layer Revisions:' >> $versionfile |
24 | echo '${@get_layer_revs(d)}' >> $versionfile | 26 | echo '${@get_layer_revs(d)}' >> $versionfile |
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 74cee35..28ccfa3 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -27,7 +27,6 @@ | |||
27 | remote="qtyocto" | 27 | remote="qtyocto" |
28 | revision="e6897ccd0eec8fb5229e0fdd8f354292e0f49a16" | 28 | revision="e6897ccd0eec8fb5229e0fdd8f354292e0f49a16" |
29 | path="sources/meta-qt5"/> | 29 | path="sources/meta-qt5"/> |
30 | |||
31 | <project name="meta-mingw" | 30 | <project name="meta-mingw" |
32 | remote="qtyocto" | 31 | remote="qtyocto" |
33 | path="sources/meta-mingw" | 32 | path="sources/meta-mingw" |
@@ -37,58 +36,58 @@ | |||
37 | remote="yocto" | 36 | remote="yocto" |
38 | revision="8d22b44716fa624ff87383c36d222d9e28d0b267" | 37 | revision="8d22b44716fa624ff87383c36d222d9e28d0b267" |
39 | path="sources/meta-fsl-arm" | 38 | path="sources/meta-fsl-arm" |
40 | groups="notdefault,fsl,toradex,architech,ti,bbb,smx6"/> | 39 | groups="notdefault,external,fsl,toradex,architech,ti,bbb,smx6"/> |
41 | <project name="meta-ti" | 40 | <project name="meta-ti" |
42 | remote="yocto" | 41 | remote="yocto" |
43 | revision="0da13d5a37a9d40ad6e41fe5eeeb532fef795a7a" | 42 | revision="0da13d5a37a9d40ad6e41fe5eeeb532fef795a7a" |
44 | path="sources/meta-ti" | 43 | path="sources/meta-ti" |
45 | groups="notdefault,ti,bbb"/> | 44 | groups="notdefault,external,ti,bbb"/> |
46 | <project name="meta-raspberrypi" | 45 | <project name="meta-raspberrypi" |
47 | remote="yocto" | 46 | remote="yocto" |
48 | revision="e82417d33b8147f65141ef937d56735d80ee7207" | 47 | revision="e82417d33b8147f65141ef937d56735d80ee7207" |
49 | path="sources/meta-raspberrypi" | 48 | path="sources/meta-raspberrypi" |
50 | groups="notdefault,rpi"/> | 49 | groups="notdefault,external,rpi"/> |
51 | <project name="meta-fsl-arm-extra" | 50 | <project name="meta-fsl-arm-extra" |
52 | remote="freescale" | 51 | remote="freescale" |
53 | revision="8fdde39f732be9e1ee9505a04c579073114459e7" | 52 | revision="8fdde39f732be9e1ee9505a04c579073114459e7" |
54 | path="sources/meta-fsl-arm-extra" | 53 | path="sources/meta-fsl-arm-extra" |
55 | groups="notdefault,fsl,toradex,architech,smx6"/> | 54 | groups="notdefault,external,fsl,toradex,architech,smx6"/> |
56 | <project name="meta-beagleboard" | 55 | <project name="meta-beagleboard" |
57 | remote="beagleboard" | 56 | remote="beagleboard" |
58 | revision="b5c709b2b6bd3bf236df923fa8f245a00fbb1b60" | 57 | revision="b5c709b2b6bd3bf236df923fa8f245a00fbb1b60" |
59 | path="sources/meta-beagleboard" | 58 | path="sources/meta-beagleboard" |
60 | groups="notdefault,bbb"/> | 59 | groups="notdefault,external,bbb"/> |
61 | <project name="meta-toradex" | 60 | <project name="meta-toradex" |
62 | remote="toradex" | 61 | remote="toradex" |
63 | revision="eca5937408c75a997b160bd1b92e1496b07421cf" | 62 | revision="eca5937408c75a997b160bd1b92e1496b07421cf" |
64 | path="sources/meta-toradex" | 63 | path="sources/meta-toradex" |
65 | groups="notdefault,toradex"/> | 64 | groups="notdefault,external,toradex"/> |
66 | <project name="meta-tibidabo" | 65 | <project name="meta-tibidabo" |
67 | remote="architech" | 66 | remote="architech" |
68 | revision="06c6b09e0776507e1230aa98b5ca10d9d3968286" | 67 | revision="06c6b09e0776507e1230aa98b5ca10d9d3968286" |
69 | path="sources/meta-tibidabo" | 68 | path="sources/meta-tibidabo" |
70 | groups="notdefault,architech"/> | 69 | groups="notdefault,external,architech"/> |
71 | <project name="meta-intel" | 70 | <project name="meta-intel" |
72 | remote="intel" | 71 | remote="intel" |
73 | revision="4e87c59bdedaa8c3e44fc02fd23be726c4d1dfb9" | 72 | revision="4e87c59bdedaa8c3e44fc02fd23be726c4d1dfb9" |
74 | path="sources/meta-intel" | 73 | path="sources/meta-intel" |
75 | groups="notdefault,intel"/> | 74 | groups="notdefault,external,intel"/> |
76 | 75 | ||
77 | <project name="meta-tegra" | 76 | <project name="meta-tegra" |
78 | remote="playground" | 77 | remote="playground" |
79 | revision="3125d29a5c58a471b67104d1bff965df38eb3115" | 78 | revision="3125d29a5c58a471b67104d1bff965df38eb3115" |
80 | path="sources/meta-tegra" | 79 | path="sources/meta-tegra" |
81 | groups="notdefault,nvidia-logan"/> | 80 | groups="notdefault,internal"/> |
82 | <project name="jetson-tk1-pro" | 81 | <project name="jetson-tk1-pro" |
83 | remote="playground" | 82 | remote="playground" |
84 | revision="a376c795d5361fda4ea5f19feecc23ab7e753646" | 83 | revision="a376c795d5361fda4ea5f19feecc23ab7e753646" |
85 | path="sources/jetson-tk1-pro" | 84 | path="sources/jetson-tk1-pro" |
86 | groups="notdefault,nvidia-logan"/> | 85 | groups="notdefault,internal"/> |
87 | <project name="meta-smx6" | 86 | <project name="meta-smx6" |
88 | remote="playground" | 87 | remote="playground" |
89 | revision="c2f639ef4b2fd5809ab95fb330d28c2716aa290d" | 88 | revision="c2f639ef4b2fd5809ab95fb330d28c2716aa290d" |
90 | path="sources/meta-smx6" | 89 | path="sources/meta-smx6" |
91 | groups="notdefault,smx6"/> | 90 | groups="notdefault,internal"/> |
92 | 91 | ||
93 | </manifest> | 92 | </manifest> |
94 | 93 | ||
diff --git a/scripts/manifest_jethro.xml b/scripts/manifest_jethro.xml index c9b86b2..29b401c 100644 --- a/scripts/manifest_jethro.xml +++ b/scripts/manifest_jethro.xml | |||
@@ -27,7 +27,6 @@ | |||
27 | remote="qtyocto" | 27 | remote="qtyocto" |
28 | revision="5.7" | 28 | revision="5.7" |
29 | path="sources/meta-qt5"/> | 29 | path="sources/meta-qt5"/> |
30 | |||
31 | <project name="meta-mingw" | 30 | <project name="meta-mingw" |
32 | remote="qtyocto" | 31 | remote="qtyocto" |
33 | path="sources/meta-mingw" | 32 | path="sources/meta-mingw" |
@@ -37,57 +36,58 @@ | |||
37 | remote="yocto" | 36 | remote="yocto" |
38 | revision="jethro" | 37 | revision="jethro" |
39 | path="sources/meta-fsl-arm" | 38 | path="sources/meta-fsl-arm" |
40 | groups="notdefault,fsl,toradex,architech,ti,bbb"/> | 39 | groups="notdefault,external,fsl,toradex,architech,ti,bbb,smx6"/> |
41 | <project name="meta-ti" | 40 | <project name="meta-ti" |
42 | remote="yocto" | 41 | remote="yocto" |
43 | revision="master" | 42 | revision="master" |
44 | path="sources/meta-ti" | 43 | path="sources/meta-ti" |
45 | groups="notdefault,ti,bbb"/> | 44 | groups="notdefault,external,ti,bbb"/> |
46 | <project name="meta-raspberrypi" | 45 | <project name="meta-raspberrypi" |
47 | remote="yocto" | 46 | remote="yocto" |
48 | revision="master" | 47 | revision="master" |
49 | path="sources/meta-raspberrypi" | 48 | path="sources/meta-raspberrypi" |
50 | groups="notdefault,rpi"/> | 49 | groups="notdefault,external,rpi"/> |
51 | <project name="meta-fsl-arm-extra" | 50 | <project name="meta-fsl-arm-extra" |
52 | remote="freescale" | 51 | remote="freescale" |
53 | revision="jethro" | 52 | revision="jethro" |
54 | path="sources/meta-fsl-arm-extra" | 53 | path="sources/meta-fsl-arm-extra" |
55 | groups="notdefault,fsl,toradex,architech"/> | 54 | groups="notdefault,external,fsl,toradex,architech,smx6"/> |
56 | <project name="meta-beagleboard" | 55 | <project name="meta-beagleboard" |
57 | remote="beagleboard" | 56 | remote="beagleboard" |
58 | revision="master" | 57 | revision="master" |
59 | path="sources/meta-beagleboard" | 58 | path="sources/meta-beagleboard" |
60 | groups="notdefault,bbb"/> | 59 | groups="notdefault,external,bbb"/> |
61 | <project name="meta-toradex" | 60 | <project name="meta-toradex" |
62 | remote="toradex" | 61 | remote="toradex" |
63 | revision="V2.5" | 62 | revision="V2.5" |
64 | path="sources/meta-toradex" | 63 | path="sources/meta-toradex" |
65 | groups="notdefault,toradex"/> | 64 | groups="notdefault,external,toradex"/> |
66 | <project name="meta-tibidabo" | 65 | <project name="meta-tibidabo" |
67 | remote="architech" | 66 | remote="architech" |
68 | revision="dora" | 67 | revision="dora" |
69 | path="sources/meta-tibidabo" | 68 | path="sources/meta-tibidabo" |
70 | groups="notdefault,architech"/> | 69 | groups="notdefault,external,architech"/> |
71 | <project name="meta-intel" | 70 | <project name="meta-intel" |
72 | remote="intel" | 71 | remote="intel" |
73 | revision="jethro" | 72 | revision="jethro" |
74 | path="sources/meta-intel" | 73 | path="sources/meta-intel" |
75 | groups="notdefault,intel"/> | 74 | groups="notdefault,external,intel"/> |
76 | 75 | ||
77 | <project name="meta-tegra" | 76 | <project name="meta-tegra" |
78 | remote="playground" | 77 | remote="playground" |
79 | revision="master" | 78 | revision="master" |
80 | path="sources/meta-tegra" | 79 | path="sources/meta-tegra" |
81 | groups="notdefault,nvidia-logan"/> | 80 | groups="notdefault,internal"/> |
82 | <project name="jetson-tk1-pro" | 81 | <project name="jetson-tk1-pro" |
83 | remote="playground" | 82 | remote="playground" |
84 | revision="master" | 83 | revision="master" |
85 | path="sources/jetson-tk1-pro" | 84 | path="sources/jetson-tk1-pro" |
86 | groups="notdefault,nvidia-logan"/> | 85 | groups="notdefault,internal"/> |
87 | <project name="meta-smx6" | 86 | <project name="meta-smx6" |
88 | remote="playground" | 87 | remote="playground" |
89 | revision="fido" | 88 | revision="fido" |
90 | path="sources/meta-smx6" | 89 | path="sources/meta-smx6" |
91 | groups="notdefault,smx6"/> | 90 | groups="notdefault,internal"/> |
91 | |||
92 | </manifest> | 92 | </manifest> |
93 | 93 | ||
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index 9e8c4d1..322792f 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -34,7 +34,7 @@ while test -n "$1"; do | |||
34 | done | 34 | done |
35 | 35 | ||
36 | THIS_SCRIPT="setup-environment.sh" | 36 | THIS_SCRIPT="setup-environment.sh" |
37 | if [ "$(basename $0)" = "${THIS_SCRIPT}" ]; then | 37 | if [ "$(basename -- $0)" = "${THIS_SCRIPT}" ]; then |
38 | echo "Error: This script needs to be sourced. Please run as '. $0'" | 38 | echo "Error: This script needs to be sourced. Please run as '. $0'" |
39 | exit 1 | 39 | exit 1 |
40 | fi | 40 | fi |