summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/init-ifupdown/init-ifupdown/interfaces32
-rw-r--r--recipes/init-ifupdown/init-ifupdown_1.0.bbappend2
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/init-ifupdown/init-ifupdown/interfaces b/recipes/init-ifupdown/init-ifupdown/interfaces
new file mode 100644
index 0000000..02960ab
--- /dev/null
+++ b/recipes/init-ifupdown/init-ifupdown/interfaces
@@ -0,0 +1,32 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19hostname `/bin/hostname`
20iface eth1 inet dhcp
21
22# Ethernet/RNDIS gadget (g_ether)
23# ... or on host side, usbnet and random hwaddr
24iface usb0 inet static
25 address 192.168.7.2
26 netmask 255.255.255.0
27 network 192.168.7.0
28 gateway 192.168.7.1
29
30# Bluetooth networking
31iface bnep0 inet dhcp
32
diff --git a/recipes/init-ifupdown/init-ifupdown_1.0.bbappend b/recipes/init-ifupdown/init-ifupdown_1.0.bbappend
new file mode 100644
index 0000000..6d4804d
--- /dev/null
+++ b/recipes/init-ifupdown/init-ifupdown_1.0.bbappend
@@ -0,0 +1,2 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2