diff options
-rwxr-xr-x | b2qt-init-build-env | 3 | ||||
-rw-r--r-- | classes/image_types_sdcard.bbclass | 19 | ||||
-rw-r--r-- | conf/bblayers.conf.jetson.sample | 51 | ||||
-rw-r--r-- | conf/distro/include/jetson-tx1.conf | 44 | ||||
-rw-r--r-- | meta-tegra-extras/conf/layer.conf | 40 | ||||
-rw-r--r-- | meta-tegra-extras/recipes/drm/libdrm_%.bbappend | 32 | ||||
-rw-r--r-- | meta-tegra-extras/recipes/qt5/qtbase_git.bbappend | 30 | ||||
-rw-r--r-- | meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend | 34 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri | 4 | ||||
-rw-r--r-- | scripts/manifest.xml | 6 | ||||
-rwxr-xr-x | scripts/setup-environment.sh | 3 |
11 files changed, 266 insertions, 0 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env index decc2ec..b7acbd4 100755 --- a/b2qt-init-build-env +++ b/b2qt-init-build-env | |||
@@ -133,6 +133,9 @@ get_groups() { | |||
133 | alt|gose|koelsch|lager|porter|silk|stout) | 133 | alt|gose|koelsch|lager|porter|silk|stout) |
134 | PROJECT_GROUPS="renesas" | 134 | PROJECT_GROUPS="renesas" |
135 | ;; | 135 | ;; |
136 | jetson-tx1|jetson-tk1) | ||
137 | PROJECT_GROUPS="jetson" | ||
138 | ;; | ||
136 | *) | 139 | *) |
137 | echo "Unknown device configuration, including all meta layers" | 140 | echo "Unknown device configuration, including all meta layers" |
138 | PROJECT_GROUPS="external" | 141 | PROJECT_GROUPS="external" |
diff --git a/classes/image_types_sdcard.bbclass b/classes/image_types_sdcard.bbclass index e9b07f1..6c0850f 100644 --- a/classes/image_types_sdcard.bbclass +++ b/classes/image_types_sdcard.bbclass | |||
@@ -47,3 +47,22 @@ build_hddimg_append() { | |||
47 | rm -f ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.img | 47 | rm -f ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.img |
48 | ln -s ${IMAGE_NAME}.hddimg ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.img | 48 | ln -s ${IMAGE_NAME}.hddimg ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.img |
49 | } | 49 | } |
50 | |||
51 | IMAGE_DEPENDS_tegraflash_append = " parted-native:do_populate_sysroot" | ||
52 | create_tegraflash_pkg_prepend() { | ||
53 | # Create partition table | ||
54 | SDCARD=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.img | ||
55 | SDCARD_ROOTFS=${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.ext3 | ||
56 | SDCARD_SIZE=$(expr ${IMAGE_ROOTFS_ALIGNMENT} + $ROOTFS_SIZE + ${IMAGE_ROOTFS_ALIGNMENT}) | ||
57 | |||
58 | dd if=/dev/zero of=${SDCARD} bs=1 count=0 seek=$(expr 1024 \* ${SDCARD_SIZE}) | ||
59 | |||
60 | parted -s ${SDCARD} mklabel msdos | ||
61 | parted -s ${SDCARD} unit KiB mkpart primary ${IMAGE_ROOTFS_ALIGNMENT} $(expr ${IMAGE_ROOTFS_ALIGNMENT} \+ ${ROOTFS_SIZE}) | ||
62 | parted ${SDCARD} print | ||
63 | |||
64 | dd if=${SDCARD_ROOTFS} of=${SDCARD} conv=notrunc,fsync seek=1 bs=$(expr ${IMAGE_ROOTFS_ALIGNMENT} \* 1024) | ||
65 | |||
66 | rm -f ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.img | ||
67 | ln -s ${IMAGE_NAME}.img ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.img | ||
68 | } | ||
diff --git a/conf/bblayers.conf.jetson.sample b/conf/bblayers.conf.jetson.sample new file mode 100644 index 0000000..969f071 --- /dev/null +++ b/conf/bblayers.conf.jetson.sample | |||
@@ -0,0 +1,51 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf | ||
31 | # changes incompatibly | ||
32 | POKY_BBLAYERS_CONF_VERSION = "2" | ||
33 | |||
34 | BBPATH = "${TOPDIR}" | ||
35 | BBFILES ?= "" | ||
36 | BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}" | ||
37 | |||
38 | BBLAYERS ?= " \ | ||
39 | ${BSPDIR}/sources/poky/meta \ | ||
40 | ${BSPDIR}/sources/poky/meta-poky \ | ||
41 | ${BSPDIR}/sources/meta-tegra \ | ||
42 | ${BSPDIR}/sources/meta-openembedded/meta-oe \ | ||
43 | ${BSPDIR}/sources/meta-openembedded/meta-python \ | ||
44 | ${BSPDIR}/sources/meta-openembedded/meta-networking \ | ||
45 | ${BSPDIR}/sources/meta-openembedded/meta-initramfs \ | ||
46 | ${BSPDIR}/sources/meta-openembedded/meta-multimedia \ | ||
47 | ${BSPDIR}/sources/meta-boot2qt \ | ||
48 | ${BSPDIR}/sources/meta-boot2qt/meta-tegra-extras \ | ||
49 | ${BSPDIR}/sources/meta-mingw \ | ||
50 | ${BSPDIR}/sources/meta-qt5 \ | ||
51 | " | ||
diff --git a/conf/distro/include/jetson-tx1.conf b/conf/distro/include/jetson-tx1.conf new file mode 100644 index 0000000..840e7fa --- /dev/null +++ b/conf/distro/include/jetson-tx1.conf | |||
@@ -0,0 +1,44 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DEPLOY_CONF_NAME = "NVIDIA Jetson TX1" | ||
31 | DISTRO_FEATURES_DEFAULT += "wayland" | ||
32 | |||
33 | # use mmc0 | ||
34 | ROOTFS_DEVICE = "mmcblk1p1" | ||
35 | |||
36 | IMAGE_CLASSES += "image_types_tegra" | ||
37 | IMAGE_FSTYPES += "tegraflash" | ||
38 | IMAGE_ROOTFS_ALIGNMENT = "1024" | ||
39 | UBOOT_SUFFIX = "bin" | ||
40 | |||
41 | QBSP_IMAGE_CONTENT = "\ | ||
42 | ${IMAGE_LINK_NAME}.img \ | ||
43 | ${IMAGE_LINK_NAME}.conf \ | ||
44 | " | ||
diff --git a/meta-tegra-extras/conf/layer.conf b/meta-tegra-extras/conf/layer.conf new file mode 100644 index 0000000..c170570 --- /dev/null +++ b/meta-tegra-extras/conf/layer.conf | |||
@@ -0,0 +1,40 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # We have a conf and classes directory, append to BBPATH | ||
31 | BBPATH .= ":${LAYERDIR}" | ||
32 | |||
33 | # We have a recipes directory, add to BBFILES | ||
34 | BBFILES += "${LAYERDIR}/recipes*/*/*.bb \ | ||
35 | ${LAYERDIR}/recipes*/*/*.bbappend \ | ||
36 | " | ||
37 | |||
38 | BBFILE_COLLECTIONS += "b2qt_tegra" | ||
39 | BBFILE_PATTERN_b2qt_tegra := "^${LAYERDIR}/" | ||
40 | BBFILE_PRIORITY_b2qt_tegra = "20" | ||
diff --git a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend new file mode 100644 index 0000000..940c931 --- /dev/null +++ b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | do_install_append() { | ||
31 | rm -f ${D}${libdir}/libdrm.so.2 | ||
32 | } | ||
diff --git a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend new file mode 100644 index 0000000..8770c65 --- /dev/null +++ b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend | |||
@@ -0,0 +1,30 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | PACKAGECONFIG += "kms" | ||
diff --git a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend new file mode 100644 index 0000000..32a93ab --- /dev/null +++ b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend | |||
@@ -0,0 +1,34 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa', '', d)}" | ||
31 | |||
32 | do_install_append() { | ||
33 | install -m 0644 ${DRVROOT}/tegra/libdrm* ${D}${libdir} | ||
34 | } | ||
diff --git a/recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri b/recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri new file mode 100644 index 0000000..d4c14ca --- /dev/null +++ b/recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri | |||
@@ -0,0 +1,4 @@ | |||
1 | QMAKE_PLATFORM += boot2qt | ||
2 | |||
3 | QT_QPA_DEFAULT_PLATFORM = eglfs | ||
4 | EGLFS_DEVICE_INTEGRATION = eglfs_kms_egldevice | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 4d82e47..1d99d3c 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -11,6 +11,7 @@ | |||
11 | <remote fetch="ssh://codereview.qt-project.org/yocto" name="gerrit"/> | 11 | <remote fetch="ssh://codereview.qt-project.org/yocto" name="gerrit"/> |
12 | <remote fetch="git://git.yoctoproject.org" name="intel"/> | 12 | <remote fetch="git://git.yoctoproject.org" name="intel"/> |
13 | <remote fetch="git://github.com/openembedded" name="oe-mirror"/> | 13 | <remote fetch="git://github.com/openembedded" name="oe-mirror"/> |
14 | <remote fetch="git://github.com/madisongh" name="madisongh"/> | ||
14 | <remote fetch="ssh://git@git.qt.io/boot2qt" name="playground"/> | 15 | <remote fetch="ssh://git@git.qt.io/boot2qt" name="playground"/> |
15 | 16 | ||
16 | <project name="poky" | 17 | <project name="poky" |
@@ -60,6 +61,11 @@ | |||
60 | revision="d20e5bffb582c6bfabdadc22e903df86c8cfd66b" | 61 | revision="d20e5bffb582c6bfabdadc22e903df86c8cfd66b" |
61 | path="sources/meta-renesas" | 62 | path="sources/meta-renesas" |
62 | groups="notdefault,external,renesas"/> | 63 | groups="notdefault,external,renesas"/> |
64 | <project name="meta-tegra" | ||
65 | remote="madisongh" | ||
66 | revision="9f5ffd3f8320ec3379e63e75e7c47328920751d5" | ||
67 | path="sources/meta-tegra" | ||
68 | groups="notdefault,external,jetson"/> | ||
63 | 69 | ||
64 | <project name="nvidia-layer" | 70 | <project name="nvidia-layer" |
65 | remote="playground" | 71 | remote="playground" |
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index 2f8264b..d9a6713 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -83,6 +83,9 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | |||
83 | emulator) | 83 | emulator) |
84 | LAYERSCONF="bblayers.conf.emulator.sample" | 84 | LAYERSCONF="bblayers.conf.emulator.sample" |
85 | ;; | 85 | ;; |
86 | jetson-tx1|jetson-tk1) | ||
87 | LAYERSCONF="bblayers.conf.jetson.sample" | ||
88 | ;; | ||
86 | *) | 89 | *) |
87 | LAYERSCONF="bblayers.conf.sample" | 90 | LAYERSCONF="bblayers.conf.sample" |
88 | echo "Unknown MACHINE, bblayers.conf might need manual editing" | 91 | echo "Unknown MACHINE, bblayers.conf might need manual editing" |