summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch42
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend5
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch
new file mode 100644
index 0000000..e8ac286
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch
@@ -0,0 +1,42 @@
1From 524e178f97a72e9dbc81486b1af44c5749bc698b Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Wed, 27 Jan 2016 13:07:39 +0200
4Subject: [PATCH] Add support for koe tx31d200vm0baa display
5
6---
7 arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi | 12 ++++++++++++
8 1 file changed, 12 insertions(+)
9
10diff --git a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
11index 1a2a358..de01d23 100644
12--- a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
13+++ b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
14@@ -393,6 +393,7 @@
15 mxcfb1 = &fb_lvds;
16 mxcfb2 = &fb_lcd;
17 t_lvds = &t_lvds;
18+ koe = &koe;
19 };
20
21 clocks {
22@@ -955,6 +956,17 @@
23 hsync-len = <96>;
24 vsync-len = <2>;
25 };
26+ koe: tx31d200vm0baa {
27+ clock-frequency = <28000000>;
28+ hactive = <1280>;
29+ vactive = <480>;
30+ hback-porch = <200>;
31+ hfront-porch = <120>;
32+ vback-porch = <30>;
33+ vfront-porch = <20>;
34+ hsync-len = <0>;
35+ vsync-len = <0>;
36+ };
37 };
38 };
39 };
40--
411.9.1
42
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend
index 8059c93..1f23439 100644
--- a/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend
@@ -20,5 +20,10 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
24SRC_URI += " \
25 file://0001-Add-support-for-koe-tx31d200vm0baa-display.patch \
26 "
27
23# kernel image files are not needed in the image 28# kernel image files are not needed in the image
24RDEPENDS_kernel-base = "" 29RDEPENDS_kernel-base = ""