summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend50
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend24
-rw-r--r--scripts/manifest.xml4
3 files changed, 26 insertions, 52 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend
deleted file mode 100644
index c25739b..0000000
--- a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend
+++ /dev/null
@@ -1,50 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/../../../recipes/linux/linux:"
24SRC_URI += "\
25 file://ARM-perf-add-support-for-perf-registers-API.diff \
26 file://ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch \
27 "
28
29# kernel image files are not needed in the image
30RDEPENDS_kernel-base = ""
31
32do_configure_prepend() {
33 # fix imx-vpu break on video decoding
34 echo "CONFIG_VMSPLIT_2G=y" >> ${WORKDIR}/defconfig
35
36 # include H4 UART for Broadcom BT on Nitrogen6_Lite
37 echo "CONFIG_BT_HCIUART_H4=y" >> ${WORKDIR}/defconfig
38
39 # include Broadcom WiFi for Nitrogen6_Lite
40 echo "CONFIG_BRCMFMAC=m" >> ${WORKDIR}/defconfig
41
42 # include LEDS_GPIO for Nitrogen6_Lite
43 echo "CONFIG_LEDS_GPIO=y" >> ${WORKDIR}/defconfig
44
45 # enable uvcvideo module
46 echo "CONFIG_MEDIA_USB_SUPPORT=y" >> ${WORKDIR}/defconfig
47 echo "CONFIG_USB_VIDEO_CLASS=m" >> ${WORKDIR}/defconfig
48
49 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
50}
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend
new file mode 100644
index 0000000..8059c93
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index e7b1c52..6776388 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -29,7 +29,7 @@
29 29
30 <project name="meta-fsl-arm" 30 <project name="meta-fsl-arm"
31 remote="yocto" 31 remote="yocto"
32 revision="f30b056c8f1af3f3122f94dbaa4698da5d620a41" 32 revision="c9f259a4bf8472dfa3ff75f1c3fcbe5e0ded7aaf"
33 path="sources/meta-fsl-arm" 33 path="sources/meta-fsl-arm"
34 groups="notdefault,fsl,toradex,architech,ti,bbb"/> 34 groups="notdefault,fsl,toradex,architech,ti,bbb"/>
35 <project name="meta-ti" 35 <project name="meta-ti"
@@ -44,7 +44,7 @@
44 groups="notdefault,rpi"/> 44 groups="notdefault,rpi"/>
45 <project name="meta-fsl-arm-extra" 45 <project name="meta-fsl-arm-extra"
46 remote="freescale" 46 remote="freescale"
47 revision="c0ff75e85bcbd616362c21e501dc6df187612cf9" 47 revision="ad90ca98459f5de9483bb3ba5a81be0a67b078c3"
48 path="sources/meta-fsl-arm-extra" 48 path="sources/meta-fsl-arm-extra"
49 groups="notdefault,fsl,toradex,architech"/> 49 groups="notdefault,fsl,toradex,architech"/>
50 <project name="meta-beagleboard" 50 <project name="meta-beagleboard"