summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xb2qt-init-build-env3
-rw-r--r--conf/bblayers.conf.nvidia-logan.sample48
-rw-r--r--conf/distro/include/nvidia-logan.conf39
-rw-r--r--meta-nvidia-logan-extras/conf/layer.conf33
-rw-r--r--meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend33
-rw-r--r--meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf4
-rw-r--r--meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend24
-rw-r--r--meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend24
-rw-r--r--recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri11
-rw-r--r--recipes/adbd/files/nvidia-logan/adb-init46
-rw-r--r--recipes/adbd/files/nvidia-logan/defaults4
-rw-r--r--scripts/manifest.xml11
-rw-r--r--scripts/manifest_fido.xml11
-rwxr-xr-xscripts/setup-environment.sh3
14 files changed, 294 insertions, 0 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index 9c67a64..709b0b9 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -114,6 +114,9 @@ get_groups() {
114 nuc) 114 nuc)
115 PROJECT_GROUPS="nuc" 115 PROJECT_GROUPS="nuc"
116 ;; 116 ;;
117 nvidia-logan)
118 PROJECT_GROUPS="nvidia-logan"
119 ;;
117 emulator) 120 emulator)
118 PROJECT_GROUPS="emulator" 121 PROJECT_GROUPS="emulator"
119 ;; 122 ;;
diff --git a/conf/bblayers.conf.nvidia-logan.sample b/conf/bblayers.conf.nvidia-logan.sample
new file mode 100644
index 0000000..1df641c
--- /dev/null
+++ b/conf/bblayers.conf.nvidia-logan.sample
@@ -0,0 +1,48 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
24# changes incompatibly
25LCONF_VERSION = "6"
26
27BBPATH = "${TOPDIR}"
28BBFILES ?= ""
29BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}"
30
31BBLAYERS ?= " \
32 ${BSPDIR}/sources/poky/meta \
33 ${BSPDIR}/sources/poky/meta-yocto \
34 ${BSPDIR}/sources/meta-tegra \
35 ${BSPDIR}/sources/meta-openembedded/meta-oe \
36 ${BSPDIR}/sources/meta-openembedded/meta-python \
37 ${BSPDIR}/sources/meta-openembedded/meta-networking \
38 ${BSPDIR}/sources/meta-openembedded/meta-initramfs \
39 ${BSPDIR}/sources/meta-qt5 \
40 ${BSPDIR}/sources/meta-openembedded/meta-ruby \
41 ${BSPDIR}/sources/meta-b2qt \
42 ${BSPDIR}/sources/meta-b2qt/meta-nvidia-logan-extras \
43 "
44
45BBLAYERS_NON_REMOVABLE ?= " \
46 ${BSPDIR}/sources/poky/meta \
47 ${BSPDIR}/sources/poky/meta-yocto \
48 "
diff --git a/conf/distro/include/nvidia-logan.conf b/conf/distro/include/nvidia-logan.conf
new file mode 100644
index 0000000..c39d757
--- /dev/null
+++ b/conf/distro/include/nvidia-logan.conf
@@ -0,0 +1,39 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DISTRO_FEATURES_remove += "wayland"
24
25MACHINE_EXTRA_INSTALL = "\
26 libegl \
27 libgles2 \
28 tegra-firmware-gk20a \
29 graphics-fw \
30 libdrm-nv \
31"
32
33MACHINE_EXTRA_INSTALL_SDK = "\
34 libegl-dev \
35 libgles2-dev \
36 graphics-headers-dev \
37 libdrm-nv-dev \
38"
39
diff --git a/meta-nvidia-logan-extras/conf/layer.conf b/meta-nvidia-logan-extras/conf/layer.conf
new file mode 100644
index 0000000..0fc22ca
--- /dev/null
+++ b/meta-nvidia-logan-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29"
30
31BBFILE_COLLECTIONS += "b2qt_nvidia-logan"
32BBFILE_PATTERN_b2qt_nvidia-logan := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_nvidia-logan = "20"
diff --git a/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend
new file mode 100644
index 0000000..becde5f
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24
25FILES_${PN} += "etc/connman/main.conf"
26
27SRC_URI += "file://main.conf \
28 "
29
30do_install_append() {
31 install -d ${D}${sysconfdir}/connman
32 install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf
33}
diff --git a/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
new file mode 100644
index 0000000..a1e45b9
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
@@ -0,0 +1,4 @@
1[General]
2PreferredTechnologies=ethernet,wifi,cellular
3NetworkInterfaceBlacklist=eth0
4
diff --git a/meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend b/meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend
new file mode 100644
index 0000000..1cb7143
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DEPENDS += "graphics-headers"
24
diff --git a/meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend
new file mode 100644
index 0000000..78453ef
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM"
24
diff --git a/recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri b/recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri
new file mode 100644
index 0000000..6554742
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri
@@ -0,0 +1,11 @@
1TK1_CFLAGS = -DWIN_INTERFACE_CUSTOM
2QMAKE_LIBS_EGL += -lEGL
3QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL
4QMAKE_CFLAGS += $$TK1_CFLAGS
5QMAKE_CXXFLAGS += $$TK1_CFLAGS
6
7QMAKE_PLATFORM += boot2qt
8
9QT_QPA_DEFAULT_PLATFORM = eglfs
10EGLFS_DEVICE_INTEGRATION = eglfs_kms_egldevice
11
diff --git a/recipes/adbd/files/nvidia-logan/adb-init b/recipes/adbd/files/nvidia-logan/adb-init
new file mode 100644
index 0000000..1be08c8
--- /dev/null
+++ b/recipes/adbd/files/nvidia-logan/adb-init
@@ -0,0 +1,46 @@
1#!/bin/sh
2
3DAEMON=/usr/bin/adbd
4
5. /etc/default/adbd
6
7case "$1" in
8start)
9 if [ "$USE_ETHERNET" = "no" ]; then
10 echo 0 > /sys/class/android_usb/android0/enable
11 sleep 1
12 echo ${SERIAL} > /sys/class/android_usb/android0/iSerial
13 echo ${VENDOR} > /sys/class/android_usb/android0/idVendor
14 echo ${PRODUCT} > /sys/class/android_usb/android0/idProduct
15 echo ffs > /sys/class/android_usb/android0/functions
16 echo adb >/sys/class/android_usb/android0/f_ffs/aliases
17 echo 1 > /sys/class/android_usb/android0/enable
18
19 if [ ! -d "/dev/usb-ffs" ]; then
20 mkdir /dev/usb-ffs
21 mkdir /dev/usb-ffs/adb
22 fi
23 mount -t functionfs adb /dev/usb-ffs/adb -o uid=2000,gid=2000
24 fi
25 start-stop-daemon --start --quiet --exec $DAEMON &
26 ;;
27stop)
28 start-stop-daemon --stop --quiet --exec $DAEMON
29 if [ "$USE_ETHERNET" = "no" ]; then
30 sleep 1
31 if mount | grep /dev/usb-ffs/adb > /dev/null; then
32 umount /dev/usb-ffs/adb
33 fi
34 fi
35 ;;
36restart)
37 start-stop-daemon --stop --quiet --exec $DAEMON
38 sleep 1
39 start-stop-daemon --start --quiet --exec $DAEMON &
40 ;;
41*)
42 echo "Usage: $0 {start|stop|restart}"
43 exit 1
44esac
45exit 0
46
diff --git a/recipes/adbd/files/nvidia-logan/defaults b/recipes/adbd/files/nvidia-logan/defaults
new file mode 100644
index 0000000..93bba63
--- /dev/null
+++ b/recipes/adbd/files/nvidia-logan/defaults
@@ -0,0 +1,4 @@
1VENDOR=0955
2PRODUCT=7940
3SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth1/address)
4USE_ETHERNET=no
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 927a2f3..e7b1c52 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -12,6 +12,7 @@
12 <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/> 12 <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/>
13 <remote fetch="git://git.yoctoproject.org" name="intel"/> 13 <remote fetch="git://git.yoctoproject.org" name="intel"/>
14 <remote fetch="git://github.com/openembedded" name="oe-mirror"/> 14 <remote fetch="git://github.com/openembedded" name="oe-mirror"/>
15 <remote fetch="git://playground.ci.local" name="playground"/>
15 16
16 <project name="poky" 17 <project name="poky"
17 remote="yocto" 18 remote="yocto"
@@ -66,6 +67,16 @@
66 revision="ead0a5c115e632015d8358f4f304ec8908732f5f" 67 revision="ead0a5c115e632015d8358f4f304ec8908732f5f"
67 path="sources/meta-intel" 68 path="sources/meta-intel"
68 groups="notdefault,nuc"/> 69 groups="notdefault,nuc"/>
70 <project name="meta-tegra"
71 remote="playground"
72 revision="96fc69180aa359065d2d587ba0fca671d9e5a89b"
73 path="sources/meta-tegra"
74 groups="notdefault,nvidia-logan"/>
75 <project name="jetson-tk1-pro"
76 remote="playground"
77 revision="a376c795d5361fda4ea5f19feecc23ab7e753646"
78 path="sources/jetson-tk1-pro"
79 groups="notdefault,nvidia-logan"/>
69 80
70</manifest> 81</manifest>
71 82
diff --git a/scripts/manifest_fido.xml b/scripts/manifest_fido.xml
index 2a1c78e..e633e35 100644
--- a/scripts/manifest_fido.xml
+++ b/scripts/manifest_fido.xml
@@ -12,6 +12,7 @@
12 <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/> 12 <remote fetch="git://github.com/meta-qt5" name="meta-qt5"/>
13 <remote fetch="git://git.yoctoproject.org" name="intel"/> 13 <remote fetch="git://git.yoctoproject.org" name="intel"/>
14 <remote fetch="git://github.com/openembedded" name="oe-mirror"/> 14 <remote fetch="git://github.com/openembedded" name="oe-mirror"/>
15 <remote fetch="git://git://playground.ci.local" name="playground"/>
15 16
16 <project name="poky" 17 <project name="poky"
17 remote="yocto" 18 remote="yocto"
@@ -66,6 +67,16 @@
66 revision="fido" 67 revision="fido"
67 path="sources/meta-intel" 68 path="sources/meta-intel"
68 groups="notdefault,nuc"/> 69 groups="notdefault,nuc"/>
70 <project name="meta-tegra"
71 remote="playground"
72 revision="master"
73 path="sources/meta-tegra"
74 groups="notdefault,nvidia-logan"/>
75 <project name="jetson-tk1-pro"
76 remote="playground"
77 revision="master"
78 path="sources/jetson-tk1-pro"
79 groups="notdefault,nvidia-logan"/>
69 80
70</manifest> 81</manifest>
71 82
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index da7ec69..0736d0d 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -70,6 +70,9 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
70 nuc) 70 nuc)
71 LAYERSCONF="bblayers.conf.nuc.sample" 71 LAYERSCONF="bblayers.conf.nuc.sample"
72 ;; 72 ;;
73 nvidia-logan)
74 LAYERSCONF="bblayers.conf.nvidia-logan.sample"
75 ;;
73 emulator) 76 emulator)
74 LAYERSCONF="bblayers.conf.emulator.sample" 77 LAYERSCONF="bblayers.conf.emulator.sample"
75 ;; 78 ;;