summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/apalis-imx6.conf1
-rw-r--r--conf/distro/include/colibri-vf.conf9
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch27
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb18
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/flash_mmc.scr2
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr6
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr6
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr2
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr3
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch45
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend3
-rw-r--r--recipes/fonts/otf-noto.bb23
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb1
13 files changed, 134 insertions, 12 deletions
diff --git a/conf/distro/include/apalis-imx6.conf b/conf/distro/include/apalis-imx6.conf
index 9865549..ee811be 100644
--- a/conf/distro/include/apalis-imx6.conf
+++ b/conf/distro/include/apalis-imx6.conf
@@ -30,6 +30,7 @@ BOOTFS_CONTENT = "\
30 ${KERNEL_IMAGETYPE}-imx6q-apalis-eval_v1_0.dtb:imx6q-apalis-eval_v1_0.dtb \ 30 ${KERNEL_IMAGETYPE}-imx6q-apalis-eval_v1_0.dtb:imx6q-apalis-eval_v1_0.dtb \
31 u-boot-${MACHINE}.imx:u-boot.imx \ 31 u-boot-${MACHINE}.imx:u-boot.imx \
32 flash_mmc-${MACHINE}.img:flash_mmc.img \ 32 flash_mmc-${MACHINE}.img:flash_mmc.img \
33 flash_blk-${MACHINE}.img:flash_blk.img \
33 " 34 "
34BOOTFS_DEPENDS = "u-boot:do_deploy u-boot-script-toradex:do_deploy virtual/kernel:do_deploy" 35BOOTFS_DEPENDS = "u-boot:do_deploy u-boot-script-toradex:do_deploy virtual/kernel:do_deploy"
35 36
diff --git a/conf/distro/include/colibri-vf.conf b/conf/distro/include/colibri-vf.conf
index c6c818a..d92410c 100644
--- a/conf/distro/include/colibri-vf.conf
+++ b/conf/distro/include/colibri-vf.conf
@@ -23,12 +23,11 @@
23include conf/distro/include/toradex.inc 23include conf/distro/include/toradex.inc
24 24
25BOOTFS_CONTENT = "\ 25BOOTFS_CONTENT = "\
26 ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \ 26 u-boot-nand-${MACHINE}.imx:u-boot-nand.imx \
27 ${KERNEL_IMAGETYPE}-vf500-colibri-eval-v3.dtb:vf500-colibri-eval-v3.dtb \ 27 flash_mmc-${MACHINE}.img:flash_mmc.img \
28 ${KERNEL_IMAGETYPE}-vf610-colibri-eval-v3.dtb:vf610-colibri-eval-v3.dtb \ 28 flash_blk-${MACHINE}.img:flash_blk.img \
29 u-boot-${MACHINE}.imx:u-boot.imx \
30 " 29 "
31BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy" 30BOOTFS_DEPENDS = "u-boot:do_deploy u-boot-script-toradex:do_deploy virtual/kernel:do_deploy"
32 31
33PREFERRED_PROVIDER_virtual/egl = "opengldummy" 32PREFERRED_PROVIDER_virtual/egl = "opengldummy"
34PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy" 33PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy"
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch
new file mode 100644
index 0000000..43edec3
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch
@@ -0,0 +1,27 @@
1From 30c67656c09f49608bbadb75e365d1d3da36cc70 Mon Sep 17 00:00:00 2001
2From: Andy Nichols <andy.nichols@theqtcompany.com>
3Date: Wed, 18 Feb 2015 14:28:14 +0100
4Subject: [PATCH] Allow builds with GCC 4.8
5
6---
7 arch/arm/kernel/asm-offsets.c | 4 ----
8 1 file changed, 4 deletions(-)
9
10diff --git a/arch/arm/kernel/asm-offsets.c b/arch/arm/kernel/asm-offsets.c
11index 2d2d608..6f8e79c 100644
12--- a/arch/arm/kernel/asm-offsets.c
13+++ b/arch/arm/kernel/asm-offsets.c
14@@ -49,10 +49,6 @@
15 #error Your compiler is too buggy; it is known to miscompile kernels.
16 #error Known good compilers: 3.3, 4.x
17 #endif
18-#if GCC_VERSION >= 40800 && GCC_VERSION < 40803
19-#error Your compiler is too buggy; it is known to miscompile kernels
20-#error and result in filesystem corruption and oopses.
21-#endif
22 #endif
23
24 int main(void)
25--
261.9.1
27
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
index b83e6a0..92ea3bd 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
@@ -25,16 +25,21 @@ DEPENDS = "u-boot-mkimage-native"
25 25
26PV = "v2.3" 26PV = "v2.3"
27 27
28SRC_URI = "file://flash_mmc.scr" 28SRC_URI = " \
29 file://flash_mmc.scr \
30 file://flash_blk.scr \
31 "
29 32
30inherit deploy 33inherit deploy
31 34
32UPDATESCRIPT = "${WORKDIR}/flash_mmc.scr"
33
34do_mkimage () { 35do_mkimage () {
35 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ 36 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
36 -n "update script" -d ${UPDATESCRIPT} \ 37 -n "update script" -d ${WORKDIR}/flash_mmc.scr \
37 flash_mmc.img 38 flash_mmc.img
39
40 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
41 -n "update script" -d ${WORKDIR}/flash_blk.scr \
42 flash_blk.img
38} 43}
39 44
40addtask mkimage after do_compile before do_install 45addtask mkimage after do_compile before do_install
@@ -42,10 +47,13 @@ addtask mkimage after do_compile before do_install
42do_deploy () { 47do_deploy () {
43 install -d ${DEPLOYDIR} 48 install -d ${DEPLOYDIR}
44 install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img 49 install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img
50 install ${S}/flash_blk.img ${DEPLOYDIR}/flash_blk-${MACHINE}-${PV}-${PR}.img
45 51
46 cd ${DEPLOYDIR} 52 cd ${DEPLOYDIR}
47 rm -f flash_mmc-${MACHINE}.img 53 rm -f flash_mmc-${MACHINE}.img
48 ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img 54 ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img
55 rm -f flash_blk-${MACHINE}.img
56 ln -sf flash_blk-${MACHINE}-${PV}-${PR}.img flash_blk-${MACHINE}.img
49} 57}
50 58
51addtask deploy after do_install before do_build 59addtask deploy after do_install before do_build
@@ -55,4 +63,4 @@ do_install[noexec] = "1"
55do_populate_sysroot[noexec] = "1" 63do_populate_sysroot[noexec] = "1"
56 64
57PACKAGE_ARCH = "${MACHINE_ARCH}" 65PACKAGE_ARCH = "${MACHINE_ARCH}"
58COMPATIBLE_MACHINE = "(apalis-imx6)" 66COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf)"
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/flash_mmc.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/flash_mmc.scr
deleted file mode 100644
index 5b7dc80..0000000
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/flash_mmc.scr
+++ /dev/null
@@ -1,2 +0,0 @@
1setenv update_uboot 'fatload mmc ${drive}:1 ${loadaddr} u-boot.imx && setexpr blkcnt $filesize + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200 && mmc dev 0 && mmc write ${loadaddr} 2 ${blkcnt}'
2echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr
new file mode 100644
index 0000000..ee87e85
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr
@@ -0,0 +1,6 @@
1test -n ${interface} || setenv interface mmc
2test -n ${drive} || setenv drive 1
3
4setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200'
5setenv update_uboot 'fatload ${interface} ${drive}:1 ${loadaddr} u-boot.imx && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}'
6echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr
new file mode 100644
index 0000000..207c7db
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr
@@ -0,0 +1,6 @@
1#flash_mmc has been renamed to flash_blk, ensure compatibilty when updating from older versions
2test -n ${interface} || setenv interface mmc
3test -n ${drive} || setenv drive 1
4
5fatload ${interface} ${drive}:1 ${loadaddr} flash_blk.img
6source ${loadaddr}
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
new file mode 100644
index 0000000..5e31380
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
@@ -0,0 +1,2 @@
1setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} u-boot-nand.imx && nand erase.part u-boot && nand erase.part u-boot-env && nand write ${loadaddr} u-boot'
2echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr
new file mode 100644
index 0000000..e0770a0
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr
@@ -0,0 +1,3 @@
1setenv interface mmc
2fatload ${interface} 0:1 ${loadaddr} flash_blk.img
3source ${loadaddr}
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch
new file mode 100644
index 0000000..2e72ff6
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch
@@ -0,0 +1,45 @@
1From a388755704c3f8c4336939f3c868942d68b1e256 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Thu, 28 May 2015 09:06:54 +0300
4Subject: [PATCH] colibri vf: enable sdboot by default
5
6Run sdboot first, update dtb file location to /boot/ and
7remove console message from tty1
8---
9 include/configs/colibri_vf.h | 6 +++---
10 1 file changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h
13index feea159..b080510 100644
14--- a/include/configs/colibri_vf.h
15+++ b/include/configs/colibri_vf.h
16@@ -135,7 +135,7 @@
17 "load mmc 0:2 ${kernel_addr_r} /boot/${kernel_file} && " \
18 "run sddtbload; bootz ${kernel_addr_r} - ${dtbparam}\0" \
19 "sddtbload=setenv dtbparam; load mmc 0:2 ${fdt_addr_r} " \
20- "${soc}-colibri-${fdt_board}.dtb && " \
21+ "/boot/${soc}-colibri-${fdt_board}.dtb && " \
22 "setenv dtbparam ${fdt_addr_r}\0"
23
24 #define NFS_BOOTCMD \
25@@ -160,7 +160,7 @@
26 "/boot/${soc}-colibri-${fdt_board}.dtb && " \
27 "setenv dtbparam ${fdt_addr_r}\0"
28
29-#define CONFIG_BOOTCOMMAND "run ubiboot; run sdboot; run nfsboot"
30+#define CONFIG_BOOTCOMMAND "run sdboot; run ubiboot; run nfsboot"
31
32 #define DFU_ALT_NAND_INFO "vf-bcb part 0,1;u-boot part 0,2;ubi part 0,4"
33
34@@ -173,7 +173,7 @@
35 "defargs=\0" \
36 "console=ttyLP0\0" \
37 "setup=setenv setupargs fec_mac=${ethaddr} consoleblank=0 " \
38- "console=tty1 console=${console},${baudrate}n8 ${memargs}\0" \
39+ "console=${console},${baudrate}n8 ${memargs}\0" \
40 "setsdupdate=mmc rescan && set interface mmc && " \
41 "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \
42 "source ${loadaddr}\0" \
43--
441.9.1
45
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
index d1675de..1c2e561 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
@@ -24,3 +24,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI_append_apalis-imx6 = " \ 24SRC_URI_append_apalis-imx6 = " \
25 file://0001-Update-default-args-for-apalis-imx6.patch \ 25 file://0001-Update-default-args-for-apalis-imx6.patch \
26 " 26 "
27SRC_URI_append_colibri-vf = " \
28 file://0001-colibri-vf-enable-sdboot-by-default.patch \
29 "
diff --git a/recipes/fonts/otf-noto.bb b/recipes/fonts/otf-noto.bb
new file mode 100644
index 0000000..266010c
--- /dev/null
+++ b/recipes/fonts/otf-noto.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Noto Sans CJK"
2SECTION = "fonts"
3HOMEPAGE = "http://www.google.com/get/noto"
4LICENSE = "Apache-2.0"
5# see https://code.google.com/p/noto/issues/detail?id=331
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8INHIBIT_DEFAULT_DEPS = "1"
9
10inherit allarch fontcache
11
12SRC_URI = "http://www.google.com/get/noto/pkgs/NotoSansCJKSC-hinted.zip"
13
14SRC_URI[md5sum] = "9c59b0a684b03d3220dc05c6f7d4a097"
15SRC_URI[sha256sum] = "c815b154a57877bfc3c9baa9650f22217e509bddc73f5433f640d875ae6f35e0"
16
17do_install() {
18 install -m 0644 -d ${D}${datadir}/fonts/otf/noto
19 install -m 0644 ${WORKDIR}/*.otf ${D}${datadir}/fonts/otf/noto
20}
21
22PACKAGES = "${PN}"
23FILES_${PN} += "${datadir}/fonts/otf/noto"
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index a038b86..c5078c2 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -51,6 +51,7 @@ RDEPENDS_${PN} = "\
51 ttf-dejavu-common \ 51 ttf-dejavu-common \
52 ttf-dejavu-sans \ 52 ttf-dejavu-sans \
53 dbus-session-init \ 53 dbus-session-init \
54 otf-noto \
54 libmysqlclient \ 55 libmysqlclient \
55 libpq \ 56 libpq \
56 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \ 57 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \