summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/deploy-conf.bbclass8
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb2
2 files changed, 7 insertions, 3 deletions
diff --git a/classes/deploy-conf.bbclass b/classes/deploy-conf.bbclass
index 228b1e2..22c6ef7 100644
--- a/classes/deploy-conf.bbclass
+++ b/classes/deploy-conf.bbclass
@@ -29,15 +29,19 @@
29 29
30inherit image_types 30inherit image_types
31 31
32IMAGE_DEPENDS_conf = "qtbase-native"
33
32DEPLOY_CONF_NAME ?= "${MACHINE}" 34DEPLOY_CONF_NAME ?= "${MACHINE}"
33DEPLOY_CONF_TYPE ?= "Boot2Qt" 35DEPLOY_CONF_TYPE ?= "Boot2Qt"
34 36
35IMAGE_CMD_conf() { 37IMAGE_CMD_conf() {
38 QT_VERSION=$(qmake -query QT_VERSION)
36 cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF 39 cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF
37[${DEPLOY_CONF_TYPE} | ${DEPLOY_CONF_NAME}] 40[${DEPLOY_CONF_NAME}]
38platform=${MACHINE} 41platform=${MACHINE}
42product=${DEPLOY_CONF_TYPE}
43qt=Qt $QT_VERSION
39os=linux 44os=linux
40board=
41imagefile=${IMAGE_LINK_NAME}.img 45imagefile=${IMAGE_LINK_NAME}.img
42asroot=true 46asroot=true
43EOF 47EOF
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
index 67819d7..7c6c2de 100644
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -32,7 +32,7 @@ LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" 32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33PR = "r0" 33PR = "r0"
34 34
35DEPLOY_CONF_TYPE = "Automotive" 35DEPLOY_CONF_TYPE = "Qt Automotive Suite 2.0.1"
36 36
37IMAGE_FEATURES += "\ 37IMAGE_FEATURES += "\
38 package-management \ 38 package-management \