summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend2
-rw-r--r--meta-ti-extras/recipes/gbm/libgbm_%.bbappend30
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend3
-rw-r--r--recipes/mesa/mesa_%.bbappend1
4 files changed, 35 insertions, 1 deletions
diff --git a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
index 8770c65..602782e 100644
--- a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
+++ b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
@@ -27,4 +27,4 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30PACKAGECONFIG += "kms" 30PACKAGECONFIG += "gbm kms"
diff --git a/meta-ti-extras/recipes/gbm/libgbm_%.bbappend b/meta-ti-extras/recipes/gbm/libgbm_%.bbappend
new file mode 100644
index 0000000..fd11a50
--- /dev/null
+++ b/meta-ti-extras/recipes/gbm/libgbm_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PROVIDES += "virtual/libgbm"
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
index 585e1b5..e997936 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -58,3 +58,6 @@ do_configure_prepend() {
58} 58}
59 59
60SRCREV = "179045f36a16ce2f6cfaad1dbd9443b52b1bf8d3" 60SRCREV = "179045f36a16ce2f6cfaad1dbd9443b52b1bf8d3"
61
62# make other libgbm providers possible
63PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/libgbm"
diff --git a/recipes/mesa/mesa_%.bbappend b/recipes/mesa/mesa_%.bbappend
index fc55a18..35f66f4 100644
--- a/recipes/mesa/mesa_%.bbappend
+++ b/recipes/mesa/mesa_%.bbappend
@@ -28,3 +28,4 @@
28############################################################################ 28############################################################################
29 29
30RDEPENDS_libgles2-mesa-dev += "libgles3-mesa-dev" 30RDEPENDS_libgles2-mesa-dev += "libgles3-mesa-dev"
31PROVIDES += "virtual/libgbm"