summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/internal-build.bbclass4
-rw-r--r--classes/qbsp.bbclass2
-rw-r--r--files/qbsp/base_package.xml2
-rw-r--r--files/qbsp/image_package.xml2
-rw-r--r--files/qbsp/toolchain_installscript.qs17
-rw-r--r--files/qbsp/toolchain_package.xml2
-rw-r--r--meta-nvidia-extras/recipes/ppp/ppp_2.4.%.bbappend (renamed from recipes/ppp/ppp_2.%.bbappend)4
-rw-r--r--recipes-qt/meta/meta-b2qt-automotive-qbsp.bb2
-rw-r--r--recipes-qt/meta/meta-b2qt-embedded-qbsp.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend2
-rw-r--r--recipes/ppp/files/ppp-fix-building-with-linux-4.8.patch23
-rw-r--r--scripts/manifest.xml1
12 files changed, 21 insertions, 42 deletions
diff --git a/classes/internal-build.bbclass b/classes/internal-build.bbclass
index 0f12a78..64c07bf 100644
--- a/classes/internal-build.bbclass
+++ b/classes/internal-build.bbclass
@@ -35,8 +35,8 @@ python enable_internal_build () {
35 return 35 return
36 36
37 e.data.setVar('ENABLE_QTQUICKCOMPILER', "1") 37 e.data.setVar('ENABLE_QTQUICKCOMPILER', "1")
38 e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.intra.qt.io/sstate-caches/${DISTRO_CODENAME}/PATH") 38 e.data.prependVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.intra.qt.io/sstate-caches/${DISTRO_CODENAME}/PATH")
39 e.data.setVar('PREMIRRORS', "\ 39 e.data.prependVar('PREMIRRORS', "\
40 ftp://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \ 40 ftp://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
41 http://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \ 41 http://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
42 https://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \ 42 https://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
diff --git a/classes/qbsp.bbclass b/classes/qbsp.bbclass
index db70fc9..da790bf 100644
--- a/classes/qbsp.bbclass
+++ b/classes/qbsp.bbclass
@@ -84,7 +84,7 @@ patch_installer_files() {
84 -e "s#@RELEASEDATE@#${RELEASEDATE}#" \ 84 -e "s#@RELEASEDATE@#${RELEASEDATE}#" \
85 -e "s#@MACHINE@#${MACHINE}#" \ 85 -e "s#@MACHINE@#${MACHINE}#" \
86 -e "s#@SYSROOT@#${REAL_MULTIMACH_TARGET_SYS}#" \ 86 -e "s#@SYSROOT@#${REAL_MULTIMACH_TARGET_SYS}#" \
87 -e "s#@TARGET@#${TARGET_SYS}#" \ 87 -e "s#@TARGET_SYS@#${TARGET_SYS}#" \
88 -e "s#@ABI@#${ABI}#" \ 88 -e "s#@ABI@#${ABI}#" \
89 -e "s#@INSTALLPATH@#${QBSP_INSTALL_PATH}#" \ 89 -e "s#@INSTALLPATH@#${QBSP_INSTALL_PATH}#" \
90 -e "s#@SDKPATH@#${SDKPATH}#" \ 90 -e "s#@SDKPATH@#${SDKPATH}#" \
diff --git a/files/qbsp/base_package.xml b/files/qbsp/base_package.xml
index 80a02e8..5f16dfa 100644
--- a/files/qbsp/base_package.xml
+++ b/files/qbsp/base_package.xml
@@ -2,7 +2,7 @@
2<Package> 2<Package>
3 <Version>@VERSION@</Version> 3 <Version>@VERSION@</Version>
4 <ReleaseDate>@RELEASEDATE@</ReleaseDate> 4 <ReleaseDate>@RELEASEDATE@</ReleaseDate>
5 <DisplayName>@NAME@</DisplayName> 5 <DisplayName>@TARGET@</DisplayName>
6 <Description>@NAME@ for @TARGET@</Description> 6 <Description>@NAME@ for @TARGET@</Description>
7 <Dependencies>@LICENSEDEPENDENCY@</Dependencies> 7 <Dependencies>@LICENSEDEPENDENCY@</Dependencies>
8</Package> 8</Package>
diff --git a/files/qbsp/image_package.xml b/files/qbsp/image_package.xml
index a3fe0cc..27e5f2e 100644
--- a/files/qbsp/image_package.xml
+++ b/files/qbsp/image_package.xml
@@ -2,7 +2,7 @@
2<Package> 2<Package>
3 <Version>@VERSION@</Version> 3 <Version>@VERSION@</Version>
4 <ReleaseDate>@RELEASEDATE@</ReleaseDate> 4 <ReleaseDate>@RELEASEDATE@</ReleaseDate>
5 <DisplayName>@MACHINE@ Linux System</DisplayName> 5 <DisplayName>@TARGET@ Linux System</DisplayName>
6 <Description>System image for @TARGET@ hardware</Description> 6 <Description>System image for @TARGET@ hardware</Description>
7 <DownloadableArchives>image.7z</DownloadableArchives> 7 <DownloadableArchives>image.7z</DownloadableArchives>
8</Package> 8</Package>
diff --git a/files/qbsp/toolchain_installscript.qs b/files/qbsp/toolchain_installscript.qs
index 15e9570..4afab71 100644
--- a/files/qbsp/toolchain_installscript.qs
+++ b/files/qbsp/toolchain_installscript.qs
@@ -38,6 +38,7 @@ Component.prototype.createOperations = function()
38 var device = "@MACHINE@" 38 var device = "@MACHINE@"
39 var platform = "@NAME@" 39 var platform = "@NAME@"
40 var sysroot = "@SYSROOT@" 40 var sysroot = "@SYSROOT@"
41 var target_sys = "@TARGET_SYS@"
41 var target = "@TARGET@" 42 var target = "@TARGET@"
42 var abi = "@ABI@" 43 var abi = "@ABI@"
43 var installPath = "@INSTALLPATH@/toolchain" 44 var installPath = "@INSTALLPATH@/toolchain"
@@ -71,8 +72,8 @@ Component.prototype.createOperations = function()
71 component.addOperation("Execute", 72 component.addOperation("Execute",
72 ["@SDKToolBinary@", "addTC", 73 ["@SDKToolBinary@", "addTC",
73 "--id", toolchainId + ".gcc", 74 "--id", toolchainId + ".gcc",
74 "--name", "GCC (Boot2Qt " + platform + ")", 75 "--name", "GCC (" + platform + " " + target + ")",
75 "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target + "/" + target + "-gcc" + executableExt, 76 "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target_sys + "/" + target_sys + "-gcc" + executableExt,
76 "--abi", abi, 77 "--abi", abi,
77 "--language", "1", 78 "--language", "1",
78 "UNDOEXECUTE", 79 "UNDOEXECUTE",
@@ -81,8 +82,8 @@ Component.prototype.createOperations = function()
81 component.addOperation("Execute", 82 component.addOperation("Execute",
82 ["@SDKToolBinary@", "addTC", 83 ["@SDKToolBinary@", "addTC",
83 "--id", toolchainId + ".g++", 84 "--id", toolchainId + ".g++",
84 "--name", "G++ (Boot2Qt " + platform + ")", 85 "--name", "G++ (" + platform + " " + target + ")",
85 "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target + "/" + target + "-g++" + executableExt, 86 "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target_sys + "/" + target_sys + "-g++" + executableExt,
86 "--abi", abi, 87 "--abi", abi,
87 "--language", "2", 88 "--language", "2",
88 "UNDOEXECUTE", 89 "UNDOEXECUTE",
@@ -91,9 +92,9 @@ Component.prototype.createOperations = function()
91 component.addOperation("Execute", 92 component.addOperation("Execute",
92 ["@SDKToolBinary@", "addDebugger", 93 ["@SDKToolBinary@", "addDebugger",
93 "--id", debuggerId, 94 "--id", debuggerId,
94 "--name", "GDB (Boot2Qt " + platform + ")", 95 "--name", "GDB (" + platform + " " + target + ")",
95 "--engine", "1", 96 "--engine", "1",
96 "--binary", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target + "/" + target + "-gdb" + executableExt, 97 "--binary", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target_sys + "/" + target_sys + "-gdb" + executableExt,
97 "--abis", abi, 98 "--abis", abi,
98 "UNDOEXECUTE", 99 "UNDOEXECUTE",
99 "@SDKToolBinary@", "rmDebugger", "--id", debuggerId]); 100 "@SDKToolBinary@", "rmDebugger", "--id", debuggerId]);
@@ -101,7 +102,7 @@ Component.prototype.createOperations = function()
101 component.addOperation("Execute", 102 component.addOperation("Execute",
102 ["@SDKToolBinary@", "addQt", 103 ["@SDKToolBinary@", "addQt",
103 "--id", qtId, 104 "--id", qtId,
104 "--name", "Boot2Qt %{Qt:Version} " + platform, 105 "--name", platform + " " + target,
105 "--type", "Qdb.EmbeddedLinuxQt", 106 "--type", "Qdb.EmbeddedLinuxQt",
106 "--qmake", path + "/sysroots/" + hostSysroot + "/usr/bin/qmake" + executableExt, 107 "--qmake", path + "/sysroots/" + hostSysroot + "/usr/bin/qmake" + executableExt,
107 "UNDOEXECUTE", 108 "UNDOEXECUTE",
@@ -110,7 +111,7 @@ Component.prototype.createOperations = function()
110 component.addOperation("Execute", 111 component.addOperation("Execute",
111 ["@SDKToolBinary@", "addKit", 112 ["@SDKToolBinary@", "addKit",
112 "--id", basecomponent, 113 "--id", basecomponent,
113 "--name", "Boot2Qt %{Qt:Version} " + platform, 114 "--name", platform + " " + target,
114 "--mkspec", "devices/linux-oe-generic-g++", 115 "--mkspec", "devices/linux-oe-generic-g++",
115 "--qt", qtId, 116 "--qt", qtId,
116 "--debuggerid", debuggerId, 117 "--debuggerid", debuggerId,
diff --git a/files/qbsp/toolchain_package.xml b/files/qbsp/toolchain_package.xml
index b578fc9..166e09b 100644
--- a/files/qbsp/toolchain_package.xml
+++ b/files/qbsp/toolchain_package.xml
@@ -2,7 +2,7 @@
2<Package> 2<Package>
3 <Version>@VERSION@</Version> 3 <Version>@VERSION@</Version>
4 <ReleaseDate>@RELEASEDATE@</ReleaseDate> 4 <ReleaseDate>@RELEASEDATE@</ReleaseDate>
5 <DisplayName>@MACHINE@ Linux Toolchain</DisplayName> 5 <DisplayName>@TARGET@ Linux Toolchain</DisplayName>
6 <Description>Toolchain and system root for @TARGET@</Description> 6 <Description>Toolchain and system root for @TARGET@</Description>
7 <DownloadableArchives>toolchain.7z</DownloadableArchives> 7 <DownloadableArchives>toolchain.7z</DownloadableArchives>
8 <Dependencies>qt.tools.qtcreator</Dependencies> 8 <Dependencies>qt.tools.qtcreator</Dependencies>
diff --git a/recipes/ppp/ppp_2.%.bbappend b/meta-nvidia-extras/recipes/ppp/ppp_2.4.%.bbappend
index d687518..ca8f573 100644
--- a/recipes/ppp/ppp_2.%.bbappend
+++ b/meta-nvidia-extras/recipes/ppp/ppp_2.4.%.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2017 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -27,4 +27,4 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 30SRC_URI_remove = "file://ppp-fix-building-with-linux-4.8.patch"
diff --git a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
index 9b5c615..5595cc6 100644
--- a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
+++ b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
@@ -40,7 +40,7 @@ inherit qbsp
40 40
41PV := "${@d.getVar('PV', True).split('+')[0]}" 41PV := "${@d.getVar('PV', True).split('+')[0]}"
42 42
43QBSP_NAME = "Qt Automotive" 43QBSP_NAME = "Automotive ${PV}"
44QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" 44QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}"
45QBSP_INSTALLER_COMPONENT = "automotive.10.yocto.${QBSP_MACHINE}" 45QBSP_INSTALLER_COMPONENT = "automotive.10.yocto.${QBSP_MACHINE}"
46QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}" 46QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}"
diff --git a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
index c531633..dc2873f 100644
--- a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
+++ b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
@@ -41,7 +41,7 @@ inherit qbsp
41PV := "${@d.getVar('PV', True).split('+')[0]}" 41PV := "${@d.getVar('PV', True).split('+')[0]}"
42 42
43VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" 43VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}"
44QBSP_NAME = "Boot to Qt" 44QBSP_NAME = "Boot2Qt ${PV}"
45QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" 45QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}"
46QBSP_INSTALLER_COMPONENT = "qt.embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" 46QBSP_INSTALLER_COMPONENT = "qt.embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}"
47QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}" 47QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}"
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
index af38d2c..7685c5a 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -49,6 +49,8 @@ PACKAGECONFIG += " \
49 xkbcommon-evdev \ 49 xkbcommon-evdev \
50 " 50 "
51 51
52PACKAGECONFIG_remove = "tests"
53
52FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 54FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
53 55
54SRC_URI += " \ 56SRC_URI += " \
diff --git a/recipes/ppp/files/ppp-fix-building-with-linux-4.8.patch b/recipes/ppp/files/ppp-fix-building-with-linux-4.8.patch
deleted file mode 100644
index 17e7975..0000000
--- a/recipes/ppp/files/ppp-fix-building-with-linux-4.8.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1diff --git a/pppd/plugins/rp-pppoe/pppoe.h b/pppd/plugins/rp-pppoe/pppoe.h
2index 9ab2eee..96d2794 100644
3--- a/pppd/plugins/rp-pppoe/pppoe.h
4+++ b/pppd/plugins/rp-pppoe/pppoe.h
5@@ -47,6 +47,10 @@
6 #include <sys/socket.h>
7 #endif
8
9+/* This has to be included before Linux 4.8's linux/in.h
10+ * gets dragged in. */
11+#include <netinet/in.h>
12+
13 /* Ugly header files on some Linux boxes... */
14 #if defined(HAVE_LINUX_IF_H)
15 #include <linux/if.h>
16@@ -84,7 +88,6 @@ typedef unsigned long UINT32_t;
17 #include <linux/if_ether.h>
18 #endif
19
20-#include <netinet/in.h>
21
22 #ifdef HAVE_NETINET_IF_ETHER_H
23 #include <sys/types.h>
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 56f083e..1aa053b 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -109,4 +109,3 @@
109 path="sources/meta-smx6" 109 path="sources/meta-smx6"
110 groups="notdefault,internal"/> 110 groups="notdefault,internal"/>
111</manifest> 111</manifest>
112