summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/automotive/gammaray_git.bb6
-rw-r--r--recipes-qt/automotive/neptune-ui/neptune.service4
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb14
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb6
-rw-r--r--recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch29
-rw-r--r--recipes-qt/automotive/qtivi_git.bb5
6 files changed, 48 insertions, 16 deletions
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb
index 6317040..1de4c09 100644
--- a/recipes-qt/automotive/gammaray_git.bb
+++ b/recipes-qt/automotive/gammaray_git.bb
@@ -8,11 +8,11 @@ inherit cmake_qt5
8 8
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" 9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10 10
11BRANCH = "2.7" 11BRANCH = "5.9"
12SRCREV = "a22da6d63cab08f3ef8588611fdbda3f96731efe" 12SRCREV = "ff53d7328d6db17dcb6486bb98b02a2f107b4066"
13PV = "${BRANCH}+git${SRCPV}" 13PV = "${BRANCH}+git${SRCPV}"
14 14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml \ 15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \
16 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 16 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service
index 7793d0b..ef73324 100644
--- a/recipes-qt/automotive/neptune-ui/neptune.service
+++ b/recipes-qt/automotive/neptune-ui/neptune.service
@@ -3,9 +3,9 @@ Description=Neptune
3After=dbus.service dbus-session.service systemd-user-sessions.service 3After=dbus.service dbus-session.service systemd-user-sessions.service
4 4
5[Service] 5[Service]
6ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml Main.qml 6ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
7Restart=on-failure 7Restart=on-failure
8WorkingDirectory=/opt/neptune 8WorkingDirectory=/opt/neptune-ui
9 9
10[Install] 10[Install]
11WantedBy=multi-user.target 11WantedBy=multi-user.target
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
index b7ca95d..e8d01f2 100644
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -29,7 +29,7 @@
29 29
30DESCRIPTION = "Neptune IVI UI" 30DESCRIPTION = "Neptune IVI UI"
31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" 31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=c41b4a3e669de55dfe304b8376b04a82"
33 33
34inherit qt5-module systemd 34inherit qt5-module systemd
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
@@ -41,13 +41,15 @@ SRC_URI += " \
41 file://neptune.service \ 41 file://neptune.service \
42 " 42 "
43 43
44SRCREV = "6ddea70fd06d78ca7672f18221b91b3e8990aee8" 44SRCREV = "2a242aa65f267d010d8c10b8c5da5a1e728d0551"
45 45
46DEPENDS = "qtbase qtdeclarative qttools-native" 46DEPENDS = "qtbase qtdeclarative qttools-native qtquickcontrols2 qtapplicationmanager"
47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard dbus \ 47RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \
48 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ 48 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \
49 ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" 49 ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
50 50
51EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt"
52
51do_install_append() { 53do_install_append() {
52 install -m 0755 -d ${D}${systemd_unitdir}/system 54 install -m 0755 -d ${D}${systemd_unitdir}/system
53 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ 55 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
@@ -56,9 +58,9 @@ do_install_append() {
56PACKAGES =+ "${PN}-apps" 58PACKAGES =+ "${PN}-apps"
57RRECOMMENDS_${PN} += "${PN}-apps" 59RRECOMMENDS_${PN} += "${PN}-apps"
58 60
59FILES_${PN}-apps += "/opt/neptune/apps" 61FILES_${PN}-apps += "/opt/neptune-ui/apps"
60FILES_${PN} += "\ 62FILES_${PN} += "\
61 /opt/neptune \ 63 /opt/neptune-ui \
62 " 64 "
63 65
64SYSTEMD_SERVICE_${PN} = "neptune.service" 66SYSTEMD_SERVICE_${PN} = "neptune.service"
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index 52ee20e..5b112b5 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,7 +34,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=43a31c6abffdd61c938811959b3c1b71"
34inherit qt5-module 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37SRCREV = "f472ef3662cf0a9bc2bf727c7cef18fd884df5a2" 37SRCREV = "57ff870b0790e1e1feb3421cdfb46dff82878825"
38 38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
@@ -60,8 +60,8 @@ FILES_${PN} += "\
60 60
61BBCLASSEXTEND += "nativesdk" 61BBCLASSEXTEND += "nativesdk"
62 62
63DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale" 63DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale nativesdk-libarchive"
64DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale" 64DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale nativesdk-libarchive"
65 65
66EXTRA_QMAKEVARS_PRE_class-nativesdk += "\ 66EXTRA_QMAKEVARS_PRE_class-nativesdk += "\
67 -config tools-only \ 67 -config tools-only \
diff --git a/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch b/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch
new file mode 100644
index 0000000..9f6c0c0
--- /dev/null
+++ b/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch
@@ -0,0 +1,29 @@
1From b4ed8c9d4a391771cba485bfa685147126260dc2 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Thu, 7 Sep 2017 10:24:11 +0300
4Subject: [PATCH] Use QT_HOST_BINS/get for getting correct path
5
6Patch QT_HOST_BINS same way as is done it qtbase for getting
7the EffectivePath instead of installation path.
8
9Change-Id: I3e9c04019c432e182dcb5c0898275173f20de1e2
10---
11 mkspecs/features/ivigenerator.prf | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/mkspecs/features/ivigenerator.prf b/mkspecs/features/ivigenerator.prf
15index 65c497e..7634355 100644
16--- a/mkspecs/features/ivigenerator.prf
17+++ b/mkspecs/features/ivigenerator.prf
18@@ -31,9 +31,9 @@ QFACE_YAML = $$QFACE_ABS_PWD/$${QFACE_BASE_NAME}.yaml
19 OTHER_FILES += $$QFACE_FILE
20
21 # Detect whether we are using the feature inside the qtivi repository
22-VIRTUALENV_PATH = $$[QT_HOST_BINS]/ivigenerator/qtivi_qface_virtualenv
23+VIRTUALENV_PATH = $$[QT_HOST_BINS/get]/ivigenerator/qtivi_qface_virtualenv
24 INTERNAL_VIRTUALENV_PATH = $$QTIVI_BUILD_ROOT/src/tools/ivigenerator/qtivi_qface_virtualenv
25-IVI_GENERATOR_PATH = $$[QT_HOST_BINS]/ivigenerator
26+IVI_GENERATOR_PATH = $$[QT_HOST_BINS/get]/ivigenerator
27 QTEST_ENVIRONMENT = $$upper($$(QTEST_ENVIRONMENT))
28
29 # Try to use the internal virtualenv when building qtivi
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index 0f49d5d..3eb48e5 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -47,10 +47,11 @@ QT_MODULE_BRANCH_QFACE = "upstream/develop"
47 47
48SRC_URI += " \ 48SRC_URI += " \
49 ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \ 49 ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \
50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
50" 51"
51 52
52SRCREV_qtivi = "3205b6e8f57273096ae60d8f6fcdbe597c350393" 53SRCREV_qtivi = "705acb8d595d772778dd4985b762ed6a604473d9"
53SRCREV_qface = "b1d96d85a7c43ac74335b9a1a99a68507047f5bc" 54SRCREV_qface = "295824c8df7f74af8f3d1f368ec15942e6622f22"
54SRCREV = "${SRCREV_qtivi}" 55SRCREV = "${SRCREV_qtivi}"
55SRCREV_FORMAT = "qtivi_qface" 56SRCREV_FORMAT = "qtivi_qface"
56 57