summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb49
-rw-r--r--recipes-qt/images/b2qt-embedded-qt5-image.bb4
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb32
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb35
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb (renamed from recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb)5
5 files changed, 122 insertions, 3 deletions
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
new file mode 100644
index 0000000..6aafc77
--- /dev/null
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "B2Qt Automotive Qt5 image"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
26PR = "r0"
27
28IMAGE_FEATURES += "\
29 package-management \
30 ssh-server-dropbear \
31 tools-debug \
32 debug-tweaks \
33 hwcodecs \
34 "
35
36inherit core-image
37inherit bootfs-image
38
39MACHINE_EXTRA_INSTALL_QT ?= ""
40
41IMAGE_INSTALL += "\
42 ${MACHINE_EXTRA_INSTALL_QT} \
43 packagegroup-b2qt-embedded-base \
44 packagegroup-b2qt-embedded-tools \
45 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
46 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
47 packagegroup-b2qt-qt5-modules \
48 packagegroup-b2qt-automotive-addons \
49 "
diff --git a/recipes-qt/images/b2qt-embedded-qt5-image.bb b/recipes-qt/images/b2qt-embedded-qt5-image.bb
index 924ba61..8c986ac 100644
--- a/recipes-qt/images/b2qt-embedded-qt5-image.bb
+++ b/recipes-qt/images/b2qt-embedded-qt5-image.bb
@@ -44,6 +44,6 @@ IMAGE_INSTALL += "\
44 packagegroup-b2qt-embedded-tools \ 44 packagegroup-b2qt-embedded-tools \
45 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \ 45 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
46 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \ 46 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
47 packagegroup-b2qt-embedded-qt5 \ 47 packagegroup-b2qt-qt5-modules \
48 packagegroup-b2qt-embedded-qt5-addons \ 48 packagegroup-b2qt-embedded-addons \
49 " 49 "
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
new file mode 100644
index 0000000..a318d0e
--- /dev/null
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -0,0 +1,32 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Automotive specific Qt packages"
24LICENSE = "QtEnterprise"
25
26inherit packagegroup
27
28PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
29
30RDEPENDS_${PN} += " \
31 b2qt-appcontroller \
32 "
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
new file mode 100644
index 0000000..006702a
--- /dev/null
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
@@ -0,0 +1,35 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Device Creation specific Qt packages"
24LICENSE = "QtEnterprise"
25
26inherit packagegroup
27
28PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
29
30RDEPENDS_${PN} += " \
31 b2qt-appcontroller \
32 b2qt-utils \
33 b2qt-launcher \
34 b2qt-demos \
35 "
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index 861f61a..cc4784a 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -32,13 +32,16 @@ RDEPENDS_${PN} += " \
32 qtbase \ 32 qtbase \
33 qtbase-fonts \ 33 qtbase-fonts \
34 qtcanvas3d \ 34 qtcanvas3d \
35 qtcharts \
35 qtconnectivity \ 36 qtconnectivity \
37 qtdatavisualization \
36 qtdeclarative \ 38 qtdeclarative \
37 qtdeclarative-tools \ 39 qtdeclarative-tools \
38 qtgraphicaleffects \ 40 qtgraphicaleffects \
39 qtimageformats \ 41 qtimageformats \
40 qtlocation \ 42 qtlocation \
41 qtmultimedia \ 43 qtmultimedia \
44 qtquickcontrols \
42 qtsensors \ 45 qtsensors \
43 qtserialport \ 46 qtserialport \
44 qtsvg \ 47 qtsvg \
@@ -48,5 +51,5 @@ RDEPENDS_${PN} += " \
48 qtwebsockets \ 51 qtwebsockets \
49 qtwebchannel \ 52 qtwebchannel \
50 qtxmlpatterns \ 53 qtxmlpatterns \
51 qtquickcontrols \ 54 qtvirtualkeyboard \
52 " 55 "