summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/bblayers.conf.rpi.sample1
-rw-r--r--conf/distro/b2qt.conf6
-rw-r--r--conf/distro/include/colibri-imx7.conf2
-rw-r--r--conf/distro/include/colibri-vf.conf2
-rw-r--r--conf/distro/include/emulator.conf2
-rw-r--r--conf/distro/include/imx6qsabresd.conf2
-rw-r--r--conf/distro/include/intel-corei7-64.conf2
-rw-r--r--conf/distro/include/jetson-tx1.conf1
-rw-r--r--conf/distro/include/nitrogen6x.conf2
-rw-r--r--conf/distro/include/rcar-gen2.inc2
-rw-r--r--conf/distro/include/tegra-t18x.conf2
-rw-r--r--conf/distro/include/ti.inc1
-rw-r--r--meta-raspberrypi-extras/conf/layer.conf40
-rw-r--r--meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend31
-rw-r--r--meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend3
15 files changed, 83 insertions, 16 deletions
diff --git a/conf/bblayers.conf.rpi.sample b/conf/bblayers.conf.rpi.sample
index 86bb442..e376bea 100644
--- a/conf/bblayers.conf.rpi.sample
+++ b/conf/bblayers.conf.rpi.sample
@@ -45,6 +45,7 @@ BBLAYERS ?= " \
45 ${BSPDIR}/sources/meta-openembedded/meta-initramfs \ 45 ${BSPDIR}/sources/meta-openembedded/meta-initramfs \
46 ${BSPDIR}/sources/meta-openembedded/meta-multimedia \ 46 ${BSPDIR}/sources/meta-openembedded/meta-multimedia \
47 ${BSPDIR}/sources/meta-boot2qt \ 47 ${BSPDIR}/sources/meta-boot2qt \
48 ${BSPDIR}/sources/meta-boot2qt/meta-raspberrypi-extras \
48 ${BSPDIR}/sources/meta-mingw \ 49 ${BSPDIR}/sources/meta-mingw \
49 ${BSPDIR}/sources/meta-qt5 \ 50 ${BSPDIR}/sources/meta-qt5 \
50 " 51 "
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index 81cc98b..3048fff 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -51,16 +51,14 @@ SANITY_TESTED_DISTROS += " \
51 51
52SYSVINIT_ENABLED_GETTYS = "" 52SYSVINIT_ENABLED_GETTYS = ""
53 53
54DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost wifi xattr nfs webengine" 54DISTRO_FEATURES_DEFAULT_remove = "irda pcmcia pci 3g nfc zeroconf x11"
55POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch"
56DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio sysvinit" 55DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio sysvinit"
57 56
58FONTCONFIG_CACHE_DIR = "${libdir}/fontconfig/cache" 57FONTCONFIG_CACHE_DIR = "${libdir}/fontconfig/cache"
59 58
60# use GStreamer 1.0, optionally change to "gstreamer010" to use GStreamer 0.10 59# use GStreamer 1.0, optionally change to "gstreamer010" to use GStreamer 0.10
61DISTRO_FEATURES += "gstreamer" 60DISTRO_FEATURES += "gstreamer webengine systemd"
62 61
63DISTRO_FEATURES += "systemd"
64VIRTUAL-RUNTIME_init_manager = "systemd" 62VIRTUAL-RUNTIME_init_manager = "systemd"
65VIRTUAL-RUNTIME_initscripts = "" 63VIRTUAL-RUNTIME_initscripts = ""
66PREFERRED_PROVIDER_udev ?= "systemd" 64PREFERRED_PROVIDER_udev ?= "systemd"
diff --git a/conf/distro/include/colibri-imx7.conf b/conf/distro/include/colibri-imx7.conf
index 4a4d460..2c3b32a 100644
--- a/conf/distro/include/colibri-imx7.conf
+++ b/conf/distro/include/colibri-imx7.conf
@@ -38,4 +38,4 @@ BOOT_SCRIPTS += " \
38PREFERRED_PROVIDER_virtual/egl = "opengldummy" 38PREFERRED_PROVIDER_virtual/egl = "opengldummy"
39PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy" 39PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy"
40 40
41DISTRO_FEATURES_remove = "webengine" 41DISTRO_FEATURES_remove = "webengine wayland"
diff --git a/conf/distro/include/colibri-vf.conf b/conf/distro/include/colibri-vf.conf
index bbe596f..e4c025b 100644
--- a/conf/distro/include/colibri-vf.conf
+++ b/conf/distro/include/colibri-vf.conf
@@ -40,4 +40,4 @@ BOOT_SCRIPTS += " \
40PREFERRED_PROVIDER_virtual/egl = "opengldummy" 40PREFERRED_PROVIDER_virtual/egl = "opengldummy"
41PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy" 41PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy"
42 42
43DISTRO_FEATURES_remove = "webengine" 43DISTRO_FEATURES_remove = "webengine wayland"
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf
index 61bc248..21b2e65 100644
--- a/conf/distro/include/emulator.conf
+++ b/conf/distro/include/emulator.conf
@@ -43,7 +43,7 @@ PREFERRED_PROVIDER_virtual/libgles2 = "qtglesstream-dummy-client"
43 43
44KERNEL_MODULE_AUTOLOAD += "snd-intel8x0 vboxguest vboxsf" 44KERNEL_MODULE_AUTOLOAD += "snd-intel8x0 vboxguest vboxsf"
45 45
46DISTRO_FEATURES_remove = "webengine opengl" 46DISTRO_FEATURES_remove = "webengine opengl wayland"
47 47
48MACHINE_EXTRA_INSTALL += "\ 48MACHINE_EXTRA_INSTALL += "\
49 mount-vboxsf \ 49 mount-vboxsf \
diff --git a/conf/distro/include/imx6qsabresd.conf b/conf/distro/include/imx6qsabresd.conf
index 9983af3..683c601 100644
--- a/conf/distro/include/imx6qsabresd.conf
+++ b/conf/distro/include/imx6qsabresd.conf
@@ -32,8 +32,6 @@ include conf/distro/include/opencv.inc
32 32
33DEPLOY_CONF_NAME = "Freescale SABRE SD i.MX6Quad" 33DEPLOY_CONF_NAME = "Freescale SABRE SD i.MX6Quad"
34 34
35DISTRO_FEATURES_DEFAULT += "wayland"
36
37KERNEL_MODULE_AUTOLOAD += "mxc_v4l2_capture" 35KERNEL_MODULE_AUTOLOAD += "mxc_v4l2_capture"
38 36
39# add support for both imx6qsabresd and imx6dlsabresd 37# add support for both imx6qsabresd and imx6dlsabresd
diff --git a/conf/distro/include/intel-corei7-64.conf b/conf/distro/include/intel-corei7-64.conf
index 3b959a4..a72ff0c 100644
--- a/conf/distro/include/intel-corei7-64.conf
+++ b/conf/distro/include/intel-corei7-64.conf
@@ -29,8 +29,6 @@
29 29
30DEPLOY_CONF_NAME = "Intel NUC" 30DEPLOY_CONF_NAME = "Intel NUC"
31 31
32DISTRO_FEATURES_DEFAULT += "wayland"
33
34DISTRO_FEATURES_remove = "usbgadget" 32DISTRO_FEATURES_remove = "usbgadget"
35 33
36IMAGE_CLASSES += "image_dd_efi" 34IMAGE_CLASSES += "image_dd_efi"
diff --git a/conf/distro/include/jetson-tx1.conf b/conf/distro/include/jetson-tx1.conf
index 4ae287c..80435f3 100644
--- a/conf/distro/include/jetson-tx1.conf
+++ b/conf/distro/include/jetson-tx1.conf
@@ -28,7 +28,6 @@
28############################################################################ 28############################################################################
29 29
30DEPLOY_CONF_NAME = "NVIDIA Jetson TX1" 30DEPLOY_CONF_NAME = "NVIDIA Jetson TX1"
31DISTRO_FEATURES_DEFAULT += "wayland"
32 31
33# use mmc0 32# use mmc0
34ROOTFS_DEVICE = "mmcblk1p1" 33ROOTFS_DEVICE = "mmcblk1p1"
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf
index a8db798..e59faca 100644
--- a/conf/distro/include/nitrogen6x.conf
+++ b/conf/distro/include/nitrogen6x.conf
@@ -82,8 +82,6 @@ KERNEL_DEVICETREE += "\
82 imx6dl-nit6xlite.dtb \ 82 imx6dl-nit6xlite.dtb \
83 " 83 "
84 84
85DISTRO_FEATURES_DEFAULT += "wayland"
86
87MACHINE_EXTRA_INSTALL += "\ 85MACHINE_EXTRA_INSTALL += "\
88 bcm4330-nvram-config \ 86 bcm4330-nvram-config \
89 " 87 "
diff --git a/conf/distro/include/rcar-gen2.inc b/conf/distro/include/rcar-gen2.inc
index 854ac2c..262fe81 100644
--- a/conf/distro/include/rcar-gen2.inc
+++ b/conf/distro/include/rcar-gen2.inc
@@ -69,7 +69,7 @@ KERNEL_MODULE_AUTOLOAD += " \
69GLES_DRIVER = "sgx" 69GLES_DRIVER = "sgx"
70GLES_DRIVER_r8a7790 = "rgx" 70GLES_DRIVER_r8a7790 = "rgx"
71 71
72DISTRO_FEATURES += "wayland bluetooth bluez5 h264avcenc_lib" 72DISTRO_FEATURES += "h264avcenc_lib"
73MACHINE_FEATURES += "multimedia ${GLES_DRIVER}" 73MACHINE_FEATURES += "multimedia ${GLES_DRIVER}"
74 74
75PREFERRED_VERSION_gstreamer1.0-libav = "1.2.3" 75PREFERRED_VERSION_gstreamer1.0-libav = "1.2.3"
diff --git a/conf/distro/include/tegra-t18x.conf b/conf/distro/include/tegra-t18x.conf
index 80f4d57..85b0b6c 100644
--- a/conf/distro/include/tegra-t18x.conf
+++ b/conf/distro/include/tegra-t18x.conf
@@ -30,7 +30,7 @@
30OLDEST_KERNEL_aarch64 = "3.18" 30OLDEST_KERNEL_aarch64 = "3.18"
31 31
32TARGET_CFLAGS += " -DWIN_INTERFACE_CUSTOM" 32TARGET_CFLAGS += " -DWIN_INTERFACE_CUSTOM"
33DISTRO_FEATURES_DEFAULT += "wayland" 33
34IMAGE_FSTYPES += "tar.gz" 34IMAGE_FSTYPES += "tar.gz"
35 35
36QBSP_IMAGE_CONTENT = "\ 36QBSP_IMAGE_CONTENT = "\
diff --git a/conf/distro/include/ti.inc b/conf/distro/include/ti.inc
index 4c9f803..80f90f2 100644
--- a/conf/distro/include/ti.inc
+++ b/conf/distro/include/ti.inc
@@ -40,3 +40,4 @@ EXTRA_IMAGEDEPENDS += "u-boot"
40PREFERRED_PROVIDER_virtual/egl = "ti-sgx-ddk-um" 40PREFERRED_PROVIDER_virtual/egl = "ti-sgx-ddk-um"
41PREFERRED_PROVIDER_virtual/libgles1 = "ti-sgx-ddk-um" 41PREFERRED_PROVIDER_virtual/libgles1 = "ti-sgx-ddk-um"
42PREFERRED_PROVIDER_virtual/libgles2 = "ti-sgx-ddk-um" 42PREFERRED_PROVIDER_virtual/libgles2 = "ti-sgx-ddk-um"
43PREFERRED_PROVIDER_virtual/mesa = "ti-sgx-ddk-um"
diff --git a/meta-raspberrypi-extras/conf/layer.conf b/meta-raspberrypi-extras/conf/layer.conf
new file mode 100644
index 0000000..9e64b87
--- /dev/null
+++ b/meta-raspberrypi-extras/conf/layer.conf
@@ -0,0 +1,40 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# We have a conf and classes directory, append to BBPATH
31BBPATH .= ":${LAYERDIR}"
32
33# We have a recipes directory, add to BBFILES
34BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
35 ${LAYERDIR}/recipes*/*/*.bbappend \
36 "
37
38BBFILE_COLLECTIONS += "b2qt_rpi"
39BBFILE_PATTERN_b2qt_rpi := "^${LAYERDIR}/"
40BBFILE_PRIORITY_b2qt_rpi = "20"
diff --git a/meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend b/meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend
new file mode 100644
index 0000000..25ec264
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend
@@ -0,0 +1,31 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# from https://www.mail-archive.com/yocto@yoctoproject.org/msg33193.html
31PACKAGECONFIG_remove_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'fbdev', 'kms', d)}"
diff --git a/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend
index 64feb7e..6079659 100644
--- a/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend
+++ b/meta-ti-extras/recipes/libgles/ti-sgx-ddk-um_%.bbappend
@@ -30,6 +30,9 @@
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31SRC_URI += "file://99-fb.rules" 31SRC_URI += "file://99-fb.rules"
32 32
33# for supporting weston
34PROVIDES += "virtual/mesa"
35
33do_install_append() { 36do_install_append() {
34 install -d ${D}${base_libdir}/udev/rules.d 37 install -d ${D}${base_libdir}/udev/rules.d
35 install -m 0644 ${WORKDIR}/99-fb.rules ${D}${base_libdir}/udev/rules.d 38 install -m 0644 ${WORKDIR}/99-fb.rules ${D}${base_libdir}/udev/rules.d