summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xb2qt-init-build-env12
-rw-r--r--meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb1
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend2
-rw-r--r--meta-fsl-extras/recipes/linux/linux-imx_3.14.%.bbappend1
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend1
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend1
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb3
-rw-r--r--recipes-qt/qt5-addons/qtcharts_2.0.bb9
-rw-r--r--recipes-qt/qt5-addons/qtdatavisualization_1.2.bb4
-rw-r--r--recipes/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch96
-rw-r--r--recipes/openssl/openssl_1.%.bbappend3
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb1
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb1
-rwxr-xr-xscripts/configure-qtcreator.sh15
-rw-r--r--scripts/manifest_qt5.xml2
15 files changed, 129 insertions, 23 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index 0ccd952..a367d31 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -48,6 +48,10 @@ while test -n "$1"; do
48 shift 48 shift
49 DEVICE=$1 49 DEVICE=$1
50 ;; 50 ;;
51 "--repo-url")
52 shift
53 REPO_URL="--repo-url $1"
54 ;;
51 *) 55 *)
52 if [ -n "$COMMAND" ]; then 56 if [ -n "$COMMAND" ]; then
53 echo "Unknown argument: $1" 57 echo "Unknown argument: $1"
@@ -70,6 +74,10 @@ if [ -n "${REFERENCE}" ]; then
70 REFERENCE="--reference $(readlink -f ${REFERENCE})" 74 REFERENCE="--reference $(readlink -f ${REFERENCE})"
71fi 75fi
72 76
77if [ -z "${REPO_URL}" ]; then
78 REPO_URL="--repo-url git://github.com/theqtcompany/git-repo"
79fi
80
73get_repo() { 81get_repo() {
74 REPO="./repo" 82 REPO="./repo"
75 if [ -n "$(command -v repo)" ]; then 83 if [ -n "$(command -v repo)" ]; then
@@ -126,7 +134,7 @@ mirror() {
126 mkdir -p .repo/manifests 134 mkdir -p .repo/manifests
127 cp ${DIR}/scripts/manifest.xml .repo/manifests/ 135 cp ${DIR}/scripts/manifest.xml .repo/manifests/
128 MANIFEST="manifest.xml" 136 MANIFEST="manifest.xml"
129 ${REPO} init -u ${PWD}/.repo/repo -b default -m ${MANIFEST} -g all --mirror 137 ${REPO} init ${REPO_URL} -u ${PWD}/.repo/repo -b default -m ${MANIFEST} -g all --mirror
130 ${REPO} sync 138 ${REPO} sync
131} 139}
132 140
@@ -146,7 +154,7 @@ init() {
146 else 154 else
147 MANIFEST="manifest.xml" 155 MANIFEST="manifest.xml"
148 fi 156 fi
149 ${REPO} init -u ${PWD}/.repo/repo -b default -m ${MANIFEST} -g "${PROJECT_GROUPS}" ${REFERENCE} 157 ${REPO} init ${REPO_URL} -u ${PWD}/.repo/repo -b default -m ${MANIFEST} -g "${PROJECT_GROUPS}" ${REFERENCE}
150 ${REPO} sync 158 ${REPO} sync
151 159
152 if [ ! -e "sources/meta-b2qt" ]; then 160 if [ ! -e "sources/meta-b2qt" ]; then
diff --git a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb b/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
index 4fbd2b3..8a2fd54 100644
--- a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
+++ b/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
@@ -32,6 +32,7 @@ do_configure_prepend() {
32 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig 32 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig 33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig 34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
35 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
35} 36}
36 37
37# bbappend in meta-tibidabo still tries to use PRINC, set to -1 to prevent errors 38# bbappend in meta-tibidabo still tries to use PRINC, set to -1 to prevent errors
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend
index 1d7f942..c25739b 100644
--- a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend
@@ -45,4 +45,6 @@ do_configure_prepend() {
45 # enable uvcvideo module 45 # enable uvcvideo module
46 echo "CONFIG_MEDIA_USB_SUPPORT=y" >> ${WORKDIR}/defconfig 46 echo "CONFIG_MEDIA_USB_SUPPORT=y" >> ${WORKDIR}/defconfig
47 echo "CONFIG_USB_VIDEO_CLASS=m" >> ${WORKDIR}/defconfig 47 echo "CONFIG_USB_VIDEO_CLASS=m" >> ${WORKDIR}/defconfig
48
49 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
48} 50}
diff --git a/meta-fsl-extras/recipes/linux/linux-imx_3.14.%.bbappend b/meta-fsl-extras/recipes/linux/linux-imx_3.14.%.bbappend
index e12bde0..602c3df 100644
--- a/meta-fsl-extras/recipes/linux/linux-imx_3.14.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-imx_3.14.%.bbappend
@@ -32,4 +32,5 @@ do_configure_prepend() {
32 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig 32 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig 33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig 34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
35 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
35} 36}
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend
index 1e2b5f3..3f07de3 100644
--- a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend
+++ b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend
@@ -32,6 +32,7 @@ RDEPENDS_kernel-base = ""
32config_script () { 32config_script () {
33 # FunctionFS for adb 33 # FunctionFS for adb
34 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config 34 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config
35 echo "CONFIG_USB_ACM=m" >> ${S}/.config
35} 36}
36 37
37B = "${S}" 38B = "${S}"
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend
index 76bf87d..fd9ad55 100644
--- a/meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend
+++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend
@@ -29,5 +29,6 @@ SRC_URI += " \
29do_configure_prepend () { 29do_configure_prepend () {
30 # FunctionFS for adb 30 # FunctionFS for adb
31 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig 31 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
32 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
32 echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${WORKDIR}/defconfig 33 echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${WORKDIR}/defconfig
33} 34}
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
index 98ff5cc..45d3148 100644
--- a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
+++ b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
@@ -65,4 +65,5 @@ create_sdk_files_append () {
65 echo 'TargetSpec = devices/linux-oe-generic-g++' >> $qtconf 65 echo 'TargetSpec = devices/linux-oe-generic-g++' >> $qtconf
66} 66}
67 67
68SDK_POST_INSTALL_COMMAND += "$SUDO_EXEC sed -i -e "s:$DEFAULT_INSTALL_DIR:$target_sdk_dir:g" $native_sysroot/mkspecs/qdevice.pri ;" 68SDK_POST_INSTALL_COMMAND += "$SUDO_EXEC sed -i -e "s:$DEFAULT_INSTALL_DIR:$target_sdk_dir:g" \
69 $target_sdk_dir/sysroots/@REAL_MULTIMACH_TARGET_SYS@/usr/lib/${QT_DIR_NAME}/mkspecs/qdevice.pri ;"
diff --git a/recipes-qt/qt5-addons/qtcharts_2.0.bb b/recipes-qt/qt5-addons/qtcharts_2.0.bb
index 216268a..c4d88f4 100644
--- a/recipes-qt/qt5-addons/qtcharts_2.0.bb
+++ b/recipes-qt/qt5-addons/qtcharts_2.0.bb
@@ -37,12 +37,3 @@ BRANCH = "master"
37S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
38 38
39DEPENDS = "qtbase qtdeclarative qtmultimedia" 39DEPENDS = "qtbase qtdeclarative qtmultimedia"
40
41PACKAGES =+ "${PN}-designer"
42DEBIAN_NOAUTONAME_${PN}-designer = "1"
43
44FILES_${PN}-designer = " \
45 ${OE_QMAKE_PATH_QML}/QtCharts/designer \
46 "
47
48RRECOMMENDS_${PN}-dev += "${PN}-designer"
diff --git a/recipes-qt/qt5-addons/qtdatavisualization_1.2.bb b/recipes-qt/qt5-addons/qtdatavisualization_1.2.bb
index 1a06675..11c4279 100644
--- a/recipes-qt/qt5-addons/qtdatavisualization_1.2.bb
+++ b/recipes-qt/qt5-addons/qtdatavisualization_1.2.bb
@@ -37,7 +37,3 @@ BRANCH = "master"
37S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
38 38
39DEPENDS += "qtbase qtdeclarative qtmultimedia" 39DEPENDS += "qtbase qtdeclarative qtmultimedia"
40
41FILES_${PN}-qmlplugins += " \
42 ${OE_QMAKE_PATH_QML}/QtDataVisualization/designer/* \
43 "
diff --git a/recipes/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch b/recipes/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch
new file mode 100644
index 0000000..9aa9648
--- /dev/null
+++ b/recipes/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch
@@ -0,0 +1,96 @@
1From 9cf8fa1c4dae07a6aff194a3632bc499a813d3f8 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Wed, 9 Sep 2015 13:37:28 +0300
4Subject: [PATCH] Support SYSROOT in c_rehash
5
6update-ca-certificates is ran during image creation, which in turn runs
7c_rehash. Since the symlinks in /etc/ssl/certs/ are pointing to absolute
8location, c_rehash does not find the actual files. Add support for SYSROOT
9environment variable and use it to locate the actual files during image
10creation.
11
12Upstream-status: Pending
13---
14 tools/c_rehash.in | 30 +++++++++++++++++-------------
15 1 file changed, 17 insertions(+), 13 deletions(-)
16
17diff --git a/tools/c_rehash.in b/tools/c_rehash.in
18index 92cb503..f3d2703 100644
19--- a/tools/c_rehash.in
20+++ b/tools/c_rehash.in
21@@ -7,6 +7,7 @@ my $dir;
22 my $prefix;
23
24 my $openssl = $ENV{OPENSSL} || "openssl";
25+my $sysroot = $ENV{SYSROOT} || "";
26 my $pwd;
27 my $verbose = 0;
28 my $symlink_exists=eval {symlink("",""); 1};
29@@ -101,16 +102,17 @@ sub hash_dir {
30 }
31 }
32 FILE: foreach $fname (grep {/\.(pem)|(crt)|(cer)|(crl)$/} @flist) {
33+ $fullname = $sysroot . readlink($fname);
34 # Check to see if certificates and/or CRLs present.
35- my ($cert, $crl) = check_file($fname);
36+ my ($cert, $crl) = check_file($fullname);
37 if(!$cert && !$crl) {
38 print STDERR "WARNING: $fname does not contain a certificate or CRL: skipping\n";
39 next;
40 }
41- link_hash_cert($fname) if($cert);
42- link_hash_cert_old($fname) if($cert);
43- link_hash_crl($fname) if($crl);
44- link_hash_crl_old($fname) if($crl);
45+ link_hash_cert($fname, $fullname) if($cert);
46+ link_hash_cert_old($fname, $fullname) if($cert);
47+ link_hash_crl($fname, $fullname) if($crl);
48+ link_hash_crl_old($fname, $fullname) if($crl);
49 }
50 }
51
52@@ -143,9 +145,10 @@ sub check_file {
53
54 sub link_hash_cert {
55 my $fname = $_[0];
56- my $x509hash = $_[1] || '-subject_hash';
57- $fname =~ s/'/'\\''/g;
58- my ($hash, $fprint) = `"$openssl" x509 $x509hash -fingerprint -noout -in "$fname"`;
59+ my $fullname = $_[1];
60+ my $x509hash = $_[2] || '-subject_hash';
61+ $fullname =~ s/'/'\\''/g;
62+ my ($hash, $fprint) = `"$openssl" x509 $x509hash -fingerprint -noout -in "$fullname"`;
63 chomp $hash;
64 chomp $fprint;
65 $fprint =~ s/^.*=//;
66@@ -176,11 +179,11 @@ sub link_hash_cert {
67 }
68
69 sub link_hash_cert_old {
70- link_hash_cert($_[0], '-subject_hash_old');
71+ link_hash_cert($_[0], $_[1], '-subject_hash_old');
72 }
73
74 sub link_hash_crl_old {
75- link_hash_crl($_[0], '-hash_old');
76+ link_hash_crl($_[0], $_[1], '-hash_old');
77 }
78
79
80@@ -188,9 +191,10 @@ sub link_hash_crl_old {
81
82 sub link_hash_crl {
83 my $fname = $_[0];
84- my $crlhash = $_[1] || "-hash";
85- $fname =~ s/'/'\\''/g;
86- my ($hash, $fprint) = `"$openssl" crl $crlhash -fingerprint -noout -in '$fname'`;
87+ my $fullname = $_[1];
88+ my $crlhash = $_[2] || "-hash";
89+ $fullname =~ s/'/'\\''/g;
90+ my ($hash, $fprint) = `"$openssl" crl $crlhash -fingerprint -noout -in '$fullname'`;
91 chomp $hash;
92 chomp $fprint;
93 $fprint =~ s/^.*=//;
94--
951.9.1
96
diff --git a/recipes/openssl/openssl_1.%.bbappend b/recipes/openssl/openssl_1.%.bbappend
index 461cb45..ce68b59 100644
--- a/recipes/openssl/openssl_1.%.bbappend
+++ b/recipes/openssl/openssl_1.%.bbappend
@@ -20,6 +20,9 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += "file://0001-Support-SYSROOT-in-c_rehash.patch"
25
23PACKAGECONFIG += "perl" 26PACKAGECONFIG += "perl"
24 27
25do_install_append () { 28do_install_append () {
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 34a53c9..82e801b 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -59,6 +59,7 @@ RDEPENDS_${PN} = "\
59 tzdata-asia \ 59 tzdata-asia \
60 tzdata-europe \ 60 tzdata-europe \
61 atk \ 61 atk \
62 libevent \
62 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \ 63 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \
63 ${MACHINE_EXTRA_INSTALL} \ 64 ${MACHINE_EXTRA_INSTALL} \
64 " 65 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
index f567f4e..b31ea3f 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
@@ -49,6 +49,7 @@ RDEPENDS_${PN} += "\
49 libmysqlclient-dev \ 49 libmysqlclient-dev \
50 libpq-dev \ 50 libpq-dev \
51 atk-dev \ 51 atk-dev \
52 libevent-dev \
52 ${@base_contains("DISTRO_FEATURES", "wayland", "libwayland-egl-mx6-dev libxkbcommon-dev libgbm-dev libdrm-dev", "", d)} \ 53 ${@base_contains("DISTRO_FEATURES", "wayland", "libwayland-egl-mx6-dev libxkbcommon-dev libgbm-dev libdrm-dev", "", d)} \
53 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \ 54 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \
54 ${MACHINE_EXTRA_INSTALL_SDK} \ 55 ${MACHINE_EXTRA_INSTALL_SDK} \
diff --git a/scripts/configure-qtcreator.sh b/scripts/configure-qtcreator.sh
index 4ffe64f..7661297 100755
--- a/scripts/configure-qtcreator.sh
+++ b/scripts/configure-qtcreator.sh
@@ -29,7 +29,7 @@ ABI="arm-linux-generic-elf-32bit"
29 29
30printUsage () 30printUsage ()
31{ 31{
32 echo "Usage: $0 <toolchain-environment-setup-file> [--remove]" 32 echo "Usage: $0 <toolchain-environment-setup-file> [--remove] [--sdktool <path>]"
33} 33}
34 34
35while test -n "$1"; do 35while test -n "$1"; do
@@ -37,17 +37,19 @@ while test -n "$1"; do
37 "--help" | "-h") 37 "--help" | "-h")
38 printUsage 38 printUsage
39 exit 0 39 exit 0
40 shift
41 ;; 40 ;;
42 "--remove") 41 "--remove")
43 REMOVEONLY=1 42 REMOVEONLY=1
43 ;;
44 "--sdktool")
44 shift 45 shift
46 SDKTOOL=$1
45 ;; 47 ;;
46 *) 48 *)
47 CONFIG=$1 49 CONFIG=$1
48 shift
49 ;; 50 ;;
50 esac 51 esac
52 shift
51done 53done
52 54
53if [ ! -f "$CONFIG" ]; then 55if [ ! -f "$CONFIG" ]; then
@@ -65,12 +67,13 @@ fi
65 67
66source $CONFIG 68source $CONFIG
67 69
68if [ ! -d "${OECORE_NATIVE_SYSROOT}/mkspecs/${MKSPEC}" ]; then 70MKSPECPATH=$(find ${OECORE_TARGET_SYSROOT} -name $(basename ${MKSPEC}))
69 echo Error: $CONFIG is invalid. 71if [ ! -d "${MKSPECPATH}" ]; then
72 echo "Error: could not find mkspec ${MKSPEC} from the toolchain"
70 exit 1 73 exit 1
71fi 74fi
72 75
73MACHINE=$(grep '^MACHINE' ${OECORE_NATIVE_SYSROOT}/mkspecs/qdevice.pri | cut -d'=' -f2 | tr -d ' ') 76MACHINE=$(grep '^MACHINE' ${MKSPECPATH}/../../qdevice.pri | cut -d'=' -f2 | tr -d ' ')
74 77
75RELEASE=$(qmake -query QT_VERSION) 78RELEASE=$(qmake -query QT_VERSION)
76 79
diff --git a/scripts/manifest_qt5.xml b/scripts/manifest_qt5.xml
index 1a50a10..69eb254 100644
--- a/scripts/manifest_qt5.xml
+++ b/scripts/manifest_qt5.xml
@@ -7,7 +7,7 @@
7 7
8 <project name="meta-qt5" 8 <project name="meta-qt5"
9 remote="playground" 9 remote="playground"
10 revision="5.5" 10 revision="5.5-next"
11 path="sources/meta-qt5"/> 11 path="sources/meta-qt5"/>
12 12
13</manifest> 13</manifest>