diff options
3 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qmllive-target/qmllive-target.patch b/recipes-qt/automotive/qmllive-target/qmllive-target.patch new file mode 100644 index 0000000..e3f81fa --- /dev/null +++ b/recipes-qt/automotive/qmllive-target/qmllive-target.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | diff --git a/runtime.pro b/runtime.pro | ||
2 | index 73dd6d7..e569b23 100644 | ||
3 | --- a/runtime.pro | ||
4 | +++ b/runtime.pro | ||
5 | @@ -1,5 +1,4 @@ | ||
6 | TARGET = qmlliveruntime | ||
7 | -DESTDIR = ../../bin | ||
8 | |||
9 | QT *= widgets quick | ||
10 | osx: CONFIG -= app_bundle | ||
11 | @@ -14,6 +13,6 @@ include(../src.pri) | ||
12 | RESOURCES += \ | ||
13 | qml.qrc | ||
14 | |||
15 | - | ||
16 | - | ||
17 | +target.path += /usr/bin | ||
18 | +INSTALLS += target | ||
19 | |||
diff --git a/recipes-qt/automotive/qmllive-target_git.bb b/recipes-qt/automotive/qmllive-target_git.bb new file mode 100644 index 0000000..efcac4d --- /dev/null +++ b/recipes-qt/automotive/qmllive-target_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "QML Live target runtime" | ||
2 | |||
3 | LICENSE = "GPL-3.0" | ||
4 | LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c" | ||
5 | |||
6 | inherit qmake5 sdk-sources | ||
7 | |||
8 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
9 | |||
10 | SRC_URI = " \ | ||
11 | git://codereview.qt-project.org/qt-apps/qmllive.git;branch=${BRANCH};protocol=ssh;name=tools \ | ||
12 | file://qmllive-target.patch \ | ||
13 | " | ||
14 | |||
15 | BRANCH = "master" | ||
16 | SRCREV_tools="d0d41c71c4691a5f3e2b72e22917f314b4190ffc" | ||
17 | |||
18 | S = "${WORKDIR}/git/src/runtime" | ||
19 | |||
20 | DEPENDS = "qtbase qtdeclarative" | ||
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb index aee96d9..5ec66b4 100644 --- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb +++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb | |||
@@ -43,4 +43,5 @@ RDEPENDS_${PN} += " \ | |||
43 | neptune-ui-apps \ | 43 | neptune-ui-apps \ |
44 | ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \ | 44 | ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \ |
45 | gammaray \ | 45 | gammaray \ |
46 | qmllive-target \ | ||
46 | " | 47 | " |