summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb2
-rw-r--r--meta-boot2qt/classes/deploy-conf.bbclass8
-rwxr-xr-xmeta-boot2qt/files/configure-qtcreator.sh27
3 files changed, 8 insertions, 29 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb
index 67819d7..5150463 100644
--- a/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -32,7 +32,7 @@ LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" 32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33PR = "r0" 33PR = "r0"
34 34
35DEPLOY_CONF_TYPE = "Automotive" 35DEPLOY_CONF_TYPE = "Qt Automotive Suite 5.11.0"
36 36
37IMAGE_FEATURES += "\ 37IMAGE_FEATURES += "\
38 package-management \ 38 package-management \
diff --git a/meta-boot2qt/classes/deploy-conf.bbclass b/meta-boot2qt/classes/deploy-conf.bbclass
index 228b1e2..22c6ef7 100644
--- a/meta-boot2qt/classes/deploy-conf.bbclass
+++ b/meta-boot2qt/classes/deploy-conf.bbclass
@@ -29,15 +29,19 @@
29 29
30inherit image_types 30inherit image_types
31 31
32IMAGE_DEPENDS_conf = "qtbase-native"
33
32DEPLOY_CONF_NAME ?= "${MACHINE}" 34DEPLOY_CONF_NAME ?= "${MACHINE}"
33DEPLOY_CONF_TYPE ?= "Boot2Qt" 35DEPLOY_CONF_TYPE ?= "Boot2Qt"
34 36
35IMAGE_CMD_conf() { 37IMAGE_CMD_conf() {
38 QT_VERSION=$(qmake -query QT_VERSION)
36 cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF 39 cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF
37[${DEPLOY_CONF_TYPE} | ${DEPLOY_CONF_NAME}] 40[${DEPLOY_CONF_NAME}]
38platform=${MACHINE} 41platform=${MACHINE}
42product=${DEPLOY_CONF_TYPE}
43qt=Qt $QT_VERSION
39os=linux 44os=linux
40board=
41imagefile=${IMAGE_LINK_NAME}.img 45imagefile=${IMAGE_LINK_NAME}.img
42asroot=true 46asroot=true
43EOF 47EOF
diff --git a/meta-boot2qt/files/configure-qtcreator.sh b/meta-boot2qt/files/configure-qtcreator.sh
index 7386f70..105e476 100755
--- a/meta-boot2qt/files/configure-qtcreator.sh
+++ b/meta-boot2qt/files/configure-qtcreator.sh
@@ -35,7 +35,7 @@ CONFIG=""
35 35
36printUsage () 36printUsage ()
37{ 37{
38 echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>] [--appman]" 38 echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>]"
39} 39}
40 40
41while test -n "$1"; do 41while test -n "$1"; do
@@ -43,9 +43,6 @@ while test -n "$1"; do
43 "--remove") 43 "--remove")
44 REMOVEONLY=1 44 REMOVEONLY=1
45 ;; 45 ;;
46 "--appman")
47 APPMAN=1
48 ;;
49 "--qtcreator") 46 "--qtcreator")
50 shift 47 shift
51 QTCREATOR=$1 48 QTCREATOR=$1
@@ -99,9 +96,7 @@ NAME=${NAME:-"Custom Qt ${RELEASE} ${MACHINE}"}
99BASEID="byos.${RELEASE}.${MACHINE}" 96BASEID="byos.${RELEASE}.${MACHINE}"
100 97
101${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true 98${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true
102${SDKTOOL} rmKit --id ${BASEID}.am.kit 2>/dev/null || true
103${SDKTOOL} rmQt --id ${BASEID}.qt || true 99${SDKTOOL} rmQt --id ${BASEID}.qt || true
104${SDKTOOL} rmQt --id ${BASEID}.am.qt || true
105${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true 100${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true
106${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true 101${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true
107${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true 102${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true
@@ -150,24 +145,4 @@ ${SDKTOOL} addKit \
150 --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ 145 --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \
151 --mkspec "${MKSPEC}" 146 --mkspec "${MKSPEC}"
152 147
153if [ -n "${APPMAN}" ]; then
154 ${SDKTOOL} addQt \
155 --id "${BASEID}.am.qt" \
156 --name "${NAME} [Application Manager]" \
157 --type "AM.Qt" \
158 --qmake "$(type -p qmake)"
159
160 ${SDKTOOL} addKit \
161 --id "${BASEID}.am.kit" \
162 --name "${NAME} [Application Manager]" \
163 --qt "${BASEID}.am.qt" \
164 --debuggerid "${BASEID}.gdb" \
165 --sysroot "${SDKTARGETSYSROOT}" \
166 --devicetype "AM.Device.Type" \
167 --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \
168 --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \
169 --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \
170 --mkspec "${MKSPEC}"
171fi
172
173echo "Configured Qt Creator with new kit: ${NAME}" 148echo "Configured Qt Creator with new kit: ${NAME}"