summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-10 17:01:55 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-10 17:01:55 +0300
commitc38d1b6eecfa0e209a0c1fa93319bf4aeb6e3759 (patch)
tree14aa05d27ee4012a8c6b62e847792f9b31d6db52 /scripts
parenta0d9fb33f8475336fbdebdbab803f43c7b9107d4 (diff)
parent014389ed5af9c5870efbbcd2c03f9641f65cda99 (diff)
downloadmeta-boot2qt-c38d1b6eecfa0e209a0c1fa93319bf4aeb6e3759.tar.gz
Merge remote-tracking branch 'origin/pyro' into sumo
* origin/pyro: (29 commits) meta-qt5: update layer qt5: Enable Link Time Optimization toradex: add Qt marketing slides toradex: add support for colibri-imx6ull rpi: include mcp2515 overlay for CAN support qtdeviceutilities: update to latest version boot2qt-demos: update revision boot2qt-addons: update components meta-qt5: update layer boot2qt-launcher: update to latest version qtdeviceutilities: update to latest version Do not use Link Time Optimization boot2qt-demo: update demo videos qtquicktimeline: fetch from public repository boot2qt-demos: no need to patch demos anymore Don't use git folder to check if we are using SDK sources toradex: include easy installer file in the release 7z toradex: Add Boot2Qt material to the Tezi image meta-qt5: update layer qt5: update submodules ... Change-Id: I23e9b0a018328d7be1441616c07c526e2db61be2
Diffstat (limited to 'scripts')
-rw-r--r--scripts/manifest.xml7
-rwxr-xr-xscripts/setup-environment.sh7
-rwxr-xr-xscripts/update-qt5-modules.sh46
3 files changed, 29 insertions, 31 deletions
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index ef47bab..672b6ca 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -37,17 +37,12 @@
37 remote="freescale" 37 remote="freescale"
38 revision="af5a8cf74d488ba45715ed0b0e0441e60b10c31d" 38 revision="af5a8cf74d488ba45715ed0b0e0441e60b10c31d"
39 path="sources/meta-freescale" 39 path="sources/meta-freescale"
40 groups="notdefault,external,fsl,toradex,ti,smx6,renesas-gen3,boundary,fsl-imx8"/> 40 groups="notdefault,external,fsl,toradex,smx6,renesas-gen3,boundary,fsl-imx8"/>
41 <project name="meta-freescale-3rdparty" 41 <project name="meta-freescale-3rdparty"
42 remote="freescale" 42 remote="freescale"
43 revision="9613dbc02ca970122a01c935bc9e5789ced73a9d" 43 revision="9613dbc02ca970122a01c935bc9e5789ced73a9d"
44 path="sources/meta-freescale-3rdparty" 44 path="sources/meta-freescale-3rdparty"
45 groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8"/> 45 groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8"/>
46 <project name="meta-ti"
47 remote="yocto"
48 revision="aca8f5d6ff8a529e00bdeae5b401c791ed6ecb2b"
49 path="sources/meta-ti"
50 groups="notdefault,external,ti"/>
51 <project name="meta-raspberrypi" 46 <project name="meta-raspberrypi"
52 remote="yocto" 47 remote="yocto"
53 revision="f2e2a4376e84dec6e5efeabaa86a4406fddf7dcd" 48 revision="f2e2a4376e84dec6e5efeabaa86a4406fddf7dcd"
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index 3045e3c..44f529c 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -59,7 +59,7 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
59 apalis-imx8|imx8qmlpddr4arm2) 59 apalis-imx8|imx8qmlpddr4arm2)
60 LAYERSCONF="bblayers.conf.fsl-imx8.sample" 60 LAYERSCONF="bblayers.conf.fsl-imx8.sample"
61 ;; 61 ;;
62 apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) 62 apalis-imx6|colibri-imx6|colibri-imx6ull|colibri-vf|colibri-imx7)
63 LAYERSCONF="bblayers.conf.toradex.sample" 63 LAYERSCONF="bblayers.conf.toradex.sample"
64 ;; 64 ;;
65 nitrogen6x|nitrogen7) 65 nitrogen6x|nitrogen7)
@@ -71,9 +71,6 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
71 smarc-samx6i) 71 smarc-samx6i)
72 LAYERSCONF="bblayers.conf.smx6.sample" 72 LAYERSCONF="bblayers.conf.smx6.sample"
73 ;; 73 ;;
74 beagleboard|beaglebone|am335x-evm)
75 LAYERSCONF="bblayers.conf.ti.sample"
76 ;;
77 raspberrypi0|raspberrypi|raspberrypi2|raspberrypi3) 74 raspberrypi0|raspberrypi|raspberrypi2|raspberrypi3)
78 LAYERSCONF="bblayers.conf.rpi.sample" 75 LAYERSCONF="bblayers.conf.rpi.sample"
79 ;; 76 ;;
@@ -101,7 +98,7 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
101 mkdir -p ${PWD}/${BUILDDIRECTORY}/conf 98 mkdir -p ${PWD}/${BUILDDIRECTORY}/conf
102 cp ${PWD}/sources/meta-boot2qt/meta-boot2qt-distro/conf/${LAYERSCONF} ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf 99 cp ${PWD}/sources/meta-boot2qt/meta-boot2qt-distro/conf/${LAYERSCONF} ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf
103 100
104 if [ ! -d ${PWD}/sources/meta-boot2qt/.git ]; then 101 if [ -e ${PWD}/sources/meta-boot2qt/.QT-FOR-DEVICE-CREATION-LICENSE-AGREEMENT ]; then
105 QT_SDK_PATH=$(readlink -f ${PWD}/sources/meta-boot2qt/../../../../) 102 QT_SDK_PATH=$(readlink -f ${PWD}/sources/meta-boot2qt/../../../../)
106 fi 103 fi
107fi 104fi
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh
index bd63de8..2172c01 100755
--- a/scripts/update-qt5-modules.sh
+++ b/scripts/update-qt5-modules.sh
@@ -1,7 +1,7 @@
1#!/bin/bash 1#!/bin/bash
2############################################################################ 2############################################################################
3## 3##
4## Copyright (C) 2016 The Qt Company Ltd. 4## Copyright (C) 2018 The Qt Company Ltd.
5## Contact: https://www.qt.io/licensing/ 5## Contact: https://www.qt.io/licensing/
6## 6##
7## This file is part of the Boot to Qt meta layer. 7## This file is part of the Boot to Qt meta layer.
@@ -28,41 +28,47 @@
28## 28##
29############################################################################ 29############################################################################
30 30
31if [ $# -ne 1 ]; then 31if [ $# -lt 1 ]; then
32 echo "Usage: $0 <qt5.git>" 32 echo "Usage: $0 <qt5.git> [<layerdir>]"
33 echo "Update SRCREVs for all Qt modules in the current folder." 33 echo "Update SRCREVs for all Qt modules in the current layer."
34 echo "The <qt5.git> is path to the qt5 super repo, where modules' SHA1 is taken." 34 echo "The <qt5.git> is path to the qt5 super repo, where modules' SHA1 is taken."
35 exit 1 35 exit 1
36fi 36fi
37 37
38SHA1S=$(git -C $1 submodule status --recursive | cut -c2- | awk '{print $1$2}') 38SHA1S=$(git -C $1 submodule status --recursive | cut -c2- | awk '{print $1$2}')
39LAYERDIR=${2:-$PWD}
39 40
40for S in $SHA1S; do 41for S in $SHA1S; do
41 SHA1=${S:0:40} 42 SHA1=${S:0:40}
42 PROJECT=${S:40} 43 PROJECT=${S:40}
43 44
44 if [ "${PROJECT}" = "qtwebengine" ]; then 45 if [ "${PROJECT}" = "qtwebengine" ]; then
45 sed -i -e "/^SRCREV_qtwebengine/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* 46 RECIPE="qtwebengine"
46 echo "${PROJECT} -> ${SHA1}" 47 TAG="SRCREV_qtwebengine"
47 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then 48 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then
48 sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* 49 RECIPE="qtwebengine"
49 echo "qtwebengine (chromium) -> ${SHA1}" 50 TAG="SRCREV_chromium"
50 elif [ "${PROJECT}" = "qtlocation" ]; then 51 elif [ "${PROJECT}" = "qtlocation" ]; then
51 sed -i -e "/^SRCREV_qtlocation/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* 52 RECIPE="qtlocation"
52 echo "qtlocation -> ${SHA1}" 53 TAG="SRCREV_qtlocation"
53 elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then 54 elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then
54 sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* 55 RECIPE="qtlocation"
55 echo "qtlocation (mapboxgl) -> ${SHA1}" 56 TAG="SRCREV_qtlocation-mapboxgl"
56 elif [ "${PROJECT}" = "qtivi" ]; then 57 elif [ "${PROJECT}" = "qtivi" ]; then
57 sed -i -e "/^SRCREV_qtivi/s/\".*\"/\"${SHA1}\"/" qtivi_git.bb* 58 RECIPE="qtivi"
58 echo "qtivi -> ${SHA1}" 59 TAG="SRCREV_qtivi"
59 elif [ "${PROJECT}" = "qtivi/src/3rdparty/qface" ]; then 60 elif [ "${PROJECT}" = "qtivi/src/3rdparty/qface" ]; then
60 sed -i -e "/^SRCREV_qface/s/\".*\"/\"${SHA1}\"/" qtivi_git.bb* 61 RECIPE="qtivi"
61 echo "qtivi (qface) -> ${SHA1}" 62 TAG="SRCREV_qface"
62 elif [ "${PROJECT}" = "qtenginio" ] || [ "${PROJECT}" = "qtquick1" ] || [ "${PROJECT}" = "qtsystems" ]; then 63 else
63 echo "${PROJECT} -> ignored" 64 RECIPE="${PROJECT}"
64 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then 65 TAG="SRCREV"
65 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* 66 fi
67
68 RECIPES=$(find ${LAYERDIR} -regextype egrep -regex ".*/(nativesdk-)?${RECIPE}(-native)?_git.bb(append)?")
69
70 if [ "${RECIPES}" != "" ]; then
71 sed -i -e "/^${TAG}/s/\".*\"/\"${SHA1}\"/" ${RECIPES}
66 echo "${PROJECT} -> ${SHA1}" 72 echo "${PROJECT} -> ${SHA1}"
67 else 73 else
68 echo "${PROJECT} -> no recipe found" 74 echo "${PROJECT} -> no recipe found"