diff options
author | Kari Oikarinen <kari.oikarinen@qt.io> | 2016-09-16 10:10:42 +0300 |
---|---|---|
committer | Kari Oikarinen <kari.oikarinen@qt.io> | 2016-09-19 09:12:35 +0000 |
commit | 7d0247b360192f64771f94d2032dd82a969197b0 (patch) | |
tree | 082356b08713763a0e13b1a583fa58e91109bf68 /recipes | |
parent | 029735220500c6e6bafdd648a9184c2dd5b057b6 (diff) | |
download | meta-boot2qt-7d0247b360192f64771f94d2032dd82a969197b0.tar.gz |
Use link-local addresses for USB gadget NICs
Add systemd-networkd, since it provided the easiest solution to get
link-local addresses directly (instead of only after DHCP discovery
times out).
Task-number: QTBUG-55434
Change-Id: I4198514a0bfef9d65da33f27af64a5055567dd9b
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes')
-rw-r--r-- | recipes/systemd/systemd/usb-rndis.network | 5 | ||||
-rw-r--r-- | recipes/systemd/systemd_%.bbappend | 10 |
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/systemd/systemd/usb-rndis.network b/recipes/systemd/systemd/usb-rndis.network new file mode 100644 index 0000000..d529eeb --- /dev/null +++ b/recipes/systemd/systemd/usb-rndis.network | |||
@@ -0,0 +1,5 @@ | |||
1 | [Match] | ||
2 | Type=gadget | ||
3 | |||
4 | [Network] | ||
5 | LinkLocalAddressing=yes | ||
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend index 0877135..4dce1b2 100644 --- a/recipes/systemd/systemd_%.bbappend +++ b/recipes/systemd/systemd_%.bbappend | |||
@@ -28,11 +28,19 @@ | |||
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
31 | SRC_URI += "file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch" | 31 | SRC_URI += " \ |
32 | file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch \ | ||
33 | file://usb-rndis.network \ | ||
34 | " | ||
35 | |||
36 | PACKAGECONFIG_append = " networkd" | ||
32 | 37 | ||
33 | do_install_append() { | 38 | do_install_append() { |
34 | # remove login from tty1 | 39 | # remove login from tty1 |
35 | rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service | 40 | rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service |
41 | # set up link-local IPs for USB network interface | ||
42 | install -d ${D}${prefix}/lib/systemd/network/ | ||
43 | install -m 0644 ${WORKDIR}/usb-rndis.network ${D}${prefix}/lib/systemd/network/ | ||
36 | } | 44 | } |
37 | 45 | ||
38 | do_verify_patch_required() { | 46 | do_verify_patch_required() { |