summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-08-11 13:28:28 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2017-08-17 06:45:20 +0000
commit551dd571b739e2f443f70ca20f5fd3a28d61fe82 (patch)
tree3d0a24353a816363832156ce7cfda440516dc7d6 /recipes
parent2b70147f1e353e22bd989915de8bac584fa8ce9f (diff)
downloadmeta-boot2qt-551dd571b739e2f443f70ca20f5fd3a28d61fe82.tar.gz
poky: update to 2.3 (pyro)
* Update poky, meta-openembedded etc. layers to pyro branches * Remove/update meta-boot2qt layer patches/recipes as needed Task-number: QTBUG-61283 Change-Id: I425609c99ef22a0cc904dd853b3bb281d32fbcad Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ca-certificates/ca-certificates_%.bbappend34
-rw-r--r--recipes/fonts/ttf-opensans.bb5
-rw-r--r--recipes/gnutls/files/check_SYS_getrandom.patch36
-rw-r--r--recipes/gnutls/gnutls_3.%.bbappend32
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb1
-rw-r--r--recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb (renamed from recipes/virtualbox/virtualbox-guest-additions_5.1.14.bb)6
6 files changed, 6 insertions, 108 deletions
diff --git a/recipes/ca-certificates/ca-certificates_%.bbappend b/recipes/ca-certificates/ca-certificates_%.bbappend
deleted file mode 100644
index 210f550..0000000
--- a/recipes/ca-certificates/ca-certificates_%.bbappend
+++ /dev/null
@@ -1,34 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SRC_URI_remove = "file://0001-update-ca-certificates-remove-c-rehash.patch"
31DEPENDS_class-native = "coreutils-native"
32
33# for c_rehash
34RDEPENDS_${PN}_class-target += "openssl openssl-misc"
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb
index 08e8421..a4af90e 100644
--- a/recipes/fonts/ttf-opensans.bb
+++ b/recipes/fonts/ttf-opensans.bb
@@ -29,15 +29,16 @@
29 29
30SUMMARY = "Open Sans Fonts" 30SUMMARY = "Open Sans Fonts"
31SECTION = "fonts" 31SECTION = "fonts"
32HOMEPAGE = "https://www.google.com/fonts" 32HOMEPAGE = "https://fonts.google.com"
33LICENSE = "Apache-2.0" 33LICENSE = "Apache-2.0"
34LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87" 34LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87"
35 35
36INHIBIT_DEFAULT_DEPS = "1" 36INHIBIT_DEFAULT_DEPS = "1"
37do_unpack[depends] += "unzip-native:do_populate_sysroot"
37 38
38inherit allarch fontcache 39inherit allarch fontcache
39 40
40SRC_URI = "https://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ;downloadfilename=Open_Sans.zip" 41SRC_URI = "https://fonts.google.com/download?family=Open%20Sans;downloadfilename=Open_Sans.zip"
41# Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check 42# Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check
42BB_STRICT_CHECKSUM = "" 43BB_STRICT_CHECKSUM = ""
43 44
diff --git a/recipes/gnutls/files/check_SYS_getrandom.patch b/recipes/gnutls/files/check_SYS_getrandom.patch
deleted file mode 100644
index 50693bf..0000000
--- a/recipes/gnutls/files/check_SYS_getrandom.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From f26c3979ab0325edb2e410d287bc501cf00e0ac0 Mon Sep 17 00:00:00 2001
2From: Nikos Mavrogiannopoulos <nmav@redhat.com>
3Date: Mon, 22 Aug 2016 16:32:34 +0200
4Subject: [PATCH] rnd-linux: added check for SYS_getrandom being defined
5
6This allows to compile the getrandom() code in old Linux systems
7which do not have the system call defined.
8---
9
10Upstream-Status: Backport
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12
13 lib/nettle/rnd-linux.c | 6 +++++-
14 1 file changed, 5 insertions(+), 1 deletion(-)
15
16diff --git a/lib/nettle/rnd-linux.c b/lib/nettle/rnd-linux.c
17index d7f07a6..7a24d05 100644
18--- a/lib/nettle/rnd-linux.c
19+++ b/lib/nettle/rnd-linux.c
20@@ -56,7 +56,11 @@ static dev_t _gnutls_urandom_fd_rdev = 0;
21 # else
22 # include <sys/syscall.h>
23 # undef getrandom
24-# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags)
25+# if defined(SYS_getrandom)
26+# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags)
27+# else
28+# define getrandom(dst,s,flags) -1
29+# endif
30 # endif
31
32 static unsigned have_getrandom(void)
33--
34libgit2 0.24.0
35
36
diff --git a/recipes/gnutls/gnutls_3.%.bbappend b/recipes/gnutls/gnutls_3.%.bbappend
deleted file mode 100644
index 8d91bb0..0000000
--- a/recipes/gnutls/gnutls_3.%.bbappend
+++ /dev/null
@@ -1,32 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
31
32SRC_URI += "file://check_SYS_getrandom.patch"
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index 9e55ca3..9f43fff 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -57,5 +57,4 @@ RDEPENDS_${PN}_append_mingw32 = "\
57 nativesdk-make \ 57 nativesdk-make \
58 nativesdk-libgcc \ 58 nativesdk-libgcc \
59 nativesdk-libstdc++ \ 59 nativesdk-libstdc++ \
60 nativesdk-mingw-w64-winpthreads \
61 " 60 "
diff --git a/recipes/virtualbox/virtualbox-guest-additions_5.1.14.bb b/recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb
index 00dcaa5..752d8cb 100644
--- a/recipes/virtualbox/virtualbox-guest-additions_5.1.14.bb
+++ b/recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -38,8 +38,8 @@ PR = "${MACHINE_KERNEL_PR}"
38 38
39SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2" 39SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2"
40 40
41SRC_URI[md5sum] = "21eaec9f21477d555559a63761779880" 41SRC_URI[md5sum] = "37ebbd51370841eed8ab80f2f38446d6"
42SRC_URI[sha256sum] = "8267bb026717c6e55237eb798210767d9c703cfcdf01224d9bc26f7dac9f228a" 42SRC_URI[sha256sum] = "78071c3172f3bd3c7981c352c3ae6c6a9c01f6ab24bc0aa7ec79f3528b2291a7"
43 43
44S = "${WORKDIR}/vbox" 44S = "${WORKDIR}/vbox"
45 45