summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-01-26 15:40:19 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-01 11:41:06 +0000
commit4cee85ecd6cf356f9cef28cf042065204ad5baff (patch)
tree919e6157e709e4f0faf3bb002819e8eaab358794 /recipes
parentb7c6ec16c6b4bee079894c0f29f43e53595d1a79 (diff)
downloadmeta-boot2qt-4cee85ecd6cf356f9cef28cf042065204ad5baff.tar.gz
Add meta layer revision info to image and toolchain
The branch and revision of each meta layer used in the build are stored in the image (/etc/build) and in the toolchain (${SDKPATH}/version-${REAL_MULTIMACH_TARGET_SYS}). Change-Id: Ic4be1cff62e11746ee3ec61c7909ed8c35c84db2 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/meta/meta-environment.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/meta/meta-environment.bbappend b/recipes/meta/meta-environment.bbappend
new file mode 100644
index 0000000..93500c0
--- /dev/null
+++ b/recipes/meta/meta-environment.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23toolchain_create_sdk_version_append () {
24 echo 'Layer Revisions:' >> $versionfile
25 echo '${@get_layer_revs(d)}' >> $versionfile
26}