summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-31 09:12:03 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-10-31 09:12:03 +0200
commitff5338d5189d60fe91d842fe1be26bd69a042f96 (patch)
treefcdad806b1aab2dc83982779e5fa774cc59d5108 /recipes
parent17bb365744a233dba7483be2c86b34a8c17f125a (diff)
parent18c5cb7ecea53c07682ddfeda821e4fd32a14328 (diff)
downloadmeta-boot2qt-ff5338d5189d60fe91d842fe1be26bd69a042f96.tar.gz
Merge remote-tracking branch 'origin/jethro' into dev
* origin/jethro: VKB: correctly override PACKAGECONFIG psplash: remove from image imx6: enable QT_QPA_EGLFS_FORCEVSYNC for all imx6 devices colibri-vf: use older 4.1 version of kernel to fix color issue colibri-imx7: add u-boot-nand.imx to image colibri-vf: add kernel image to rootfs dbus-session-init: fix broken init script Improve repo fetching qt5 recipes cleanup qt5: update submodules qt5: remove obsolete file 0001-Allow-a-tools-only-build.patch Conflicts: meta-raspberrypi-extras/recipes/bluez5/bluez5_%.bbappend recipes-qt/qt5/nativesdk-qtbase_git.bbappend recipes-qt/qt5/qt3d_git.bbappend recipes-qt/qt5/qtbase-native_git.bbappend recipes-qt/qt5/qtbase_git.bbappend recipes-qt/qt5/qtcanvas3d_git.bbappend recipes-qt/qt5/qtcharts_git.bbappend recipes-qt/qt5/qtconnectivity_git.bbappend recipes-qt/qt5/qtdeclarative_git.bbappend recipes-qt/qt5/qtgraphicaleffects_git.bbappend recipes-qt/qt5/qtimageformats_git.bbappend recipes-qt/qt5/qtlocation_git.bbappend recipes-qt/qt5/qtmultimedia_git.bbappend recipes-qt/qt5/qtquickcontrols2_git.bbappend recipes-qt/qt5/qtquickcontrols_git.bbappend recipes-qt/qt5/qtsensors_git.bbappend recipes-qt/qt5/qtserialbus_git.bbappend recipes-qt/qt5/qtserialport_git.bbappend recipes-qt/qt5/qtsvg_git.bbappend recipes-qt/qt5/qttools_git.bbappend recipes-qt/qt5/qttranslations_git.bbappend recipes-qt/qt5/qtvirtualkeyboard_git.bbappend recipes-qt/qt5/qtwayland_git.bbappend recipes-qt/qt5/qtwebchannel_git.bbappend recipes-qt/qt5/qtwebengine_git.bbappend recipes-qt/qt5/qtwebsockets_git.bbappend recipes-qt/qt5/qtxmlpatterns_git.bbappend scripts/manifest.xml Change-Id: I089e7d3667ac4ed150cc5c2201c2505103f548ee
Diffstat (limited to 'recipes')
-rw-r--r--recipes/dbus/dbus/dbus-session.service4
-rw-r--r--recipes/dbus/dbus_%.bbappend8
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb1
-rw-r--r--recipes/psplash/files/qt.pngbin9193 -> 0 bytes
-rw-r--r--recipes/psplash/psplash_git.bbappend33
5 files changed, 6 insertions, 40 deletions
diff --git a/recipes/dbus/dbus/dbus-session.service b/recipes/dbus/dbus/dbus-session.service
index dbd6fcd..8dcf081 100644
--- a/recipes/dbus/dbus/dbus-session.service
+++ b/recipes/dbus/dbus/dbus-session.service
@@ -4,8 +4,8 @@ After=dbus.service
4 4
5[Service] 5[Service]
6Type=forking 6Type=forking
7ExecStart=/usr/bin/dbus-session.init start 7ExecStart=/usr/bin/dbus-session.init.sh start
8ExecStop=/usr/bin/dbus-session.init stop 8ExecStop=/usr/bin/dbus-session.init.sh stop
9Environment=HOME=/home/root 9Environment=HOME=/home/root
10 10
11[Install] 11[Install]
diff --git a/recipes/dbus/dbus_%.bbappend b/recipes/dbus/dbus_%.bbappend
index f9f1345..dde2927 100644
--- a/recipes/dbus/dbus_%.bbappend
+++ b/recipes/dbus/dbus_%.bbappend
@@ -45,21 +45,21 @@ SYSTEMD_PACKAGES =+ "${PN}-session-init"
45FILES_${PN}-session-init = " \ 45FILES_${PN}-session-init = " \
46 ${sysconfdir}/init.d/dbus-session \ 46 ${sysconfdir}/init.d/dbus-session \
47 ${sysconfdir}/profile.d/dbus-session-address \ 47 ${sysconfdir}/profile.d/dbus-session-address \
48 ${bindir}/dbus-session.init \ 48 ${bindir}/dbus-session.init.sh \
49 ${systemd_unitdir}/system/dbus-session.service \ 49 ${systemd_unitdir}/system/dbus-session.service \
50 " 50 "
51 51
52do_install_append_class-target() { 52do_install_append_class-target() {
53 sed 's:@bindir@:${bindir}:' < ${WORKDIR}/dbus-session.init >${WORKDIR}/dbus-session.init 53 sed 's:@bindir@:${bindir}:' < ${WORKDIR}/dbus-session.init >${WORKDIR}/dbus-session.init.sh
54 54
55 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 55 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
56 install -d ${D}${sysconfdir}/init.d 56 install -d ${D}${sysconfdir}/init.d
57 install -m 0755 ${WORKDIR}/dbus-session.init ${D}${sysconfdir}/init.d/dbus-session 57 install -m 0755 ${WORKDIR}/dbus-session.init.sh ${D}${sysconfdir}/init.d/dbus-session
58 fi 58 fi
59 59
60 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 60 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
61 install -m 0755 -d ${D}${bindir}/ 61 install -m 0755 -d ${D}${bindir}/
62 install -m 0755 ${WORKDIR}/dbus-session.init ${D}${bindir}/ 62 install -m 0755 ${WORKDIR}/dbus-session.init.sh ${D}${bindir}/
63 63
64 install -m 0755 -d ${D}${systemd_unitdir}/system 64 install -m 0755 -d ${D}${systemd_unitdir}/system
65 install -m 0644 ${WORKDIR}/dbus-session.service ${D}${systemd_unitdir}/system/ 65 install -m 0644 ${WORKDIR}/dbus-session.service ${D}${systemd_unitdir}/system/
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 0e77368..55394d6 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -36,7 +36,6 @@ inherit packagegroup
36RDEPENDS_${PN} = "\ 36RDEPENDS_${PN} = "\
37 kernel-modules \ 37 kernel-modules \
38 adbd \ 38 adbd \
39 psplash \
40 openssh-sftp-server \ 39 openssh-sftp-server \
41 openssl \ 40 openssl \
42 openssl-misc \ 41 openssl-misc \
diff --git a/recipes/psplash/files/qt.png b/recipes/psplash/files/qt.png
deleted file mode 100644
index 99c5d9d..0000000
--- a/recipes/psplash/files/qt.png
+++ /dev/null
Binary files differ
diff --git a/recipes/psplash/psplash_git.bbappend b/recipes/psplash/psplash_git.bbappend
deleted file mode 100644
index 0cbff06..0000000
--- a/recipes/psplash/psplash_git.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
31
32SPLASH_IMAGES = "file://qt.png;outsuffix=default"
33