summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-31 16:17:43 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-11-03 14:11:31 +0000
commitd1014d8b2e40f36cd85d75cfd3732f6b124dab2f (patch)
tree790a176c00adbc30dd310a93ee6c2b559885e105 /recipes
parent464002ea626da5febafcae705773077eba7f7b8a (diff)
downloadmeta-boot2qt-d1014d8b2e40f36cd85d75cfd3732f6b124dab2f.tar.gz
sdk: do not explicitly define Qt dependency packages
Until now, the toolchain used by CI has been created without Qt, but with all (best guess) Qt dependencies. Now toolchain is created with Qt and we get all Qt dependencies correctly into the toolchain. As a consequence, CI will now need to build Qt, which has not been covered in CI before. The difference between embedded-sdk and embedded-qt5-sdk is that the former does not include files needed for debugging. Change-Id: Ie2be156c07e51119c0d4782494d6bcde6f34ed60 Reviewed-by: Risto Avila <risto.avila@qt.io>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb39
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb2
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb65
3 files changed, 2 insertions, 104 deletions
diff --git a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb b/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb
deleted file mode 100644
index d5f8ce7..0000000
--- a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt on embedded Linux SDK toolchain"
31PR = "r0"
32LICENSE = "The-Qt-Company-DCLA-2.1"
33LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
34
35inherit populate_b2qt_sdk
36
37TOOLCHAIN_HOST_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-host packagegroup-cross-canadian-${MACHINE}"
38TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-toolchain-target"
39
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index 1883902..5e3234f 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -33,6 +33,8 @@ LICENSE = "The-Qt-Company-DCLA-2.1"
33 33
34inherit nativesdk packagegroup 34inherit nativesdk packagegroup
35 35
36MACHINE_EXTRA_INSTALL_SDK_HOST ?= ""
37
36python __anonymous() { 38python __anonymous() {
37 overrides = d.getVar("OVERRIDES", True).split(":") 39 overrides = d.getVar("OVERRIDES", True).split(":")
38 if "mingw32" not in overrides: 40 if "mingw32" not in overrides:
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
deleted file mode 100644
index 31e0cb4..0000000
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Target packages for B2Qt on embedded Linux SDK"
31PR = "r0"
32LICENSE = "The-Qt-Company-DCLA-2.1"
33
34inherit packagegroup
35inherit bluetooth
36
37RDEPENDS_${PN} += "\
38 packagegroup-core-standalone-sdk-target \
39 base-files \
40 glib-2.0-dev \
41 openssl-dev \
42 libpng-dev \
43 tiff-dev \
44 alsa-dev \
45 dbus-dev \
46 freetype-dev \
47 fontconfig-dev \
48 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "gstreamer-dev gst-plugins-base-dev", "", d)} \
49 ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-dev gstreamer1.0-plugins-base-dev", "", d)} \
50 icu-dev \
51 libxslt-dev \
52 ${@base_contains("DISTRO_FEATURES", "systemd", "systemd-dev", "udev-dev", d)} \
53 tslib-dev \
54 hunspell-dev \
55 libcap-dev \
56 wpa-supplicant-dev \
57 libmysqlclient-dev \
58 libpq-dev \
59 atk-dev \
60 libevent-dev \
61 ostree-dev \
62 ${@base_contains("DISTRO_FEATURES", "wayland", "libxkbcommon-dev libgbm-dev libdrm-dev", "", d)} \
63 ${@base_contains("DISTRO_FEATURES", "bluetooth", "${BLUEZ}-dev", "", d)} \
64 ${MACHINE_EXTRA_INSTALL_SDK} \
65 "