summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-02-27 18:02:33 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2017-03-14 18:43:47 +0000
commitac8252cb32d1293c19963dbcf5d1902f807e78bd (patch)
tree0bf292d9f8f1920f064c666870d5281a5e60687f /recipes
parent552bb9dbf53d6d3a86fe8acf66b0d393ea49b92b (diff)
downloadmeta-boot2qt-ac8252cb32d1293c19963dbcf5d1902f807e78bd.tar.gz
gnutls: add patch to fix build break with older kernels (< 3.4.17)
Add patch missing from poky morty branch to fix gnutls 3.5.3 build break with jetson-tx1 image build. Change-Id: I2c41989aef485ea9ca0b7927285c6558c2491c32 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gnutls/files/check_SYS_getrandom.patch36
-rw-r--r--recipes/gnutls/gnutls_3.%.bbappend32
2 files changed, 68 insertions, 0 deletions
diff --git a/recipes/gnutls/files/check_SYS_getrandom.patch b/recipes/gnutls/files/check_SYS_getrandom.patch
new file mode 100644
index 0000000..50693bf
--- /dev/null
+++ b/recipes/gnutls/files/check_SYS_getrandom.patch
@@ -0,0 +1,36 @@
1From f26c3979ab0325edb2e410d287bc501cf00e0ac0 Mon Sep 17 00:00:00 2001
2From: Nikos Mavrogiannopoulos <nmav@redhat.com>
3Date: Mon, 22 Aug 2016 16:32:34 +0200
4Subject: [PATCH] rnd-linux: added check for SYS_getrandom being defined
5
6This allows to compile the getrandom() code in old Linux systems
7which do not have the system call defined.
8---
9
10Upstream-Status: Backport
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12
13 lib/nettle/rnd-linux.c | 6 +++++-
14 1 file changed, 5 insertions(+), 1 deletion(-)
15
16diff --git a/lib/nettle/rnd-linux.c b/lib/nettle/rnd-linux.c
17index d7f07a6..7a24d05 100644
18--- a/lib/nettle/rnd-linux.c
19+++ b/lib/nettle/rnd-linux.c
20@@ -56,7 +56,11 @@ static dev_t _gnutls_urandom_fd_rdev = 0;
21 # else
22 # include <sys/syscall.h>
23 # undef getrandom
24-# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags)
25+# if defined(SYS_getrandom)
26+# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags)
27+# else
28+# define getrandom(dst,s,flags) -1
29+# endif
30 # endif
31
32 static unsigned have_getrandom(void)
33--
34libgit2 0.24.0
35
36
diff --git a/recipes/gnutls/gnutls_3.%.bbappend b/recipes/gnutls/gnutls_3.%.bbappend
new file mode 100644
index 0000000..8d91bb0
--- /dev/null
+++ b/recipes/gnutls/gnutls_3.%.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
31
32SRC_URI += "file://check_SYS_getrandom.patch"