summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-01 15:07:51 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-08 12:51:01 +0000
commit87e2747f0f3cd19a637314a85c9d3650bf2d9b46 (patch)
treea37c9119143d6a6750f9fb1ae5f025994468f298 /recipes
parent7fc3a7c48a1ca083dd42e643a4870b60152f3554 (diff)
downloadmeta-boot2qt-87e2747f0f3cd19a637314a85c9d3650bf2d9b46.tar.gz
weston: patch no longer relevant
Change-Id: I9ee8f90a84c6cda487362c95e11a21137ab27089 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/wayland/weston/0001-Adapt-changes-made-in-libinput-src-evdev.c-for-touch.patch65
-rw-r--r--recipes/wayland/weston_1.%.bbappend26
2 files changed, 0 insertions, 91 deletions
diff --git a/recipes/wayland/weston/0001-Adapt-changes-made-in-libinput-src-evdev.c-for-touch.patch b/recipes/wayland/weston/0001-Adapt-changes-made-in-libinput-src-evdev.c-for-touch.patch
deleted file mode 100644
index 1bb9253..0000000
--- a/recipes/wayland/weston/0001-Adapt-changes-made-in-libinput-src-evdev.c-for-touch.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1From c4633014fff25d32926129a8b028124c6338bb2b Mon Sep 17 00:00:00 2001
2From: Louai Al-Khanji <louai.al-khanji@theqtcompany.com>
3Date: Wed, 19 Aug 2015 09:04:46 +0300
4Subject: [PATCH 1/1] Adapt changes made in libinput/src/evdev.c for touch
5 frame emission.
6
7---
8 src/evdev.c | 27 +++++++++++++++++++++++++++
9 1 file changed, 27 insertions(+)
10
11diff --git a/src/evdev.c b/src/evdev.c
12index 888dfbd..daa5d72 100644
13--- a/src/evdev.c
14+++ b/src/evdev.c
15@@ -359,12 +359,36 @@ evdev_process_absolute(struct evdev_device *device,
16 }
17 }
18
19+static inline int
20+evdev_need_touch_frame(struct evdev_device *device)
21+{
22+ if (!(device->seat_caps & EVDEV_SEAT_TOUCH))
23+ return 0;
24+
25+ switch (device->pending_event) {
26+ case EVDEV_NONE:
27+ case EVDEV_RELATIVE_MOTION:
28+ break;
29+ case EVDEV_ABSOLUTE_MT_DOWN:
30+ case EVDEV_ABSOLUTE_MT_MOTION:
31+ case EVDEV_ABSOLUTE_MT_UP:
32+ case EVDEV_ABSOLUTE_TOUCH_DOWN:
33+ case EVDEV_ABSOLUTE_TOUCH_UP:
34+ case EVDEV_ABSOLUTE_MOTION:
35+ return 1;
36+ }
37+
38+ return 0;
39+}
40+
41 static void
42 fallback_process(struct evdev_dispatch *dispatch,
43 struct evdev_device *device,
44 struct input_event *event,
45 uint32_t time)
46 {
47+ int need_frame = 0;
48+
49 switch (event->type) {
50 case EV_REL:
51 evdev_process_relative(device, event, time);
52@@ -376,7 +400,10 @@ fallback_process(struct evdev_dispatch *dispatch,
53 evdev_process_key(device, event, time);
54 break;
55 case EV_SYN:
56+ need_frame = evdev_need_touch_frame(device);
57 evdev_flush_pending_event(device, time);
58+ if (need_frame)
59+ notify_touch_frame(device->seat);
60 break;
61 }
62 }
63--
642.1.4
65
diff --git a/recipes/wayland/weston_1.%.bbappend b/recipes/wayland/weston_1.%.bbappend
deleted file mode 100644
index 6e91467..0000000
--- a/recipes/wayland/weston_1.%.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI_append = " \
24file://0001-Adapt-changes-made-in-libinput-src-evdev.c-for-touch.patch \
25"
26