summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-03-21 13:03:58 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2017-03-21 13:06:39 +0200
commit160bd85916f723ecdde8b0514c8a67fdeb4dfe73 (patch)
treee6e92edead0d78aeaf5b879e5c26a90a99b98861 /recipes
parentd481b98fe28e5bbb7d5e5a73f89abed1fedf4efb (diff)
parent00b5087da9fa37ab49a29021bf4b1e405634a751 (diff)
downloadmeta-boot2qt-160bd85916f723ecdde8b0514c8a67fdeb4dfe73.tar.gz
Merge remote-tracking branch 'origin/krogoth' into dev
* origin/krogoth: AM: update revision Add appman versions of Kit and Qt to creator fonts: add recipe for GNU FreeFonts Add multiscreen automotive demo neptune: update to include fix for i18ndemo fonts: update URL for lohit font Update GammaRay to the same version as used by the QtAS 1.1 host tools emulator: correctly append qtsimulator configuration Update automotive components setup-environment: don't exit the shell on error neptune-ui: add runtime dependencies update meta-qt5 (merged upstream/master) SHA1 to manifest.xml AM: Add appman tools to automotive nativesdk configure-qtcreator: suppress unnecessary error Update GammaRay to the latest 2.7 branch Conflicts: recipes-qt/automotive/neptune-ui_git.bb recipes-qt/automotive/qtapplicationmanager_git.bb recipes-qt/qt5/qtlocation_git.bbappend scripts/manifest.xml Change-Id: I96601e7d7a1827a6631fe59d18101d2ad3b70871
Diffstat (limited to 'recipes')
-rw-r--r--recipes/fonts/ttf-devanagari_2.94.0.bb2
-rw-r--r--recipes/fonts/ttf-freefont_20120503.bb49
-rw-r--r--recipes/libyaml/libyaml_%.bbappend30
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb1
4 files changed, 81 insertions, 1 deletions
diff --git a/recipes/fonts/ttf-devanagari_2.94.0.bb b/recipes/fonts/ttf-devanagari_2.94.0.bb
index 1073096..ee0ea06 100644
--- a/recipes/fonts/ttf-devanagari_2.94.0.bb
+++ b/recipes/fonts/ttf-devanagari_2.94.0.bb
@@ -37,7 +37,7 @@ INHIBIT_DEFAULT_DEPS = "1"
37 37
38inherit allarch fontcache 38inherit allarch fontcache
39 39
40SRC_URI = "https://fedorahosted.org/releases/l/o/lohit/lohit-devanagari-ttf-${PV}.tar.gz" 40SRC_URI = "https://releases.pagure.org/lohit/lohit-devanagari-ttf-${PV}.tar.gz"
41 41
42SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8" 42SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8"
43SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353" 43SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353"
diff --git a/recipes/fonts/ttf-freefont_20120503.bb b/recipes/fonts/ttf-freefont_20120503.bb
new file mode 100644
index 0000000..abf9562
--- /dev/null
+++ b/recipes/fonts/ttf-freefont_20120503.bb
@@ -0,0 +1,49 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "GNU FreeFont is a free family of scalable outline fonts"
31HOMEPAGE = "http://savannah.gnu.org/projects/freefont"
32LICENSE = "GPLv3"
33LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
34
35require recipes-graphics/ttf-fonts/ttf.inc
36
37inherit allarch fontcache
38
39S = "${WORKDIR}/freefont-${PV}"
40
41SRC_URI = "http://ftp.gnu.org/gnu/freefont/freefont-ttf-${PV}.zip"
42
43SRC_URI[md5sum] = "879b76d2e3c8003d567b555743f39154"
44SRC_URI[sha256sum] = "7c85baf1bf82a1a1845d1322112bc6ca982221b484e3b3925022e25b5cae89af"
45
46PACKAGES = "${PN}-sans ${PN}-mono ${PN}-serif"
47FILES_${PN}-sans = "${datadir}/fonts/truetype/FreeSans*.ttf"
48FILES_${PN}-mono = "${datadir}/fonts/truetype/FreeMono*.ttf"
49FILES_${PN}-serif = "${datadir}/fonts/truetype/FreeSerif*.ttf"
diff --git a/recipes/libyaml/libyaml_%.bbappend b/recipes/libyaml/libyaml_%.bbappend
new file mode 100644
index 0000000..728a546
--- /dev/null
+++ b/recipes/libyaml/libyaml_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30BBCLASSEXTEND += "nativesdk"
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 066ba29..65f7f5e 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -44,6 +44,7 @@ RDEPENDS_${PN} = "\
44 ttf-opensans \ 44 ttf-opensans \
45 ttf-dejavu-common \ 45 ttf-dejavu-common \
46 ttf-dejavu-sans \ 46 ttf-dejavu-sans \
47 ttf-freefont-mono \
47 otf-noto \ 48 otf-noto \
48 dbus-session-init \ 49 dbus-session-init \
49 tzdata \ 50 tzdata \