summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@pelagicore.com>2018-01-19 17:13:54 +0100
committerDominik Holland <dominik.holland@pelagicore.com>2018-02-05 09:23:46 +0000
commit0c5437b2baf2a8241665a5bdfcb7dd0e88ad9f34 (patch)
tree70b0372e843521cd7cb7f98811960dcd0dbd1500 /recipes
parent765598f189f50f905627a73cfabb29acae405a9a (diff)
downloadmeta-boot2qt-0c5437b2baf2a8241665a5bdfcb7dd0e88ad9f34.tar.gz
qtivi: Fix the broken python3 binary inside an yocto SDK
QtIvi creates a virtualenv using the python3 binary from the native sysroot. This virtualenv is also used for the SDK. As it is not intended for the SDK it is using the wrong interpreter location. This workaround installs the python3 binary into the nativesdk sysroot where the qtivi nativesdk recipe can pick it up and copy it into its virtualenv. This needs to be improved in future versions and is discussed here: AUTOSUITE-176 Task-number: AUTOSUITE-179 Change-Id: Ib134231204cc8c6a56f2a93bedb553ecbcbd9123 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> Reviewed-by: Tobias Olausson <tobias.olausson@pelagicore.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/python3_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes/python/python3_%.bbappend b/recipes/python/python3_%.bbappend
index 9015f3f..b3a5eb7 100644
--- a/recipes/python/python3_%.bbappend
+++ b/recipes/python/python3_%.bbappend
@@ -1 +1,11 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch" 1SRC_URI_remove = "file://python-3.3-multilib.patch"
2
3# We need to install the python3 binary into the sysroot to let qtivi install that binary
4# into the correct location.
5# We can't install it directly into ${bindir} as this would be picked up by other recipes
6# and produce a lot of errors. Instead put it inside a qt5 folder where only qtivi picks it up
7# This is a workaround and needs to be replaced by a proper solution discussed here:
8# https://bugreports.qt.io/browse/AUTOSUITE-176
9sysroot_stage_all_append_class-nativesdk () {
10 sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}/qt5
11}