summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRainer Keller <rainer.keller@digia.com>2014-09-05 15:13:47 +0200
committerRainer Keller <rainer.keller@theqtcompany.com>2014-11-04 09:54:05 +0200
commitf309d05bccefc29977d474df734fecbe311f8f7b (patch)
tree331826a59f9f810d91c85de160e118a2b9963bf0 /recipes
parent1279b50a2c67c388617407d704b1141fa659bca9 (diff)
downloadmeta-boot2qt-f309d05bccefc29977d474df734fecbe311f8f7b.tar.gz
Add b2qt-update-framework
Change-Id: Iaefed14f1d2bfecb436c2bfa68c94ffe74672128 Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/b2qt-update-framework/b2qt-update-framework.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/b2qt-update-framework/b2qt-update-framework.bb b/recipes/b2qt-update-framework/b2qt-update-framework.bb
new file mode 100644
index 0000000..ceae95a
--- /dev/null
+++ b/recipes/b2qt-update-framework/b2qt-update-framework.bb
@@ -0,0 +1,45 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Boot to Qt update framework"
24HOMEPAGE = "http://www.qt.io"
25SECTION = "devel"
26LICENSE = "CLOSED"
27
28PV = "1.0.0"
29PR = "r0"
30SRCREV = "${PV}"
31
32inherit deploy
33
34do_deploy() {
35 install -d ${DEPLOYDIR}/update/
36 echo ${B2QT_PLATFORM} > ${DEPLOYDIR}/update/platform
37}
38
39addtask deploy after do_install before do_build
40
41do_compile[noexec] = "1"
42do_install[noexec] = "1"
43do_populate_sysroot[noexec] = "1"
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"