diff options
author | Sami Nurmenniemi <sami.nurmenniemi@qt.io> | 2017-07-07 10:25:10 +0300 |
---|---|---|
committer | Sami Nurmenniemi <sami.nurmenniemi@qt.io> | 2017-07-10 06:13:06 +0000 |
commit | 8c3a88809f88524f997f1422d66676878011f3be (patch) | |
tree | f28492d307c011ab8c3a5555f015e68d3531dcb1 /recipes | |
parent | a959d32e9309709f2f176c3151f73c5be3146686 (diff) | |
download | meta-boot2qt-8c3a88809f88524f997f1422d66676878011f3be.tar.gz |
Fix qdb connection
Connman has gadget networks disabled by default. Service qdbd creates
usb0 gadget connection. This results in race condition where usb0
disappears if connman is started late enough after qdbd. Fix is to
enable gadget networks for connman so it doesn't force it off.
Task-number: QTBUG-61718
Change-Id: I896b537bcfb03a1b92960166f0579a58ba6a2d6f
Reviewed-by: Kari Oikarinen <kari.oikarinen@qt.io>
Diffstat (limited to 'recipes')
-rw-r--r-- | recipes/connman-conf/connman-conf.bbappend | 42 | ||||
-rw-r--r-- | recipes/connman-conf/connman-conf/settings | 5 |
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes/connman-conf/connman-conf.bbappend b/recipes/connman-conf/connman-conf.bbappend new file mode 100644 index 0000000..06dc61d --- /dev/null +++ b/recipes/connman-conf/connman-conf.bbappend | |||
@@ -0,0 +1,42 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | |||
32 | CONNMAN_SETTINGS_DIR := "${localstatedir}/lib/connman" | ||
33 | |||
34 | FILES_${PN} += "${CONNMAN_SETTINGS_DIR}/settings" | ||
35 | |||
36 | SRC_URI += "file://settings \ | ||
37 | " | ||
38 | |||
39 | do_install_append() { | ||
40 | install -d ${D}/${CONNMAN_SETTINGS_DIR} | ||
41 | install -m 0644 ${WORKDIR}/settings ${D}/${CONNMAN_SETTINGS_DIR}/settings | ||
42 | } | ||
diff --git a/recipes/connman-conf/connman-conf/settings b/recipes/connman-conf/connman-conf/settings new file mode 100644 index 0000000..edfedd4 --- /dev/null +++ b/recipes/connman-conf/connman-conf/settings | |||
@@ -0,0 +1,5 @@ | |||
1 | [global] | ||
2 | OfflineMode=false | ||
3 | |||
4 | [Gadget] | ||
5 | Enable=true | ||