summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authoraavit <eirik.aavitsland@digia.com>2014-09-26 10:17:00 +0200
committerEirik Aavitsland <eirik.aavitsland@digia.com>2014-11-10 12:11:58 +0200
commit59f1923832b301df6743ed3fa0b92556aa68ffbd (patch)
tree4fb21fc0523696ba2a5ca96638e51afd7feeedb7 /recipes
parentf309d05bccefc29977d474df734fecbe311f8f7b (diff)
downloadmeta-boot2qt-59f1923832b301df6743ed3fa0b92556aa68ffbd.tar.gz
Add Silica ArchiTech tibidabo board
Builds & runs ok! The current implementation is done with the strategy of using the vendor's defined repo versions for the yocto stack, instead of the common versions defined by b2qt. The intention is to build upon the vendor stack as closely as possible, as that is (hopefully) tested and maintained. Task-number: QTEE-801 Change-Id: Ib93b54178de870b5f288b2fae982ea2b4bb74e50 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces37
-rw-r--r--recipes/wayland/wayland_1.%.bbappend (renamed from recipes/wayland/wayland_1.4.0.bbappend)0
-rw-r--r--recipes/x264/x264_git.bbappend25
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces b/recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces
new file mode 100644
index 0000000..cb45575
--- /dev/null
+++ b/recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces
@@ -0,0 +1,37 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19iface eth1 inet dhcp
20
21auto pt0
22iface pt0 inet dhcp
23 hostname `/bin/hostname`
24auto pt1
25iface pt1 inet dhcp
26 hostname `/bin/hostname`
27
28# Ethernet/RNDIS gadget (g_ether)
29# ... or on host side, usbnet and random hwaddr
30iface usb0 inet static
31 address 192.168.7.2
32 netmask 255.255.255.0
33 network 192.168.7.0
34 gateway 192.168.7.1
35
36# Bluetooth networking
37iface bnep0 inet dhcp
diff --git a/recipes/wayland/wayland_1.4.0.bbappend b/recipes/wayland/wayland_1.%.bbappend
index 1c67f60..1c67f60 100644
--- a/recipes/wayland/wayland_1.4.0.bbappend
+++ b/recipes/wayland/wayland_1.%.bbappend
diff --git a/recipes/x264/x264_git.bbappend b/recipes/x264/x264_git.bbappend
new file mode 100644
index 0000000..ccbbbd1
--- /dev/null
+++ b/recipes/x264/x264_git.bbappend
@@ -0,0 +1,25 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# Workaround: at the sha version defined by tibidabo, the x264 recipe
24# defines a nonexisting SRCREV sha.
25SRCREV_tibidabo = "ffc3ad4945da69f3caa2b40e4eed715a9a8d9526"