summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-04 13:00:01 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-17 09:22:53 +0300
commit2562bbbe0a0def38ec07fc28bff85d4a2c8b7d3e (patch)
treeaee655d437c866b9743401eb05de9974cc7bb7a4 /recipes
parent53825398ac8fe6dbf4b55b0cdb571cdffb4c0634 (diff)
downloadmeta-boot2qt-2562bbbe0a0def38ec07fc28bff85d4a2c8b7d3e.tar.gz
remove unneeded kernel image from rootfs
No need for the kernel image to be in rootfs (/boot/) as it's used from the boot partition. Task-number: QTEE-749 Change-Id: Ic5e53e25d896bba807c8e098c1fd50208b646034 Reviewed-by: Rainer Keller <rainer.keller@digia.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-boundary_3.10.17.bbappend2
-rw-r--r--recipes/linux/linux-imx_3.10.17.bbappend3
-rw-r--r--recipes/linux/linux-toradex-fsl_git.bbappend3
3 files changed, 8 insertions, 0 deletions
diff --git a/recipes/linux/linux-boundary_3.10.17.bbappend b/recipes/linux/linux-boundary_3.10.17.bbappend
index ae59272..da33ff5 100644
--- a/recipes/linux/linux-boundary_3.10.17.bbappend
+++ b/recipes/linux/linux-boundary_3.10.17.bbappend
@@ -20,6 +20,8 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
23 25
24do_configure_prepend() { 26do_configure_prepend() {
25 # Use multitouch protocol for touchscreen that support it 27 # Use multitouch protocol for touchscreen that support it
diff --git a/recipes/linux/linux-imx_3.10.17.bbappend b/recipes/linux/linux-imx_3.10.17.bbappend
index 082c431..df01b62 100644
--- a/recipes/linux/linux-imx_3.10.17.bbappend
+++ b/recipes/linux/linux-imx_3.10.17.bbappend
@@ -20,6 +20,9 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
25
23do_configure_prepend() { 26do_configure_prepend() {
24 # FunctionFS for adb 27 # FunctionFS for adb
25 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig 28 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
diff --git a/recipes/linux/linux-toradex-fsl_git.bbappend b/recipes/linux/linux-toradex-fsl_git.bbappend
index adee8c4..0bcbad7 100644
--- a/recipes/linux/linux-toradex-fsl_git.bbappend
+++ b/recipes/linux/linux-toradex-fsl_git.bbappend
@@ -20,6 +20,9 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
25
23config_script () { 26config_script () {
24 # FunctionFS for adb 27 # FunctionFS for adb
25 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config 28 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config