summaryrefslogtreecommitdiffstats
path: root/recipes/virtualbox/virtualbox-guest-additions_4.3.30.bb
diff options
context:
space:
mode:
authorRainer Keller <rainer.keller@theqtcompany.com>2015-07-15 14:30:51 +0200
committerRainer Keller <rainer.keller@theqtcompany.com>2015-08-12 13:50:57 +0000
commit0fe5a62bd4c557e245128d4671b1f5af7dd6b4b1 (patch)
treefeb41717b4ee0c638c3c0958e58c488f86e10299 /recipes/virtualbox/virtualbox-guest-additions_4.3.30.bb
parent62e8fadcaa3ec57c442779bf523d25313c9b1f2c (diff)
downloadmeta-boot2qt-0fe5a62bd4c557e245128d4671b1f5af7dd6b4b1.tar.gz
Update VirtualBox kernel modules
Modules needed to be updated in order to build with newer kernels. Change-Id: I113b0831aebfeac3818837ed557ae5ae2bf072e1 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'recipes/virtualbox/virtualbox-guest-additions_4.3.30.bb')
-rw-r--r--recipes/virtualbox/virtualbox-guest-additions_4.3.30.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes/virtualbox/virtualbox-guest-additions_4.3.30.bb b/recipes/virtualbox/virtualbox-guest-additions_4.3.30.bb
new file mode 100644
index 0000000..43af064
--- /dev/null
+++ b/recipes/virtualbox/virtualbox-guest-additions_4.3.30.bb
@@ -0,0 +1,55 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Kernel drivers for the VirtualBox guest additions"
24LICENSE = "GPLv2"
25LIC_FILES_CHKSUM = "file://${WORKDIR}/VirtualBox-${PV}/COPYING;md5=e197d5641bb35b29d46ca8c4bf7f2660"
26
27inherit module
28
29MACHINE_KERNEL_PR_append = "a"
30PR = "${MACHINE_KERNEL_PR}"
31
32SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2"
33
34SRC_URI[md5sum] = "cc053340f88922a11ad9d4fab56557bd"
35SRC_URI[sha256sum] = "ea9569ec16cd6202ee61bcadb2506d31ac12fd343adb91565773a05eaaea9a36"
36
37S = "${WORKDIR}/vbox"
38
39export KERN_DIR="${STAGING_KERNEL_DIR}"
40export KBUILD_VERBOSE="1"
41export BUILD_TARGET_ARCH="${ARCH}"
42
43do_compile_prepend() {
44 ${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/export_modules ${WORKDIR}/vbox.tar.gz
45 tar xf ${WORKDIR}/vbox.tar.gz -C ${WORKDIR}/vbox
46}
47
48do_install() {
49 install -m 0755 -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
50 install -m 0644 vboxsf.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
51 install -m 0644 vboxguest.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
52 install -m 0644 vboxvideo.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
53}
54
55PKG_${PN} = "kernel-module-vbox"