summaryrefslogtreecommitdiffstats
path: root/recipes/v86d
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-04 08:09:33 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-07 09:39:34 +0000
commitf55d896454ac93aa4de17c334a46a37683e61048 (patch)
treea08ffa13407f405a87bfe5d9f12c32d72e128055 /recipes/v86d
parent85e2dbf78e6ba044fea744367f16ccd1808c1810 (diff)
downloadmeta-boot2qt-f55d896454ac93aa4de17c334a46a37683e61048.tar.gz
emulator: change resolution when using systemd
Change-Id: I8b6015c3017ece38a296288f804deffff4fd2e6f Reviewed-by: Rainer Keller <rainer.keller@theqtcompany.com>
Diffstat (limited to 'recipes/v86d')
-rw-r--r--recipes/v86d/v86d/uvesafb.options.conf1
-rw-r--r--recipes/v86d/v86d_0.1.10.bbappend10
2 files changed, 10 insertions, 1 deletions
diff --git a/recipes/v86d/v86d/uvesafb.options.conf b/recipes/v86d/v86d/uvesafb.options.conf
new file mode 100644
index 0000000..7d0dc96
--- /dev/null
+++ b/recipes/v86d/v86d/uvesafb.options.conf
@@ -0,0 +1 @@
options uvesafb mode_option=800x600-32 mtrr=3 scroll=ywrap
diff --git a/recipes/v86d/v86d_0.1.10.bbappend b/recipes/v86d/v86d_0.1.10.bbappend
index c438912..9d5dfe1 100644
--- a/recipes/v86d/v86d_0.1.10.bbappend
+++ b/recipes/v86d/v86d_0.1.10.bbappend
@@ -20,5 +20,13 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23COMPATIBLE_MACHINE = "(qemux86|emulator)"
24FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24
25SRC_URI += "file://uvesafb.options.conf"
26
27do_install_append() {
28 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
29 install -d ${D}${sysconfdir}/modprobe.d
30 install -m 0644 ${WORKDIR}/uvesafb.options.conf ${D}${sysconfdir}/modprobe.d/uvesafb.conf
31 fi
32}