summaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-03-09 10:43:20 +0000
committerThe Qt Project <gerrit-noreply@qt-project.org>2018-03-09 10:59:10 +0000
commitd9985542d7617b43ec7180c7ade0c4f64db82b42 (patch)
tree6c95ea16b72a2330bb696a6380ec221402379b1d /recipes/python
parentfd03fa6e8395ae814d0d588cab1cb6f51befa6c1 (diff)
parentcb9fe99a41d6e0855cb6a7d5febc903b42c52d28 (diff)
downloadmeta-boot2qt-d9985542d7617b43ec7180c7ade0c4f64db82b42.tar.gz
Merge "Merge remote-tracking branch 'origin/morty' into pyro" into refs/staging/pyro
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python3_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes/python/python3_%.bbappend b/recipes/python/python3_%.bbappend
index 9015f3f..b3a5eb7 100644
--- a/recipes/python/python3_%.bbappend
+++ b/recipes/python/python3_%.bbappend
@@ -1 +1,11 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch" 1SRC_URI_remove = "file://python-3.3-multilib.patch"
2
3# We need to install the python3 binary into the sysroot to let qtivi install that binary
4# into the correct location.
5# We can't install it directly into ${bindir} as this would be picked up by other recipes
6# and produce a lot of errors. Instead put it inside a qt5 folder where only qtivi picks it up
7# This is a workaround and needs to be replaced by a proper solution discussed here:
8# https://bugreports.qt.io/browse/AUTOSUITE-176
9sysroot_stage_all_append_class-nativesdk () {
10 sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}/qt5
11}