summaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@pelagicore.com>2017-07-14 11:21:59 +0200
committerDominik Holland <dominik.holland@pelagicore.com>2017-07-18 20:07:23 +0000
commitab097355d593244bf0b5ea5a62ee7b04d1a0a5a3 (patch)
tree2207838fe5ef951263eae56dbdab683903ddb012 /recipes/python
parente9a9002eac0e6d667826c18cb6f0d96e536eacd0 (diff)
downloadmeta-boot2qt-ab097355d593244bf0b5ea5a62ee7b04d1a0a5a3.tar.gz
python3-virtualenv: Add a recipe for python3-virtualenv
The recipe also supports native and nativsdk builds Change-Id: Iab2b66b7969a1ca7f444eece2f7a74ed3760364b Reviewed-by: Gordan Markus <gordan.markus@pelagicore.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python3-virtualenv.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/python/python3-virtualenv.bb b/recipes/python/python3-virtualenv.bb
new file mode 100644
index 0000000..cc091b8
--- /dev/null
+++ b/recipes/python/python3-virtualenv.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Virtual Python Environment builder"
2HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51910050bd6ad04a50033f3e15d6ce43"
6
7PV="15.1.0"
8SRC_URI = "https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-15.1.0.tar.gz"
9
10SRC_URI[md5sum] = "44e19f4134906fe2d75124427dc9b716"
11SRC_URI[sha256sum] = "02f8102c2436bb03b3ee6dede1919d1dac8a427541652e5ec95171ec8adbc93a"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/virtualenv/"
14UPSTREAM_CHECK_REGEX = "/virtualenv/(?P<pver>(\d+[\.\-_]*)+)"
15
16S = "${WORKDIR}/virtualenv-${PV}"
17
18BBCLASSEXTEND = "native nativesdk"
19
20inherit setuptools3
21