summaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /recipes/python
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/nativesdk-prebuild-python.inc53
-rw-r--r--recipes/python/nativesdk-prebuild-python_i686.bb42
-rw-r--r--recipes/python/nativesdk-prebuild-python_x86_64.bb42
-rw-r--r--recipes/python/python3-native_%.bbappend1
-rw-r--r--recipes/python/python3-virtualenv.bb21
-rw-r--r--recipes/python/python3_%.bbappend11
6 files changed, 0 insertions, 170 deletions
diff --git a/recipes/python/nativesdk-prebuild-python.inc b/recipes/python/nativesdk-prebuild-python.inc
deleted file mode 100644
index 3d8c083..0000000
--- a/recipes/python/nativesdk-prebuild-python.inc
+++ /dev/null
@@ -1,53 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "PSFv2"
31
32LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4b8a9367e6bb2acb6f26dc08654f6ee5"
33
34do_unpack[depends] += "p7zip-native:do_populate_sysroot"
35
36inherit bin_package nativesdk python3-dir
37
38PV = "3.5.2"
39
40S = "${WORKDIR}"
41
42do_install() {
43 install -d ${D}${includedir}/${PYTHON_DIR}
44 install -m 0644 ${S}/include/* ${D}${includedir}/${PYTHON_DIR}
45
46 install -d ${D}${libdir}
47 install -m 0644 ${S}/libs/*.a ${D}${libdir}
48
49 install -d ${D}${bindir}
50 install -m 0644 ${S}/python.exe ${D}${bindir}
51 install -m 0644 ${S}/python35.dll ${D}${bindir}
52 install -m 0644 ${S}/python35.zip ${D}${bindir}
53}
diff --git a/recipes/python/nativesdk-prebuild-python_i686.bb b/recipes/python/nativesdk-prebuild-python_i686.bb
deleted file mode 100644
index 2ff4f76..0000000
--- a/recipes/python/nativesdk-prebuild-python_i686.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30require nativesdk-prebuild-python.inc
31
32COMPATIBLE_HOST = "i686.*-mingw.*"
33
34SRC_URI = "\
35 https://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z \
36 https://www.python.org/ftp/python/${PV}/python-${PV}-embed-win32.zip;name=bin \
37 "
38
39SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f"
40SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2"
41SRC_URI[bin.md5sum] = "ad637a1db7cf91e344318d55c94ad3ca"
42SRC_URI[bin.sha256sum] = "75f05800fbe4a8cd6672b268ca53244838684561e03c60c668a7dccb050eb954"
diff --git a/recipes/python/nativesdk-prebuild-python_x86_64.bb b/recipes/python/nativesdk-prebuild-python_x86_64.bb
deleted file mode 100644
index 8e69fbd..0000000
--- a/recipes/python/nativesdk-prebuild-python_x86_64.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30require nativesdk-prebuild-python.inc
31
32COMPATIBLE_HOST = "x86_64.*-mingw.*"
33
34SRC_URI = "\
35 https://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z \
36 https://www.python.org/ftp/python/${PV}/python-${PV}-embed-amd64.zip;name=bin \
37 "
38
39SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f"
40SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124"
41SRC_URI[bin.md5sum] = "f1c24bb78bd6dd792a73d5ebfbd3b20e"
42SRC_URI[bin.sha256sum] = "faefbd98f61c0d87c5683eeb526ae4d4a9ddc369bef27870cfe1c8939329d066"
diff --git a/recipes/python/python3-native_%.bbappend b/recipes/python/python3-native_%.bbappend
deleted file mode 100644
index 9015f3f..0000000
--- a/recipes/python/python3-native_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch"
diff --git a/recipes/python/python3-virtualenv.bb b/recipes/python/python3-virtualenv.bb
deleted file mode 100644
index cc091b8..0000000
--- a/recipes/python/python3-virtualenv.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1SUMMARY = "Virtual Python Environment builder"
2HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51910050bd6ad04a50033f3e15d6ce43"
6
7PV="15.1.0"
8SRC_URI = "https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-15.1.0.tar.gz"
9
10SRC_URI[md5sum] = "44e19f4134906fe2d75124427dc9b716"
11SRC_URI[sha256sum] = "02f8102c2436bb03b3ee6dede1919d1dac8a427541652e5ec95171ec8adbc93a"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/virtualenv/"
14UPSTREAM_CHECK_REGEX = "/virtualenv/(?P<pver>(\d+[\.\-_]*)+)"
15
16S = "${WORKDIR}/virtualenv-${PV}"
17
18BBCLASSEXTEND = "native nativesdk"
19
20inherit setuptools3
21
diff --git a/recipes/python/python3_%.bbappend b/recipes/python/python3_%.bbappend
deleted file mode 100644
index b3a5eb7..0000000
--- a/recipes/python/python3_%.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch"
2
3# We need to install the python3 binary into the sysroot to let qtivi install that binary
4# into the correct location.
5# We can't install it directly into ${bindir} as this would be picked up by other recipes
6# and produce a lot of errors. Instead put it inside a qt5 folder where only qtivi picks it up
7# This is a workaround and needs to be replaced by a proper solution discussed here:
8# https://bugreports.qt.io/browse/AUTOSUITE-176
9sysroot_stage_all_append_class-nativesdk () {
10 sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}/qt5
11}