summaryrefslogtreecommitdiffstats
path: root/recipes/packagegroup
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-03 14:58:59 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-04 09:30:16 +0000
commit36022b22424f26a8b157046ee9692208d0394069 (patch)
tree04fea5e239ae6270a332b4c87eb358d56d06764d /recipes/packagegroup
parent1ee4cd208f7283c3c932b8fa4f94f2de27116ac1 (diff)
downloadmeta-boot2qt-36022b22424f26a8b157046ee9692208d0394069.tar.gz
perl: include perl modules
If perl is used from the SDK, it also needs modules. Use python magic to separate packages that cannot be installed to mingw32 toolchain. Change-Id: I9190cea1f00a166cc2f9119f2d4ad29c00347e19 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes/packagegroup')
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb21
1 files changed, 12 insertions, 9 deletions
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index 96fb10b..9a89baf 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -26,12 +26,22 @@ LICENSE = "CLOSED"
26 26
27inherit nativesdk packagegroup 27inherit nativesdk packagegroup
28 28
29python __anonymous() {
30 overrides = d.getVar("OVERRIDES", True).split(":")
31 if "mingw32" not in overrides:
32 d.appendVar("OVERRIDES", ":linux")
33}
34
29RDEPENDS_${PN} = "\ 35RDEPENDS_${PN} = "\
36 nativesdk-gperf \
37 ${MACHINE_EXTRA_INSTALL_SDK_HOST} \
38 "
39
40RDEPENDS_${PN}_append_linux = "\
30 nativesdk-python-modules \ 41 nativesdk-python-modules \
31 nativesdk-python-misc \ 42 nativesdk-python-misc \
32 nativesdk-gperf \ 43 nativesdk-perl-modules \
33 ${@base_contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland", "", d)} \ 44 ${@base_contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland", "", d)} \
34 ${MACHINE_EXTRA_INSTALL_SDK_HOST} \
35 " 45 "
36 46
37RDEPENDS_${PN}_append_mingw32 = "\ 47RDEPENDS_${PN}_append_mingw32 = "\
@@ -39,10 +49,3 @@ RDEPENDS_${PN}_append_mingw32 = "\
39 nativesdk-libgcc \ 49 nativesdk-libgcc \
40 nativesdk-libstdc++ \ 50 nativesdk-libstdc++ \
41 " 51 "
42
43RDEPENDS_${PN}_remove_mingw32 = "\
44 nativesdk-wayland \
45 nativesdk-ostree \
46 nativesdk-python-modules \
47 nativesdk-python-misc \
48 "