summaryrefslogtreecommitdiffstats
path: root/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-03-04 11:58:10 +0200
committerSamuli Piippo <samuli.piippo@digia.com>2014-03-13 12:54:29 +0200
commit0975201e0a0e09ec878b210aa461949a3da9c32e (patch)
tree7f2ea59dcd83d6ad2c2a6a2bc26686724990558e /recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
parent4157f4331347813136b6f4276f11ddd917903733 (diff)
downloadmeta-boot2qt-0975201e0a0e09ec878b210aa461949a3da9c32e.tar.gz
use package groups for image content
Move installed packages from image recipe to separate package group recipes Change-Id: I0417953da4bc92438b3201b38b43f6d1784f1f17 Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
Diffstat (limited to 'recipes/packagegroup/packagegroup-b2qt-embedded-base.bb')
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
new file mode 100644
index 0000000..f518430
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -0,0 +1,48 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 kernel-modules \
31 adbd \
32 psplash \
33 openssh-sftp-server \
34 openssl \
35 libpng \
36 jpeg \
37 tiff \
38 libxslt \
39 icu \
40 freetype \
41 fontconfig \
42 liberation-fonts \
43 tslib \
44 tslib-calibrate \
45 alsa-utils-amixer \
46 hunspell \
47 ${MACHINE_EXTRA_INSTALL} \
48 "