summaryrefslogtreecommitdiffstats
path: root/recipes/ostree
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-08-21 09:43:45 +0200
committerGatis Paeglis <gatis.paeglis@digia.com>2015-09-25 09:45:39 +0000
commita3f443f1d7c721aa1df61e18da97276992e51665 (patch)
tree5b8296850f2437f22aa10b5f7fa27fd48ce8d1af /recipes/ostree
parent78ab1293ea81034fa60571074ca38b2133354d36 (diff)
downloadmeta-boot2qt-a3f443f1d7c721aa1df61e18da97276992e51665.tar.gz
Add ostree, dracut and libgsystem recipes.
Change-Id: I8fc3b7ec5f2ebeb82e31638037a2dd2e449da48c Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'recipes/ostree')
-rw-r--r--recipes/ostree/ostree.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
new file mode 100644
index 0000000..1ba1504
--- /dev/null
+++ b/recipes/ostree/ostree.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees."
24
25LICENSE = "LGPL-2.1"
26LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
27
28inherit autotools pkgconfig
29
30SRC_URI = "git://github.com/GNOME/ostree.git;tag=v2015.7"
31S = "${WORKDIR}/git"
32
33DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz"
34
35EXTRA_OECONF = "--with-dracut --without-selinux --without-libarchive --with-grub2=no --enable-gtk-doc-html=no"
36
37do_configure_prepend() {
38 cd ${S}
39 # Update submodules and workaround bugs.
40 env NOCONFIGURE=1 ./autogen.sh
41 cd -
42}
43
44do_install_append() {
45 # Silence installed-vs-shipped error message. We provide our own dracut module.
46 # The only way to force OSTree to build necessary binaries is to pass "--with-dracut",
47 # this of course is a broken configure.ac logic.
48 rm -rf ${D}${libdir}/dracut/
49}