summaryrefslogtreecommitdiffstats
path: root/recipes/ostree
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-12-07 14:08:34 +0100
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-12-08 16:02:58 +0000
commit9fd94853105aaf0670f0f94386d9a30a6876f115 (patch)
treeec08717fd78dbba5275b167abcc29c631a2ce20a /recipes/ostree
parente32de981c7fdfc48c8867c04e8fda3c0fc85209c (diff)
downloadmeta-boot2qt-9fd94853105aaf0670f0f94386d9a30a6876f115.tar.gz
ostree: deploy dracut module
This is required for ostree boot compatible initramfs image generation on systemd enabled images. Also there is no harm to deploy this module-setup.sh script on a systemd-less images. We overwrite it when deploying our custom dracut module in this case. Change-Id: I8142cfa36db663782ac0399c30bc08cf5bdcd8b2 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'recipes/ostree')
-rw-r--r--recipes/ostree/ostree.bb10
1 files changed, 2 insertions, 8 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index 49060b6..8dac8a5 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -45,7 +45,8 @@ PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '',
45PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,," 45PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
46 46
47SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 47SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
48FILES_${PN} += "${systemd_unitdir}/system/" 48FILES_${PN} += "${systemd_unitdir}/system/ \
49 ${libdir}/dracut/"
49 50
50EXTRA_OECONF = "--with-dracut \ 51EXTRA_OECONF = "--with-dracut \
51 --without-selinux \ 52 --without-selinux \
@@ -61,10 +62,3 @@ do_configure_prepend() {
61 env NOCONFIGURE=1 ./autogen.sh 62 env NOCONFIGURE=1 ./autogen.sh
62 cd - 63 cd -
63} 64}
64
65do_install_append() {
66 # Silence installed-vs-shipped error message. We provide our own dracut module.
67 # The only way to force OSTree to build necessary binaries is to pass "--with-dracut",
68 # this of course is a broken configure.ac logic.
69 rm -rf ${D}${libdir}/dracut/
70}